Jump to content
funtoo forums
  • 0
Sign in to follow this  
johnwiki

Getting started again for old time Gentoo user - Steam NVIDIA etc.

Question

Hi all,

I've recently gained an interest in using Linux as a desktop OS again, and I want to have some fun with Funtoo.

I must say I have fond memories of Gentoo back in the early days (circa 2004), when Daniel Robbins' articles actually got me started on how to learn Linux.

I'm going to attempt to install Funtoo on a spare SSD on a 4790K haswell with a GTX 1060 6GB.

Are there any good guides for the following?
-Dual boot with two seperate ssds, UEFI? (i.e. windows on one - and Funtoo on the other)
-NVIDIA proprietary vs open source drivers
-How to setup my profile (i.e. make.conf seems to be deprecated) with KDE (I was thinking of trying KDE out- since I haven't touched it in forever).
-On that note, do you need a specific desktop environment to run steam?
(I saw Mr. Robbins had a quick 1 min. steam video.  Any idea how to get that working?  (or should i just wait for 1.4?- as there seems to be some strange 32 bit dependencies - cmon Valve!)

 

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi John,

You don't seem to be getting any traction from anyone else so I thought I'd try to give you some pointers. I was in pretty much the same boat as you until a month ago - though I have previously trial installed gentoo/funtoo a couple of times since the 2000's

Dual booting: I haven't had much luck with the automated boot update being able to chainload windows on my desktop (separate boot disks for window/funtoo) or my laptop (single disk). I haven't had time to investigate what's going wrong so I'm using the EFI BIOS to select the required boot rather than grub.

If you want to play games on your 1060, use the proprietary drivers. This requirement appears to be linked to how you can run steam - see below.

make.conf hasn't been deprecated (or I missed that memo). I still use it for global USE flags, MAKEOPTS, LINGUAS, L10N, VIDEO_CARDS... emerge does a good job of auto updating the /etc/portage/package.* files for package specific stuff (you need to do 'etc-update' and re-run emerge though).

KDE is my old favourite DE and I'm using it again now. When trying to setup your session manager use sddm and logind - I went down a route that didn't appear to be working using some older docs, but the setup instructions for sddm/logind worked for me.

Steam has to be run in some sort of container to get it's 32bit library support requirements met. DR is working on funtoo 1.4 which will allow steam to work in an LXD container, but for now there are instructions on the net for running steam from a flatpak container (I can't remember which container). Worked first time for me using X11, nvidia - just remember to look for some update instructions which have to be run within the container to get the nvidia drivers into it. It takes a little while for steam to startup but once running it's fine. Apparently the drivers inside and outside the container must match.

I'll try to find the specific links to the instructions I used for some of the above when I get time at work.

One other thing... I keep coming across docs (possibly just the one document multiple times) telling me to do an 'emerge sync' to update package lists (needless to say I cannot find it now I want to). You need to be doing 'ego sync' to update packages.

Share this post


Link to post
Share on other sites
  • 0

Steam flatpak installation and FAQ links. Change the apt commands to emerge equivalents and make sure you do the "flatpak update" mentioned in the first FAQ answer.

https://www.omgubuntu.co.uk/2017/06/steam-now-available-flatpak

https://github.com/flathub/com.valvesoftware.Steam/wiki/Frequently-asked-questions

KDE setup... https://www.funtoo.org/KDE_Plasma_5

logind above should have read 'elogind'. I seem to remember there being 2 plasma 5 mix-ins to choose from - swapping between the 2 had no effect at all with regards to altering emerge'd packages, so choose whichever.

 

good luck

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply.

I haven't went down the steam route yet, but, I did get an install working with KDE plasma 5.

I can still boot windows with the UEFI boot menu, I just had to disable secure boot.

I haven't bothered to try and make grub look for windows, or to enable secure boot for funtoo.  It takes me all of 5 seconds to go into the menu and boot whichever one I want.

I may wait until 1.4 for the steam stuff anyway, since I have steam in windows

It appears lxd benefits heavily from btrfs and zfs, which I don't think I have a good way of running unless I create a loop device over xfs, as I ended up keeping a super simple partition layout (boot, swap, root), and I'm out of spare disks at the moment.

Share this post


Link to post
Share on other sites
  • 0

Hi i just install Funtoo pretty much like your specs.

I got a lenovo y700 laptop.

M.2 with windows, and a SSD with funtoo.

I use grub uefi and from there i choose between Windows or Funtoo.

Got the Nvidia 960M

Installed KDE.

Grub was easy to install just following the instructions, just a little resarch to integrate Windows.

KDE is a little bit tricky the lock screen doesnt let me get back to my session but whit a chmod get working fine.

The pain is the Nvidia, the y700 works with an hybrid graphics intel and nvidia and i cant make them work properly.

Actualy if i choose OpenGL nvidia instead of xorg, sddm doesnt take me to my Desktop, don't know why i am working on it...

Saludos...

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...