Jump to content
  • 0
Sign in to follow this  
synteejol

can't install steam

Question

 

I was trying to install steam but I obtain some errors.
Using layman and
anyc's Steam repository I obtain this is the error:

!!! All ebuilds that could satisfy ">=sys-devel/gcc-4.6.0[multilib]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/gcc-8.2.1-r5::core-kit (masked by: missing keyword)

(dependency required by "games-util/steam-launcher-1.0.0.59-r3::steam-overlay[amd64]" [ebuild])
(dependency required by "games-util/steam-launcher" [argument])

I also tried to download steam from repo.steampowered.com extract files and run ./steam and got this error:

 

Couldn't find dpkg, please update steamdeps for your distribution.
Running Steam on funtoo intel64-ivybridge-2019-05-08 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/carmelo/.local/share/Steam/steam.sh: line 828: /home/carmelo/.local/share/Steam/ubuntu12_32/steam-runtime/run.sh: No such file or directory
Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
/home/carmelo/.local/share/Steam/steam.sh: line 888: /home/carmelo/.local/share/Steam/ubuntu12_32/steam: No such file or directory

 

I followed this wiki https://wiki.gentoo.org/wiki/Steam. Since package.use is a file I added the lines in the wiki in this file instead of create /etc/portage/package.use/steam

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I solve a porblem but here is another problem when I do emerge --ask games-util/steam-launcher
 

emerge: there are no ebuilds to satisfy ">=sys-devel/gcc-4.6.0[multilib]
(dependency required by "games-util/steam-launcher-1.0.0.59-r3::steam-overlay[amd64]" [ebuild])
(dependency required by "games-util/steam-launcher" [argument])

I can-t figure out how to solve, pls help me if u can

Share this post


Link to post
Share on other sites
  • 0

I think you are fighting a lost cause trying to install Steam in the 1.3 release of Funtoo.  A simple search of the forums and/or Google will reveal that Steam requires 32-bit libraries and Funtoo 1.3 has dropped 32-bit support. 

I know it's not the answer you want but this is Funtoo for now.  Perhaps you can do what others have done and use flatpak, but I don't know anything about that besides it's name.

Share this post


Link to post
Share on other sites
  • 0

Thank you lazlo.vii,  yours was the best answer I could receive. I thought I could install it because in bentoo steam is present present and works fine. Some time ago I saw a video of someone playing dota2 on funtoo. I wanted to do the same. As you guessed I know nothing about flatpak beside it's name. I'll be read something about it. Thank you again.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...