Jump to content
  • 0
bekkra

emerge gnome fails due to webkit-gtk and app-arch/pax failure

Question

Hi,

 

I am trying to emerge gnome(3).

The first problem I have found is the app-arch/pax package, which fails to link.

The linking problem steems from macros in lib/fts.h, where some functions are renamed, which leads to link error.

 

This can be fixed, so I continued and failed at webkit-gtk, which fails because the package can not be found in any download locations that the ebuild tries.

 

I have two requests:

 

1) Please point me to a working download of webkit-gtk

 

2) Please point me to the instructions on how to fix ebuild errors so that they are shareable with the community.

 

/bekkra

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Right-I update my own post. According to the webkit-gtk site, the discovered non-free packages forced them to re-release somevof them with the offending content removed. The patched binaries get an 'a' added to their version number.

 

In my case, this means webkitgtk-2.4.4a.tar.xz which downloads and builds without problems. Maybe a patched ebuild is a good solution?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...