Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

[SOLVED] Mesa installation issues



I ended up switching to 1.3.  Had several new issues, mainly due to old libraries that were still lying around,  but got around all of those and this one did not reappear, so I am marking this solved.


My apologies if this has been discussed or I am being obtuse.  I am trying to install Mesa 17.2.8, but it fails because I have LLVM 6 installed.  It tries to use flags.setUnsafeAlgebra, which is replaced with flags.setFast in LLVM6, based on my reading.  There is a patch to resolve this issue, by checking for LLVM 6 and using the proper flag, in that case.  I applied it manually and managed to compile and install Mesa manually.  I feel at one time I could tell Portage, etc, that I provided my own package for something, but I am not sure if that is the best path forward here.  Certainly I can take the time to learn how to add patches to my own version of the ebuild, but I am not sure it is knowledge that I am going to use again or anytime soon.  At least I hope this is not something I will have to do a lot.  I am on Release 1.2, though if the easier fix is to get a newer mesa by going to 1.3, I am game.  Time is scarce, so I was hoping to avoid a lot of issues.

Can I get a newer version of Mesa on 1.2?  I saw someone that grabbed a Gentoo ebuild and I can go that route, I would like an updated Mesa.

Am I wrongly assuming the amount of work for rolling my own ebuild, with patch?

Link to discussion on patch:



I am not at the machine and overlooked giving my non-root account sudo access, so I am limited in what logs or info I can supply right now, but later today I will update this with whatever is requested, if that will help answer my question.  Thanks in advance.

Edited by gigabot3457
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Thanks for your response.  That probably would bypass the issue.  Is 1.3 stable?


I upgraded my processor to a 2nd Gen Ryzen and my existing kernel blew up, caused the machine to reboot rather early in the boot.  I started to go down the path of 1.3 over my existing install, most likely unnecessarily, and was having a lot of issues, so I dropped back to 1.2.  Of course I am not sure if it was because the recommended rescue CD had a kernel from 2016, but it was late at night, I saw signs of multilib issues, possibly from libraries laying around from the prior install, and I was just looking to get up and going. So I instead downloaded the latest Gentoo minimal install CD and Funtoo 1.2 and have progressed, with some small hiccups, until Mesa.  I will make a snapshot of what I have and try 1.3.  See if it progresses further.  Everything else is working now, just no X, though I have not tried it.  My goal had been to get back up and going quickly, as I had not expected to have issues.  Thanks again, I will try and report back.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...