Jump to content
funtoo forums
  • 0
aoeaoeaoeaoeaoeaoe

Cant install funtoo from existing distro

Question

So I found on gentoo wiki:

https://wiki.gentoo.org/wiki/Installation_alternatives#Installing_Gentoo_from_an_existing_Linux_distribution

root #env -i HOME=$HOME TERM=$TERM chroot /mnt/gentoo /bin/bash
root #/usr/sbin/env-update
root #source /etc/profile 
But when I run second command after chrooting in
/usr/sbin/env-update

I get:

 

/usr/sbin/env-update 
Traceback (most recent call last):
  File "/usr/lib/python-exec/python2.7/env-update", line 35, in <module>
    portage.env_update(makelinks)
  File "/usr/lib64/python2.7/site-packages/portage/proxy/objectproxy.py", line 30, in __call__
    result = object.__getattribute__(self, '_get_target')()
  File "/usr/lib64/python2.7/site-packages/portage/proxy/lazyimport.py", line 130, in _get_target
    __import__(name)
  File "/usr/lib64/python2.7/site-packages/portage/util/env_update.py", line 23, in <module>
    from portage.dbapi.vartree import vartree
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 73, in <module>
    from _emerge.EbuildBuildDir import EbuildBuildDir
  File "/usr/lib64/python2.7/site-packages/_emerge/EbuildBuildDir.py", line 6, in <module>
    from _emerge.AsynchronousLock import AsynchronousLock
  File "/usr/lib64/python2.7/site-packages/_emerge/AsynchronousLock.py", line 22, in <module>
    from portage.locks import lockfile, unlockfile
  File "/usr/lib64/python2.7/site-packages/portage/locks.py", line 11, in <module>
    import multiprocessing
  File "/usr/lib64/python2.7/multiprocessing/__init__.py", line 64, in <module>
    from multiprocessing.process import Process, current_process, active_children
  File "/usr/lib64/python2.7/multiprocessing/process.py", line 321, in <module>
    _current_process = _MainProcess()
  File "/usr/lib64/python2.7/multiprocessing/process.py", line 318, in __init__
    self._authkey = AuthenticationString(os.urandom(32))
NotImplementedError: /dev/urandom (or equivalent) not found

Partition is mounted to correct directory and chrooting in works fine. There you go wiz'es, show me your magic!

Edit: huh, it creates that traceback no matter what emerge command I run... makes me 'tink 'dis eazy solushion...

 

Solved: I forgot to mount
 

# mount -t proc none proc
# mount --rbind /sys sys
# mount --rbind /dev dev

before chrooting. Totally not a noob.

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×