Jump to content
funtoo forums
  • 0
Sign in to follow this  
donjames

[Solved]Brother MFC-L2710DW printer install

Question

I have a Brother MFC-L2710DW printer that I am trying to install on a new install of Funtoo Linux.

I was able to find the print driver on the Brother website, downloaded it and installed it.  The printer is connected to my local area network.  When I try to print, the print manager is saying that it can't find the printer.  The exact message, "Unable to locate printer "BRN3C2AF45C3EB5"."

Problem: Why can't the Linux OS find the printer on the LAN?

Thanks,

donjames

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
9 minutes ago, jhan said:

Have you told the OS where it can find the printer?

I thought I had, but evidently not.

In the file, printers.conf, it says:

<Printer Brother_MRC-L2710DW_SERIES>

DeviceURI lpd://BRN3C2AF45C3EEB5/BINARY_P1

<PRINTER HP_LASERJET SERIES PCL 4/5>

DeviceURI socket://192.168.1.20

The HP printer, prints.  The Brother printer, doesn't print.

 

 

Share this post


Link to post
Share on other sites
  • 0

I have installed cups and my HP printer is working.  The Brother printer is not working from my Funtoo Linux.  The brother printer works from my Macpro.

Where is the URI syntax on the Brother website?

I finally got the Brother printer to print.

Downloaded the print driver here: http://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=mfcl2710dw_us_eu_as&os=127&dlid=dlf103525_000&flang=4&type3=10282

Converted the print dirver to a tar.gz file: rpm2tar <print driver name>

On my web  browser, I connected to http://localhost:631

Browsed to the  "modify Brother..."

Clicked on the "internet printing protocol (ipp)" button.

Entered the ip address of my Brother printer.

Now it prints!

Edited by donjames
problem solved

Share this post


Link to post
Share on other sites
  • 0

HI,

I found the driver, but I didn't do the configuration correctly.

When I chose the "internet printing protocol (ipp)" under "Other Network Printers", it allowed me to enter the printer's ip address.  Now it works!

Thanks to everyone for your help,

donjames

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×