Jump to content
  • 0

boot-update issue


robot682
Go to solution Solved by sputnik,

Question

Hi,

 

I'm trying to follow the guide to install the root filesystem over encrypted LVM, which can be found here: http://www.funtoo.org/Rootfs_over_encrypted_lvm and have run into a bit of a hiccup with boot-update. I'm hoping someone can help me.

 

I should state that I'm trying to boot the kernel off of a USB drive, which on my setup is /dev/sdb1.

 

/dev/sda1 contiains the logical volumes including the rest of the OS and other mount points.

 

When I run boot-update, I get the following errors.


boot-update 1.6.11 /
Copyright 2009-2012 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

 * Generating config for grub...

 * ERROR : (rootfstype=auto) - cannot find a valid / entry in /etc/fstab.
 * ERROR : No matching kernels or boot entries found in /etc/boot.conf.
 * Did not complete successfully.

My /etc/boot.conf file looks like this:

boot {
        generate grub
        default "Funtoo Linux Dracut"
        timeout 3
}

"Funtoo Linux Dracut" {
        kernel vmlinuz[-v]
        initrd initramfs[-v]
        params += rootfstype=ext4
        params += luks enc_root=77f735b0-3d46-4fd7-9751-34df92d460d5
        params += lvm root=UUID=625a0681-e435-429f-976e-e3bb4830ad17
        params += rd.luks.key=/boot/luks-key.gpg
}

My /etc/fstab file is as follows:

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

/dev/sdb1               /boot           ext2            noauto,noatime  1 2
/dev/mapper/vg1-swap    none            swap            sw              0 0
/dev/mapper/vg1-root    /               ext4            noatime         0 1
/dev/mapper/vg1-tmp     /tmp            ext4            noatime         0 2
/dev/mapper/vg1-var     /var            ext4            noatime         0 2
/dev/mapper/vg1-home    /home           ext4            noatime         0 2
/dev/cdrom              /mnt/sr0        auto            noauto,ro       0 2

Finally, my /boot partition contains the following files, which include the kernel and the initramfs files.

-rw-r--r-- 1 root root 3835913 Sep 14 01:08 System.map-3.16.2-hardened
-rw-r--r-- 1 root root   98826 Sep 14 01:08 config-3.16.2-hardened
drwxr-xr-x 4 root root    4096 Sep 14 01:11 grub
-rw------- 1 root root 6974532 Sep 14 11:51 initramfs-vlinuz-3.16.2-hardened.img
drwx------ 2 root root   16384 Sep 14 01:07 lost+found
-rwxr-xr-x 1 root root 8409125 Sep 14 01:09 luks-key.gpg
-rw-r--r-- 1 root root 6979552 Sep 14 01:09 vmlinuz-3.16.2-hardened

I have also tried copying and pasting the file names directly into /etc/boot.conf as a means of troubleshooting, but that didn't work. The initramfs was built using dracut, if that matters.

 

Any help would be appreciated.

 

 

 

 

Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...