Jump to content

Problems creating OpenVZ container with ploop layout


s4uliu5
 Share

Recommended Posts

Hello,

 

for couple of years I've been using Funtoo as base system for OpenVZ virtualization. Everything is working great.

So far used only simfs layout. Decided to try ploop, but

 

# vzctl create 1409072 --ostemplate centos-7-x86_64-minimal --layout ploop --hostname demo --hostname demo

 

ended with error:

 

Creating image: /vz/private/1409072.tmp/root.hdd/root.hdd size=2306867K
Creating delta /vz/private/1409072.tmp/root.hdd/root.hdd bs=2048 size=4614144 sectors v2
Storing /vz/private/1409072.tmp/root.hdd/DiskDescriptor.xml
Opening delta /vz/private/1409072.tmp/root.hdd/root.hdd
Adding delta dev=/dev/ploop58790 img=/vz/private/1409072.tmp/root.hdd/root.hdd (rw)
Can't add image /vz/private/1409072.tmp/root.hdd/root.hdd: Invalid argument
Failed to create image: Can't add image /vz/private/1409072.tmp/root.hdd/root.hdd: Invalid argument [3]
Destroying container private area: /vz/private/1409072
Creation of container private area failed
/vz partition is ext4.

 

Tried different sys-kernel/openvz-rhel6-stable kernels (from personal overlay):

 

* 2.6.32-042stab084.26

* 2.6.32-042stab090.5

* 2.6.32-042stab093.4

 

with different vzctl versions:

 

* 4.6.1

* 4.7

* 4.7.2

 

every time got the same error.

 

What could be wrong?

 

Does anybody successfully use OpenVZ containers with ploop layout?

 

Any thoughts/help is appreciated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...