Jump to content

e2fsprogs breaks u-boot


minou666
 Share

Recommended Posts

I have been working on yocto, gentoo and funtoo for the Beagleboard X15. I needed to create a new image for one of my Beagleboard X15 boards. I created a partition of 90MB in fat32 for u-boot and MLO. I then created an ext4 partition for the rootfs using the following command because funtoo now uses the e2fsprogs that breaks u-boot :

mkfs.ext4 -L rootfs -O ^metadata_csum,^64bit /dev/sdd2

That didn't not create a 32 bit filesystem as expected. The solution was to boot to ubuntu 16.04 which still uses 1.42

This command worked correctly on arch linux last I tried.

I looke to replace 1.43 with 1.42 in my overlay but it doesn't appear to be possible. The unmask and mask do not work, funtoo insists on keeping the buggy version.

I find it annoying to have to boot to ubuntu to do my work on arm boards.

Any idea how to fix that? Is there any alternative to that e2fsprogs crapware?

 

Michel

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...