Jump to content
funtoo forums
  • 0
Sign in to follow this  
adcdam

Help with python i really dont know what im doing

Question

Hi

i have python 2.7 3.4 3.5 and 3.6 installed , before installing python 3.6 and changing gcc version all was working fine, i need someone with patience to explain me how to manage python versions


 

Calculating dependencies... done!
[ebuild     U  ] app-arch/p7zip-16.02-r3::nokit [16.02-r2::nokit] USE="pch -doc -kde -rar (-static) -wxwidgets" ABI_X86="(-x32)" 0 KiB
[ebuild   R    ] dev-libs/libxml2-2.9.7-r1:2::core-kit  USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild     U  ] app-misc/ca-certificates-20180409.3.37::core-hw-kit [20180409.3.36.1-r1::core-hw-kit] USE="-cacert" 22.488 KiB
[ebuild   R    ] dev-python/pyelftools-0.24::python-kit  USE="-examples" PYTHON_TARGETS="python2_7 python3_6%* -python3_4* -python3_5" 403 KiB
[ebuild   R    ] dev-util/gdbus-codegen-2.48.2::gnome-kit  PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-libs/boost-1.65.0:0/1.65.0::core-kit  USE="icu nls python threads tools -context -debug -doc -mpi -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pyyaml-3.12::python-kit  USE="-examples -libyaml" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] x11-proto/xcb-proto-1.12-r2::xorg-kit  ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] net-libs/libtorrent-rasterbar-1.1.5-r1:0/9::net-kit  USE="dht python ssl -debug -doc -examples -libressl -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-libs/libbytesize-1.2-r1::dev-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/six-1.10.0::python-kit [1.10.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 29 KiB
[ebuild   R    ] virtual/python-ipaddress-1.0-r1::python-kit  PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 0 KiB
[ebuild   R    ] dev-python/idna-2.6::python-kit  PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 0 KiB
[ebuild   R    ] sys-apps/file-5.32::core-kit  USE="python zlib -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/mwparserfromhell-0.5::python-kit  PYTHON_TARGETS="python2_7 python3_6 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-libs/cracklib-2.9.6-r1::core-kit  USE="nls python zlib -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/chardet-3.0.4::python-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 1.829 KiB
[ebuild   R    ] dev-python/PySocks-1.6.7::python-kit  PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 277 KiB
[ebuild  N     ] dev-python/asn1crypto-0.22.0::python-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6 -pypy -pypy3 -python3_5" 83 KiB
[ebuild   R    ] dev-python/ply-3.10:0/3.10::python-kit [3.10:0/0::python-kit] USE="-examples" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 148 KiB
[ebuild   R    ] dev-python/pyxattr-0.6.0::python-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6%* -pypy -python3_4* -python3_5" 31 KiB
[ebuild     U  ] dev-python/cython-0.26::python-kit [0.25.2::python-kit] USE="-doc -emacs {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 1.653 KiB
[ebuild   R    ] dev-python/pygments-2.2.0::python-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pyasn1-0.2.3::python-kit  USE="-doc" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5" 98 KiB
[ebuild   R    ] dev-python/python-evdev-0.6.1::python-kit  PYTHON_TARGETS="python2_7 python3_6%* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-util/meson-0.44.0::dev-kit  PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-apps/kmod-25::core-kit  USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pycparser-2.17::python-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 226 KiB
[ebuild   R    ] dev-python/docutils-0.13.1::python-kit  PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/cffi-1.10.0:0/1.10.0::python-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -python3_5" 409 KiB
[ebuild     U  ] dev-python/cryptography-2.0.3::python-kit [1.7.2::python-kit] USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 418 KiB
[ebuild     U  ] dev-python/pyopenssl-17.2.0::python-kit [16.2.0::python-kit] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 167 KiB
[ebuild   R    ] dev-python/urllib3-1.22::python-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 0 KiB
[ebuild     U  ] dev-python/ndg-httpsclient-0.4.2-r1::python-kit [0.4.2::python-kit] USE="{-test%}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5" 25 KiB
[ebuild   R    ] dev-python/requests-2.18.4::python-kit  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5" 0 KiB
[ebuild   R    ] dev-python/pycairo-1.15.1::gnome-kit  USE="-doc -examples {-test} -xcb" PYTHON_TARGETS="python2_7 python3_6 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pygobject-3.20.1:3::gnome-kit  USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_6 -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/ssl-fetch-0.4::python-kit  PYTHON_TARGETS="python2_7 python3_6%* -pypy -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-apps/portage-2.3.25_beta3::core-kit  USE="(ipc) native-extensions xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/appi-0.2.0:0/0.2::python-kit  PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] app-portage/gentoolkit-0.4.1::core-kit  PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-java/java-config-2.2.0-r3:2::java-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] app-admin/ego-2.4.0_beta1::core-kit  USE="-zsh-completion" PYTHON_SINGLE_TARGET="python3_6* -python3_4* -python3_5" PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-apps/util-linux-2.31.1-r1::core-kit  USE="cramfs ncurses nls pam python readline static-libs suid unicode -build -caps -fdformat -kill (-selinux) -slang -systemd {-test} -tty-helpers (-udev)" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python3_6* -python2_7 -python3_4* -python3_5" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pyopengl-3.1.0::python-kit  USE="-tk" PYTHON_TARGETS="python2_7 python3_6%* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-python/dbus-python-1.2.4::python-kit  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] games-util/lutris-0.4.14::games-kit  PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild  NS    ] x11-libs/wxGTK-3.0.3:3.0::desktop-kit [2.8.12.1-r2:2.8::desktop-kit, 3.0.3-r300:3.0-gtk3::desktop-kit] USE="X opengl tiff (-aqua) -debug -doc -gstreamer -libnotify -sdl" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] app-crypt/gpgme-1.11.1:1/11::nokit  USE="cxx python -common-lisp -qt5 -static-libs" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] app-portage/layman-2.4.2-r1::nokit  USE="git mercurial subversion -bazaar -cvs -darcs -g-sorcery -gpg -sqlite -squashfs -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5" 0 KiB
[ebuild   R    ] media-video/mpv-0.27.0-r1::media-kit  USE="X alsa bluray cdda cli dvd egl encode iconv jpeg libass lua opengl tools uchardet v4l xv zlib (-aqua) -archive (-coreaudio) -cplugins -cuda -doc -drm -dvb -gbm -jack -javascript -lcms (-libav) -libcaca -libmpv -luajit -openal -oss -pulseaudio (-raspberry-pi) -rubberband -samba -sdl (-selinux) {-test} -vaapi -vdpau -wayland -zsh-completion" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-boot/boot-update-1.9.0::core-kit  PYTHON_SINGLE_TARGET="python3_6* -python3_4* -python3_5" PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-fs/cryptsetup-2.0.0-r1:0/12::core-kit  USE="argon2 gcrypt nls python udev -kernel -libressl -nettle -openssl -pwquality -reencrypt -static -static-libs -urandom" PYTHON_SINGLE_TARGET="python3_6* -python2_7 -python3_4* -python3_5" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] dev-libs/volume_key-0.3.9::dev-kit  USE="{-test}" PYTHON_SINGLE_TARGET="python3_6* -python3_4* -python3_5" PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild   R    ] sys-libs/libblockdev-2.15-r1::core-kit  USE="cryptsetup -bcache -dmraid -doc -kbd -lvm {-test}" PYTHON_SINGLE_TARGET="python3_6* -python3_4* -python3_5" PYTHON_TARGETS="python3_6* -python3_4* -python3_5" 0 KiB
[ebuild     U  ] app-editors/vim-core-8.0.1809::editors-kit [8.0.1803::editors-kit] USE="acl nls -minimal" 13.251 KiB
[ebuild     U  ] app-editors/vim-8.0.1809::editors-kit [8.0.1803::editors-kit] USE="X acl gpm nls python -cscope -debug -lua -luajit -minimal -perl -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB

Total: 57 packages (8 upgrades, 1 new, 1 in new slot, 47 reinstalls), Size of downloads: 41.528 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/certifi:0

  dev-python/certifi-2017.7.27.1:0/0::python-kit, ebuild scheduled for merge conflicts with
    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/setuptools-36.4.0:0/0::python-kit, installed
                                                                                                                                                                                                                                                                                                                                                            
    >=dev-python/certifi-2017.4.17[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/requests-2.18.4:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                                
    dev-python/certifi[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/urllib3-1.22:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                    

dev-python/setuptools:0

  dev-python/setuptools-36.4.0:0/0::python-kit, ebuild scheduled for merge conflicts with
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/PySocks-1.6.7:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/urllib3-1.22:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/ply-3.10:0/3.10::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python3_4] required by dev-lang/python-3.4.6-r1:3.4/3.4m::python-kit, installed
                          ^^^^^^^^^^^^^^^^^^^^^^^^
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/cryptography-2.0.3:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/idna-2.6:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/asn1crypto-0.22.0:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/certifi-2017.7.27.1:0/0::python-kit, installed
                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/chardet-3.0.4:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/requests-2.18.4:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       
    >=dev-python/setuptools-1.0[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/cryptography-2.0.3:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/pycparser-2.17:0/0::python-kit, ebuild scheduled for merge
                                                                                                                                                                                                                                                                                                                       


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/requests-2.18.4::python-kit
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/chardet-3.0.4 python_targets_python3_4
# required by dev-python/cryptography-2.0.3::python-kit[python_targets_python2_7,python_targets_python3_4,-python_targets_python3_5,python_targets_python3_6]
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/cffi-1.10.0 python_targets_python3_4
# required by dev-python/requests-2.18.4::python-kit
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/idna-2.6 python_targets_python3_4
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/pyopenssl-17.2.0 python_targets_python3_4
# required by dev-python/ssl-fetch-0.4::python-kit
# required by app-portage/layman-2.4.2-r1::nokit
# required by @selected
# required by @world (argument)
>=dev-python/requests-2.18.4 python_targets_python2_7
# required by dev-python/urllib3-1.22::python-kit
# required by dev-python/requests-2.18.4::python-kit
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/PySocks-1.6.7 python_targets_python3_4
# required by dev-python/pyopenssl-17.2.0::python-kit
# required by dev-python/ndg-httpsclient-0.4.2-r1::python-kit
# required by dev-python/ssl-fetch-0.4::python-kit[python_targets_python2_7]
# required by app-portage/layman-2.4.2-r1::nokit
# required by @selected
# required by @world (argument)
>=dev-python/six-1.10.0 python_targets_python3_4
# required by dev-python/cffi-1.10.0::python-kit
# required by dev-python/cryptography-2.0.3::python-kit[python_targets_python2_7,python_targets_python3_4,-python_targets_python3_5,python_targets_python3_6]
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/pycparser-2.17 python_targets_python3_4
# required by dev-python/pyopenssl-17.2.0::python-kit
# required by dev-python/ndg-httpsclient-0.4.2-r1::python-kit
# required by dev-python/ssl-fetch-0.4::python-kit[python_targets_python2_7]
# required by app-portage/layman-2.4.2-r1::nokit
# required by @selected
# required by @world (argument)
>=dev-python/cryptography-2.0.3 python_targets_python3_4
# required by dev-python/pycparser-2.17::python-kit
# required by dev-python/cffi-1.10.0::python-kit
# required by dev-python/cryptography-2.0.3::python-kit[python_targets_python2_7,python_targets_python3_4,-python_targets_python3_5,python_targets_python3_6]
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/ply-3.10 python_targets_python3_4
# required by dev-python/cryptography-2.0.3::python-kit
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=virtual/python-ipaddress-1.0-r1 python_targets_python3_4
# required by dev-python/cryptography-2.0.3::python-kit
# required by dev-python/requests-2.18.4::python-kit[ssl]
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/asn1crypto-0.22.0 python_targets_python3_4
# required by dev-python/requests-2.18.4::python-kit
# required by app-admin/ego-2.4.0_beta1::core-kit
# required by sys-apps/portage-2.3.25_beta3::core-kit
# required by app-portage/layman-2.4.2-r1::nokit[-sync-plugin-portage]
# required by @selected
# required by @world (argument)
>=dev-python/urllib3-1.22 python_targets_python3_4

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! Problems have been detected with your world file
!!! Please run emaint --check world

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Switching to a new python version can be tricky, especially whenh the packages setuptools and certifi get involved.

To make it easier, when I get these errors with such a large amount of packages, I install the packages step by step. Practically that means I use one xterm and get myself the list of packages to be installed. And in another xterm I try to install those packages either one by one or in small batches. That way I can isolate which packages have problems and which install without problems.

And with a resulting smaller list it is easier to see what is needed to resolve the problem. To me it seems that you need to set some USE flags for certain packages but it is hard to tell which ones, with such a large list.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...