Jump to content
funtoo forums
  • 0
absmith

evolution-data-server-3.12.4 wont build correctly.

Question

I am having a strange issue when emerging evolution-data-server-3.12.4. The build.log grows forever filling up my harddrive. In the build log I just see this repeated. I tried deleting all the distfiles to force it to download it again but no change.
 
 

example build.log entries

EDataServer-1.2.gir:15810.1-15810.0: error: unexpected end of file

EDataServer-1.2.gir:15810.1-15810.0: warning: expected end element of `type'

EDataServer-1.2.gir:15810.1-15810.0: error: unexpected end of file

EDataServer-1.2.gir:15810.1-15810.0: warning: expected end element of `type'

EDataServer-1.2.gir:15810.1-15810.0: error: unexpected end of file

EDataServer-1.2.gir:15810.1-15810.0: warning: expected end element of `type'

EDataServer-1.2.gir:15810.1-15810.0: error: unexpected end of file

EDataServer-1.2.gir:15810.1-15810.0: warning: expected end element of `type'
emerge --info 
Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.14.3-gentoo x86_64)
=================================================================
System uname: Linux-3.14.3-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.2.0
KiB Mem:     6104500 total,   3027112 free
KiB Swap:    2000088 total,   2000088 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/python:          2.7.8-r1000, 3.2.5-r1000, 3.3.5-r1000
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2-r1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r3
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13::funtoo, 2.69
sys-devel/automake:       1.5-r1, 1.10.3::funtoo, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4-r2, 4.8.2-r3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo desktop-effects personal-overlay
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync mini-manifest news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/desktop-effects /usr/local/portage/adam"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X a52 aac acl acpi alsa amd64 apache2 apng berkdb bzip2 cairo cdda cddb cdio cdr colord cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread eds evo exif facc ffmpeg flac gdbm gif gnome gnome-keyring gnome-online-accounts gnome-shell gnutls gpm gstreamer gtk gtk3 gtkstyle guntls iconv icu introspection ipv6 jpeg jpeg2k lame libnotify lm_sensors mad mmx modules mp3 mpeg mudflap multilib mysql nautilus ncurses nls nptl ogg opengl openmp pam pcre png policykit pppd pulseaudio python readline resolvconf speex spell sqlite sse sse2 ssl tcpd theora threads tiff tracker truetype udev unicode usb vorbis wavpack win32codecs x264 xinerama xml xmp xpm zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="vesa radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK
 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

With the information you have provided, my best guest is that this is related to dev-libs/gobject-introspection. You need to either globally enable (in your make.conf or through the gnome mix-in) the introspection USE flag or globally disable (in your make.conf) it. Then do "emerge -vauDN world" before emerging whatever it is you are emerging.

 

The output of "eselect profile list", the emerge command you were using, the FULL build log (snipped at the point before it started to repeat) and the USE flags of the packages you were emerging is more useful than the output of "emerge --info". Of course, use a pastebin such as http://paste.kde.org/ if the output is too long.

Share this post


Link to post
Share on other sites
  • 0

emerge command

emerge -vauDN world

 

[ebuild  N     ] gnome-extra/evolution-data-server-3.12.4:0/49  USE="gnome-online-accounts gtk introspection ipv6 vala weather -api-doc-extras -kerberos -ldap {-test}" 0 kB
 

Full build.log snipped when it beings to repeat
https://gist.githubusercontent.com/absmith/65691b39222d8e022f89/raw/gistfile1.txt

eselect profile list
http://dpaste.com/26AJXBD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...