Jump to content
  • 0
Sign in to follow this  
mauricev

Can I get cinnamon going?

Question

I tried to setup a Funtoo installation with cinnamon. I changed to the desktop flavor and added it as a mixin. It didn't complain, but emerge didn't find anything more to emerge. So I manually emerged cinnamon. When I started X, I got a basic X and not cinnamon. So I changed .xinitrc to the following

exec ck-launch-session dbus-launch cinnamon-session

When I ran startx again, it started to run and then promptly crashed.

The logged output is

Feb 02 12:33:52 [ck-launch-session] error connecting to ConsoleKit
Feb 02 12:33:52 [cinnamon-session] WARNING: t+0.00378s: Could not connect to ConsoleKit: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory_
Feb 02 12:33:53 [kernel] [   32.643783] csd-xrandr[24011]: segfault at 0 ip 00007fc98568a9d9 sp 00007fff44441e50 error 4 in libupower-glib.so.3.0.1[7fc985678000+26000]
Feb 02 12:33:53 [kernel] [   32.645367] csd-power[24010]: segfault at 0 ip 00007f812bfcd9d9 sp 00007ffdce11c8d0 error 4 in libupower-glib.so.3.0.1[7f812bfbb000+26000]
Feb 02 12:33:53 [cinnamon-session] WARNING: t+0.47240s: Application 'cinnamon-settings-daemon-xrandr.desktop' killed by signal 11_
Feb 02 12:33:53 [cinnamon-session] WARNING: t+0.95457s: Application 'cinnamon-settings-daemon-power.desktop' killed by signal 11_
Feb 02 12:33:54 [kernel] [   33.875096] csd-xrandr[24115]: segfault at 0 ip 00007fece8eb69d9 sp 00007ffcb40b5a50 error 4 in libupower-glib.so.3.0.1[7fece8ea4000+26000]
Feb 02 12:33:54 [cinnamon-session] WARNING: t+1.70045s: Application 'cinnamon-settings-daemon-xrandr.desktop' killed by signal 11_
Feb 02 12:33:54 [kernel] [   33.891378] csd-power[24116]: segfault at 0 ip 00007f154f4b59d9 sp 00007ffcb77fc6e0 error 4 in libupower-glib.so.3.0.1[7f154f4a3000+26000]
Feb 02 12:33:54 [cinnamon-session] WARNING: t+1.71240s: Application 'cinnamon-settings-daemon-power.desktop' killed by signal 11_
Feb 02 12:34:00 [cinnamon-session] WARNING: t+7.43181s: Detected that screensaver has left the bus_

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I can only guess you need to push your configuration changes into your current environment.  The manpage for ego-profile does not show action update, but it is seen via running 'ego profile -h'. You could also run 'epro -h'. Sometimes it is useful to 'source /etc/profile' and then 'env-update'. Maybe you should back up (undo your changes with .xinitrc) and try to 'push' your configuration setting through, or just reboot and hope nothing is foobar about rebooting. If you don't boot up with X-windows, I doubt you will have a problem with that, but I don't actually know. Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...