Jump to content
funtoo forums
  • 0
znavko

wpa_supplicant does not connect

Question

Hello! I have 2 questions.

I cannot connect to wifi with wpa_supplicant.

Next line worked on gentoo

wpa_supplicant -B -i wlan0 -c<(wpa_passphrase HOME passphrase) && dhcpcd wlan0

On Funtoo I have:

# wpa_supplicant -B -i wlan0 -c<(wpa_passphrase HOME passphrase) && dhcpcd wlan0
Successfully initialized wpa_supplicant
wlan0: waiting for carier
timed out
dhcpcd exited

 

I cannot understand why it does not connect? I need this when I will install funtoo again.

 

The second question:

I tried nmtui after wpa_supplicant not worked, but it also has not connected. But after reboot nmtui has connected. I want to clarify, please let me know.

Once I typed dhcpcd and connection failed it will not connect never. This situation was on Gentoo: wpa_supplicant did not work if I had error in my line - the second run of wpa_supplicant absolutely not worked and only reboot helped. I think some process does not allow to use wpa_supplicant or dhcpcd the second time.

Please, which processes do not allow to connect?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Mixing NetworkManager and manual wpa_supplicant will not work. Pick only one approach.

- NetworkManager: set it up in the applet or using CLI

- wpa_supplicant & dhcpcd: disable NetworkManager and enable wpa_supplicant and dhcpcd services and set your credential in /etc/wpa_supplicant/wpa_supplicant.conf using the wpa_pass utility

Share this post


Link to post
Share on other sites
  • 0
rc-status -a
Runlevel: default
 dbus                                                              [  started  ]
 NetworkManager                                                    [  started  ]
 netmount                                                          [  started  ]
 sshd                                                              [  started  ]
 xdm                                                               [  started  ]
 local                                                             [  started  ]
Runlevel: sysinit
 sysfs                                                             [  started  ]
 devfs                                                             [  started  ]
 dmesg                                                             [  started  ]
 kmod-static-nodes                                                 [  started  ]
 udev                                                              [  started  ]
Runlevel: shutdown
 savecache                                                         [  stopped  ]
 killprocs                                                         [  stopped  ]
 mount-ro                                                          [  stopped  ]
Runlevel: boot
 hwclock                                                           [  started  ]
 swap                                                              [  started  ]
 modules                                                           [  started  ]
 fsck                                                              [  started  ]
 root                                                              [  started  ]
 mtab                                                              [  started  ]
 localmount                                                        [  started  ]
 procfs                                                            [  started  ]
 loopback                                                          [  started  ]
 urandom                                                           [  started  ]
 sysctl                                                            [  started  ]
 binfmt                                                            [  started  ]
 hostname                                                          [  started  ]
 bootmisc                                                          [  started  ]
 termencoding                                                      [  started  ]
 keymaps                                                           [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                      [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual

 

Share this post


Link to post
Share on other sites
  • 0

I connect via Networkmanager applet in LXDE. But when I disconnect and run by root

wpa_supplicant -B -i wlan0 -c<(wpa_passphrase HOME passphrase) && dhcpcd wlan0

it does not connect and Networkmanager cannot connect too. only reboot helps. So how to stop wpa_supplicant, dhcpcd or abort any lock?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×