Jump to content
funtoo forums
  • 0
yczo

Kernel UEFI, GPT, mount root part "/" like read only; don't mount /boot & /home

Question

Hi comunity, (please pardon for my English)

Im trying to configure a new custom kernel, but it does not work.

When the Kernel starts, the root partition is like read only mounted. On the other hand /boot (Efi) and /home are not mounted

 

Please, someone so kind to help me? Thanks in advance

 

(Please ignore the systemd line. I have disabled it and I have the same problem)

here is the config for my kernel v4.9.6    https://pastebin.com/UC9GeZjT

 

my dmesg output   https://pastebin.com/gTgdGUYV

 

my fstab file

#/dev/sda1------------------------------------------------------------------------>
UUID=A841-5975          /boot           vfat            auto,noatime            1 2     

#/dev/sda7------------------------------------------------------------------------->            
UUID=70ef3567-5816-41fa-9647-b4e9ef8f05a4               /home               xfs             noatime,nodiratime      0 1

#/dev/sda9------------------------------------------------------------------------->
UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e               /           xfs             noatime,nodiratime      0 2

my /etc/default/grub  config

GRUB_CMDLINE_LINUX_DEFAULT="root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs"

my kernel Built in chain
 

[*] Built-in kernel command line                                                                                  ? ?  
  ? ?                                           (root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs) Built-in kernel command string                    ? ?  
  ? ?                                           [*]   Built-in command line overrides boot loader arguments

Regards

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello, yczo!

 

Your system is embedded? I found this in the documentation of the kernel:

 

 CONFIG_CMDLINE_BOOL:                                                                                                                                                                                      ?  
  ?                                                                                                                                                                                                           ?  
  ? Allow for specifying boot arguments to the kernel at                                                                                                                                                      ?  
  ? build time.  On some systems (e.g. embedded ones), it is                                                                                                                                                  ?  
  ? necessary or convenient to provide some or all of the                                                                                                                                                     ?  
  ? kernel boot arguments with the kernel itself (that is,                                                                                                                                                    ?  
  ? to not rely on the boot loader to provide them.)                                                                                                                                                          ?  
  ?                                                                                                                                                                                                           ?  
  ? To compile command line arguments into the kernel,                                                                                                                                                        ?  
  ? set this option to 'Y', then fill in the                                                                                                                                                                  ?  
  ? boot arguments in CONFIG_CMDLINE.                                                                                                                                                                         ?  
  ?                                                                                                                                                                                                           ?  
  ? Systems with fully functional boot loaders (i.e. non-embedded)                                                                                                                                            ?  
  ? should leave this option set to 'N'.                                                                                                                                                                      ?  
  ?                                                                                                                                                                                                           ?  
  ? Symbol: CMDLINE_BOOL [=n]                                                                                                                                                                                 ?  
  ? Type  : boolean                                                                                                                                                                                           ?  
  ? Prompt: Built-in kernel command line                                                                                                                                                                      ?  
  ?   Location:                                                                                                                                                                                               ?  
  ?     -> Processor type and features                                                                                                                                                                        ?  
  ?   Defined at arch/x86/Kconfig:2195
 
You tried without this parameter? Did you try this on /etc/fstab:
 
/dev/sda1          /boot           vfat            auto,noatime               1 2
/dev/sda7          /home         xfs              noatime,nodiratime      0 1
 
You could post the output of these commands, please:
 
#grep GRUB_DISABLE_LINUX_UUID /etc/default/grub
#ego profile list flavor
#lsblk -o +fstype,label,uuid,partuuid

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...