Jump to content

Photo

VLC - no interface is shown after installing

- - - - - xserver vlc

Best Answer kevinpaladin , 20 August 2014 - 04:26 AM

I'm sorry for the late reply.

 

It worked after `unmerging` it and merging it again using the appropriate USE flags and restarting the system. And I didn't enable the `qt4` flag. I don't know how it works but I think enabling the `X` flag made it work for me. And I had to enable the `pulseaudio` flag too to make the audio work - which was not mentioned in the vlc site here : http://www.videolan....oad-gentoo.html

Go to the full post »


4 replies to this topic

#1
kevinpaladin

kevinpaladin

    Newbie

  • Members
  • Pip
  • 2 posts

Recently, I installed vlc in my Funtoo system using `emerge`. After installing, when I try to open the vlc interface using the command `vlc`, I get the following error :

VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be)
No protocol specified
xcb_connection_has_error() returned true
No protocol specified
[0x21ea7e8] main interface error: no suitable interface module
[0x21011f8] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x21ea7e8] dbus interface error: Failed to connect to the D-Bus session daemon: /usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
Autolaunch error: X11 initialization failed.

[0x21ea7e8] main interface error: no suitable interface module
[0x21011f8] main libvlc error: interface "dbus,none" initialization failed
[0x21011f8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
No protocol specified
[0x21ea7e8] qt4 interface error: Could not connect to X server
Remote control interface initialized. Type `help' for help.

I'm using XFCE as my Desktop Environment. Any help would be great!



#2
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts
I don't think xfce4 mixin enables USE=qt4 gloabally, and you need to tell explicitly you want vlc with qt4, try emerge -av vlc again, and check qt4 USE flag is enabled, if not you can add it to package.use just for vlc or make.conf to enable qt4 globally.

#3
sputnik

sputnik

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

I highly recommend this Gentoo-specific instructional page at the VideoLan.org:

http://www.videolan....oad-gentoo.html

 

It's quite in depth about the USE flags needed, not only for vlc, but other support packages.

 

Werks fer mi



#4
kevinpaladin

kevinpaladin

    Newbie

  • Members
  • Pip
  • 2 posts
✓  Best Answer

I'm sorry for the late reply.

 

It worked after `unmerging` it and merging it again using the appropriate USE flags and restarting the system. And I didn't enable the `qt4` flag. I don't know how it works but I think enabling the `X` flag made it work for me. And I had to enable the `pulseaudio` flag too to make the audio work - which was not mentioned in the vlc site here : http://www.videolan....oad-gentoo.html



#5
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts
Just a note, you don't need to unmerge and reboot your system just for vlc, you can emerge again anything you have installed before, with something like 'emerge -av category/package', and did you set a flavor and mixins? if you select the desktop or workstation flavor or a graphical desktop mixin the 'X' useflag gets enabled by default. Also did you check the 'alsa' use flag was being used for building vlc? I don't think you actually *need* pulseaudio for vlc.



Reply to this topic



  



Also tagged with one or more of these keywords: xserver, vlc

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users