Jump to content

Photo

Built-in sound card does not work on iMac


Best Answer biocyberman , 27 June 2017 - 04:25 PM

This does the trick:

euse -E pulseaudio # enable pulseaudio feature globally
# to be sure I also installed alsa-oss. Don't have time to check if it is really necessary. 
emerge -auDN @world # update and recompile all packages that uses pulseaudio
# reboot and run alsamixer to make sure pulseaudio is unmuted. 

Case closed.

Go to the full post »


3 replies to this topic

#1
biocyberman

biocyberman

    Newbie

  • Members
  • Pip
  • 8 posts

Funtoo on an imac that has an AppleDisplay with it. I can't get the built-in sound card on the iMac to work. Oddly enought, output sound device on the AppleDisplay works, but not the screen itself (black screen). This is alsamixer current state:

┌───────────────────────────── AlsaMixer v1.1.3 ──────────────────────────────┐
│ Card: HDA Intel PCH                                 F1:  Help               │
│ Chip: Cirrus Logic CS4206                           F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All            F6:  Select sound card  │
│ Item: PCM [dB gain: -4.40, -4.40]                   Esc: Exit               │
│                                                                             │
│     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                                │
│     │  │     │  │     │  │     │  │     │  │                                │
│     │  │     │  │     │  │     │  │     │  │                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│                                │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│                                │
│     ├──┤     ├──┤     ├──┤     └──┘     └──┘     ┌──┐     ┌──┐   Enabled    │
│     │MM│     │MM│     │MM│                       │OO│     │OO│              │
│     └──┘     └──┘     └──┘                       └──┘     └──┘              │
│      83      0<>0    83<>83   82<>82   50<>50                               │
│    Master  Headphon Speaker <  PCM   >Mic Boos  S/PDIF  S/PDIF D Auto-Mut   │
└─────────────────────────────────────────────────────────────────────────────┘

Current sound modules

~ ➤ lsmod|grep snd                                                            
snd_usb_audio         184320  1
snd_usbmidi_lib        28672  1 snd_usb_audio
snd_rawmidi            32768  1 snd_usbmidi_lib
snd_seq_device         16384  1 snd_rawmidi
snd_hda_codec_hdmi     49152  1
snd_hda_codec_cirrus    20480  1
snd_hda_codec_generic    73728  1 snd_hda_codec_cirrus
snd_hda_intel          36864  6
snd_hda_codec         131072  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_cirrus
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_cirrus
snd_hwdep              16384  2 snd_hda_codec,snd_usb_audio
snd_pcm               114688  5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_timer              32768  1 snd_pcm
snd                    86016  26 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec_cirrus,snd_seq_device,snd_pcm
soundcore              16384  1 snd
usbcore               249856  15 uvcvideo,usbhid,sl811_hcd,snd_usb_audio,usb_storage,ehci_hcd,ohci_pci,uhci_hcd,xhci_pci,snd_usbmidi_lib,btusb,ohci_hcd,appledisplay,xhci_hcd,ehci_pci


And hadware information: 

 

~ ➤ lspci|grep -i audio                                                       
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
~ ➤ lsusb|grep -i audio                                                       
Bus 003 Device 003: ID 05ac:1107 Apple, Inc. Thunderbolt Display Audio

Stop and start pulseaudio mannually do not help. 

 

 

Content of /etc/conf.d/modules:

modules="thunderbolt appledisplay facetimehd binfmt_misc"

content of /etc/modprobe.d/alsa.conf (only the last line got modified manually)

 

~ ➤ cat /etc/modprobe.d/alsa.conf                                      
# Alsa kernel modules' configuration file.


# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore


##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##


# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss


alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss


# Set this to the correct number of cards.
options snd cards_limit=3

 



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 231 posts
The Master, Headphone, and Speaker controls in the alsamixer picture are muted.
Use the m key while you highlight to toggle them from MM to 00

If you require more help use the alsa-info.sh:
wget http://www.alsa-project.org/alsa-info.sh
chmod +x alsa-info.sh
./alsa-info.sh
Choose y to upload the information.
Provide the link to uploaded info in your reply.
  • biocyberman likes this

#3
biocyberman

biocyberman

    Newbie

  • Members
  • Pip
  • 8 posts

The Master, Headphone, and Speaker controls in the alsamixer picture are muted.
Use the m key while you highlight to toggle them from MM to 00

If you require more help use the alsa-info.sh:

wget http://www.alsa-project.org/alsa-info.sh
chmod +x alsa-info.sh
./alsa-info.sh

Choose y to upload the information.
Provide the link to uploaded info in your reply.

@cardinal: Thanks for the pointer. I was looking for something like the script you pointed out so I don't have to manually collect information. 

Here is the script output:

http://www.alsa-proj...cdf6a7e529dcef8

 

Regarding the muted status of the alsamixer screen, I toggled them but nothing changes. I think the problem is with pulseaudio setup. I haven't configured anything for pulseaudio, and actually don't know how to do it. The PulseAudio page on gentoo is outdated, and the one on Funtoo is empty:

 

https://wiki.gentoo....wiki/PulseAudio

http://www.funtoo.org/PulseAudio



#4
biocyberman

biocyberman

    Newbie

  • Members
  • Pip
  • 8 posts
✓  Best Answer

This does the trick:

euse -E pulseaudio # enable pulseaudio feature globally
# to be sure I also installed alsa-oss. Don't have time to check if it is really necessary. 
emerge -auDN @world # update and recompile all packages that uses pulseaudio
# reboot and run alsamixer to make sure pulseaudio is unmuted. 

Case closed.


  • cardinal likes this



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users