Jump to content
  • 0
onli

Complete Freezes after enabling gpu-powered X

Question

I described in http://forums.funtoo.org/topic/905-installing-x-with-radeon-driver-lead-to-llvmpiped-slow-x/that I had to enable the radeonsi driver. Before, I already used the desktop for several hours and it was stable (but too slow). It is not the only thing that changed though, still in the process of installing what is needed and finding my way around. That is getting hard: I'm experiencing complete system freezes that take down the whole system. The only thing I can do then is to use the magic sysrec keys to make a emergency remount and then reboot.

 

The last line in the log is this:

Mar 12 23:35:59 [kernel] [ 4352.046372] radeon 0000:01:00.0: bo ffff8800736e6400 va 0x000000de0e conflict with (bo ffff880288729000 0x000000de10 0x000000de12)

But I found nothing with that that would help me.

 

I'll of course provide whatever files and information that are necessary. Would be very happy about suggestions what to do now. Thanks in advance, and sorry for writing this a bit rushed, I guess it is obvious why ;)

 

Edit: It might be related to firefox. I realized that all crashes happen when using FF. Strange enough, hardware-acceleration on or off changes nothing, I would've expected the error to be there. I installed Qupzilla, used this a while and until now saw no further crashes ? though they might still appear. Qupzilla sadly has rendering issues, I'm compiling chromium now? Would still appreciate any hints and tips how to workaround, properly debug and report this.

 

Edit2: It's not firefox alone, it's GTK. All GTK programs I tested cause these freezes ? Firefox, geany and pinentry-gnome. I thought that chromium was an anomaly, but no, they forked GTK (Aura?) with the focus on how the gpu rendering is done, which explains why that works.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

A kernel upgrade seems to have solved this. I used the recommended debian-sources before, which set me on 3.19.3. Now funtoo runs with debian-sources 4.2.6 from the masked version, and since then I had no freeze despite trying to provoke it. Still a bit early to be 100% sure, but I'm at 99%, so I'll call it solved already.

 

Putting this in a separate post in the hope I can mark it as solved this way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...