Jump to content
  • 0

ZFS Mount Issues and Temporary Workaround


vkraven
 Share

Question

Hey everyone.

 

I'd been having issues importing zpools in ZFS since a recent update (I can't recall for sure, maybe 0.6.4 or 0.6.5). For the longest time, I thought I hadn't compiled my kernel properly, but this helped me. 

https://github.com/zfsonlinux/zfs/issues/4337

It seems this issue occurs for gentoo-patched ZFS, and the poster worked around it by compiling ZOL from the ZOL Project's tarball. Having done the same, I can attest that this worked for me too. Something about the gentoo patches might be messing with it.

 

Although it's a gentoo package - considering this compiling from source is just an ad hoc workaround, I thought you guys would like to know. Hope it helps.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...