Jump to content
  • 0
Sign in to follow this  
tmp-meteque

/boot doesn't mount but uefi works

Question

 I have an UEFI system and everything works fine. I can write into the partition but I have to mount it manually every time.

# /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#
# <fs>							<mountpoint>			<type>		<opts>												<dump/pass>

UUID="2B00-F65A"								/boot					vfat		noauto,defaults										1 2
UUID="d9fb9efe-390e-4ff7-870b-83a532af4c8e" 	/ 						ext4		defaults,noatime 									0 1
UUID="8505b49a-0ab4-4393-82f7-fb67d262906c"		swap					swap		defaults											0 0
UUID="09382c16-b07f-4e5e-b8d5-3cf53ed1edcb"		/home					ext4		rw,relatime,discard,data=ordered					0 2
tmpfs											/var/tmp/portage		tmpfs		size=3G,uid=portage,gid=portage,mode=775,noatime	0 0

#/dev/cdrom					/mnt/cdrom	auto		noauto,ro				0 0

/dev/sda1: UUID="2B00-F65A" TYPE="vfat" PARTUUID="b0c835f5-2c98-084d-ad6d-80ff784cf3b1"
/dev/sda2: UUID="d9fb9efe-390e-4ff7-870b-83a532af4c8e" TYPE="ext4" PARTUUID="fe9efbd9-0e39-f74f-870b-83a532af4c8e"
/dev/sda3: UUID="8505b49a-0ab4-4393-82f7-fb67d262906c" TYPE="swap" PARTUUID="33cbeea1-0c09-4243-949d-15488c58e41a"
/dev/sda4: UUID="09382c16-b07f-4e5e-b8d5-3cf53ed1edcb" TYPE="ext4" PARTUUID="162c3809-7fb0-5e4e-b8d5-3cf53ed1edcb"

boot {
	generate grub
	default "Funtoo Linux Vanilla"
	timeout 1 
}

"Funtoo Linux Vanilla" {
	kernel vmlinuz[-v]
	initrd initramfs.cpio.gz
	params root=/dev/sda2 rootfstype=ext4 resume=/dev/sda3
	}

"Funtoo Linux Debian" {
	kernel kernel[-v]
	initrd initramfs[-v]
	params += real_root=auto rootfstype=auto resume=/dev/sda3
} 

I tried changing the UUID first, then reformatting the partition, swap the UUID by /dev/sda1 in fstab... I'm out of ideas.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

 I have an UEFI system and everything works fine. I can write into the partition but I have to mount it manually every time.

# /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#
# <fs>							<mountpoint>			<type>		<opts>												<dump/pass>

UUID="2B00-F65A"								/boot					vfat		noauto,defaults										1 2
UUID="d9fb9efe-390e-4ff7-870b-83a532af4c8e" 	/ 						ext4		defaults,noatime 									0 1
UUID="8505b49a-0ab4-4393-82f7-fb67d262906c"		swap					swap		defaults											0 0
UUID="09382c16-b07f-4e5e-b8d5-3cf53ed1edcb"		/home					ext4		rw,relatime,discard,data=ordered					0 2
tmpfs											/var/tmp/portage		tmpfs		size=3G,uid=portage,gid=portage,mode=775,noatime	0 0

#/dev/cdrom					/mnt/cdrom	auto		noauto,ro				0 0

/dev/sda1: UUID="2B00-F65A" TYPE="vfat" PARTUUID="b0c835f5-2c98-084d-ad6d-80ff784cf3b1"
/dev/sda2: UUID="d9fb9efe-390e-4ff7-870b-83a532af4c8e" TYPE="ext4" PARTUUID="fe9efbd9-0e39-f74f-870b-83a532af4c8e"
/dev/sda3: UUID="8505b49a-0ab4-4393-82f7-fb67d262906c" TYPE="swap" PARTUUID="33cbeea1-0c09-4243-949d-15488c58e41a"
/dev/sda4: UUID="09382c16-b07f-4e5e-b8d5-3cf53ed1edcb" TYPE="ext4" PARTUUID="162c3809-7fb0-5e4e-b8d5-3cf53ed1edcb"

boot {
	generate grub
	default "Funtoo Linux Vanilla"
	timeout 1 
}

"Funtoo Linux Vanilla" {
	kernel vmlinuz[-v]
	initrd initramfs.cpio.gz
	params root=/dev/sda2 rootfstype=ext4 resume=/dev/sda3
	}

"Funtoo Linux Debian" {
	kernel kernel[-v]
	initrd initramfs[-v]
	params += real_root=auto rootfstype=auto resume=/dev/sda3
} 

I tried changing the UUID first, then reformatting the partition, swap the UUID by /dev/sda1 in fstab... I'm out of ideas.

It doesn't mount automatically because you configured it to not mount automatically:

 

UUID="2B00-F65A"    /boot	vfat	noauto,defaults		1 2

the option 'noauto', means to not mount automatically that partition, but since you have it /etc/fstab, you can quickly manually mount it by simple running:

 

$ sudo mount /boot

If you want it automatically mounted,  just  delete 'noauto'.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...