Jump to content
funtoo forums
  • 0
Sign in to follow this  
aneez

issues finding bootdevice and usb keyboard

Question

Hi,

 

Let me start by saying, this is my first time trying to install funtoo.

 

I am trying to install Funtoo on a brand new PC with an Asus Z97 keyboard ( http://www.asus.com/dk/Motherboards/GRYPHON_Z97_ARMOR_EDITION/ )

on a Samsung SSD.

 

I have followed the installation manual and everything up on til booting for the first time. Now when I am booting the pc boots not being able to find the root device. Plus it boots without USB keyboard, so i can not do a lot of error finding.

 

I am using old school grub and UEFI bios - but the kernel boot just fine. So i dont belive this is the issue.

 

I have tried compiling my own kernel using genkernel and the debian sources - but i am not sure which drivers I am missing.

 

I have tried specifying the root partition in boot.conf - and everything seem to be configured correctly - but the kernel cant find the root device during boot.

 

I have tried using iommu=soft as er kernel parameter to try to get usb to work.

 

Any help as to where im going wrong would be appreciated, as i currently cant interact with the system once its booted the kernel.

 

If theres any information that would help, ill try to provide it.

 

- aneez

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...