Jump to content
  • 0
Sign in to follow this  
proinsias

Lost trying to boot with grub & encrypted root

Question

Hi,

 

Been wanting to try Funtoo for a while and made my first move last week. I've been running Arch on my desktop, laptop & Raspberry Pi for the past few years and have been tinkering around with Gentoo. I have a spare 20GB hdd, from an old xbox, I use for trying out new things and messing around. I used it to try an encrypted Arch install before doing the install on my SSD, all went smoothly and now I've got my ssd running an encrypted Arch install. The plan is to use the existing encrypted partitions on the 20GB xbox drive to try out Funtoo with a view to using it as my main OS on the SSD.

 

I'm a bit lost with grub2, boot-update and encryption. Last time I used grub2 was when installing Gentoo on the same drive but that was before I was using encryption, it just worked first time and I forgot about it. Similarly with encrypted Arch bootctl just worked on the first attempt.

 

So far the install appears to be fine working from a chroot, I've got a bare bones but functioning and updateble system with tmux, vim, elinks and a few others. I've been popping in and out of it for the past week.

 

View from Arch:

lsblk 
NAME                    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                       8:0    0 111.8G  0 disk  
??sda1                    8:1    0   512M  0 part  /boot
??sda2                    8:2    0 111.3G  0 part  
  ??arch                254:0    0 111.3G  0 crypt 
    ??arch-swap         254:1    0     5G  0 lvm   [SWAP]
    ??arch-root         254:2    0    45G  0 lvm   /
    ??arch-home         254:3    0  61.3G  0 lvm   /home
sdb                       8:16   0 931.5G  0 disk  
??sdb1                    8:17   0 709.8G  0 part  /mnt/storage
??sdb2                    8:18   0   150G  0 part  
  ??backup              254:4    0   150G  0 crypt 
sdc                       8:32   0  18.7G  0 disk  
??sdc1                    8:33   0   512M  0 part  /mnt/funtoo/boot
??sdc2                    8:34   0  18.2G  0 part  
  ??My_Storage          254:5    0  18.2G  0 crypt 
    ??MyStorage-swapvol 254:6    0     4G  0 lvm   
    ??MyStorage-rootvol 254:7    0    10G  0 lvm   /mnt/funtoo
    ??MyStorage-homevol 254:8    0   4.2G  0 lvm   /mnt/funtoo/home
sdd                       8:48   0  55.9G  0 disk  
??sdd1                    8:49   0  55.9G  0 part  /mnt/hulk
sde                       8:64   1   7.5G  0 disk  
??sde1                    8:65   1   7.5G  0 part  
sdf                       8:80   0 232.9G  0 disk  
??sdf1                    8:81   0 232.9G  0 part  
sr0                      11:0    1 371.4M  0 rom

/boot is sdc1 vfat filesystem and is not encrypted, sdc2 was encrypted originally using this lvm on luks guide.

 

Boot-update from Funtoo I've butchered and decided to stop and seek help, I figure I need a cryptdevice=....... or something. I started using UUID's and them went back to /dev/mapper......

cat /etc/boot.conf                                                                                                       
boot {
        generate grub
        default "Funtoo Linux genkernel" 
        timeout 3 
}

"Funtoo Linux" {
        kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=/dev/mapper/MyStorage-rootvol 
} 

I've not done anything with kernels yet as I was hoping to just run with the Debian kernel until I'm comfortable, I'm assuming it supports dm-crypt.

 

My /etc/fstab is using UUID's but looks sound to me:

cat /etc/fstab 
# /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

UUID=935D-2E98          /boot           vfat            noauto,noatime  1 2
UUID=9bff32f9-906b-4ce2-8780-a9c82bc1de4d               none            swap            sw          0 0
UUID=bc6a0249-4703-4efb-8ac3-66c81da58719               /               ext4            noatime     0 1
UUID=d71e6b53-7d64-4d47-9200-fe9a0fea6cb9       /home ext4 defualts 0 0

i couldn't find anything on encypted partition in man boot-update and not sure if I should be using that or configuring grub2 manually.

 

Any help or pointers is appreciated.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...