Jump to content
  • 0
Sign in to follow this  
delgado

Opening Windows in Fullscreen

Question

Good afternoon,

 

I just started using Funtoo about a week ago and I am loving it but I had a question about my desktop that I can't seem to fix. I am running the MATE desktop environment with two monitors. When I double click on the title bar in a window to make it go full screen be it Youtube, Chromium, xterm etc it makes the window full screen but spans both monitors. What I would like to know is if it is possible when I double click the title bar can I make the program go full screen on only one monitor.

 

 

Thanks in advanced!

post-750-0-78652800-1445277473_thumb.png

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hi delgado,

 

could you tell use which video card you are using?

Usually this is a problem with older nvidia cards, as the driver does not support the so-called "RandR" extension of the X-Server, which manages multiple screens. In this case, an easy fix is to enable the useflag "xinerama" and to do a world update.

 

However, it may also be a misconfiguration in your xorg.conf, since it is possible to create "one big screen" on the base of two monitors.

To provide further assistance it would be helpful if we could know how you start your X session (e. g. startx/gdm/lightdm) and if you are using a custom xorg.conf.

 

Welcome to the funtoo community!

Share this post


Link to post
Share on other sites
  • 0

Hello Philipp,

 

The video card I am using is the following as listed by lspci -v

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
        Subsystem: Dell Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915

I also use lightdm to start my x session and I do not believe I am using a custom xorg.conf at least I did not edit one when setting up this system.

 

Thanks for your help!

Share this post


Link to post
Share on other sites
  • 0

I also did a find for xorg.conf on my system and the only places where it was found was  /usr/share/portage/config/sets/xorg.conf and it contained the following.

# Rebuild all X11 modules (mostly useful after xorg-server ABI change).
[x11-module-rebuild]
class = portage.sets.dbapi.VariableSet
world-candidate = false
variable = CATEGORY
includes = x11-drivers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...