Jump to content
funtoo forums
  • 0
Sign in to follow this  
sitquietly

Running funtoo x86 in chroot under FreeBSD

Question

I sometimes boot into Funtoo ~amd64, and sometimes boot into FreeBSD 10 stable with current (HEAD) ports.  They are on separate drives with their own boot managers but share a common /home on a ZFS mirrored pool.  I'd like to try running the 32-bit Linux google-chrome in FreeBSD.  It appears to be almost possible to do that using the CentOS 6.x system from ports and utilizing the FreeBSD "linuxulator".  In other words FreeBSD can run Linux binaries "natively" (but it only emulates the Linux 2.6.x kernel).

 

I can chroot into the FreeBSD linux subsystem at /compat/linux and run Linux gui apps using the FreeBSD X server.  e.g.

# script to chroot into bash in linux  

cp /etc/resolv.conf /compat/linux/etc/

mount -t linprocfs linproc /compat/linux/proc

mount_nullfs /dev /compat/linux/dev

mount_nullfs /sys /compat/linux/sys

mount -t fdescfs fdesc /compat/linux/dev/fd

export DISPLAY="192.168.1.1:0.0"

xhost +localhost

DISPLAY=localhost:0 chroot /compat/linux /bin/bash

but I run into problems with missing libraries for Google Chrome -- it would be so much more flexible to just put Funtoo in /compat/linux and use portage to install stuff into that chrooted system.

 

Before I spend time installing Funtoo into a FreeBSD chroot (or optionally a jail) I would appreciate hearing from anyone who has tried running a recent Gentoo or Funtoo in a FreeBSD chroot or jail.  Any advice?  Pitfalls?  Is there any reason it can't work?  Can pigs fly?

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...