Jump to content
  • 0

Localization in French with xfce


foid
 Share

Question

Hi all,

I installed Funtoo a year ago, with xfce desktop environment.

I followed all the install process, as well as the localization page indications.

I would like to have my xfce in French, but the menu is still in English.

eselect is set to fr_FR.UTF-8 (from memory, I am not on my machine now).

LANG is set to French as well. L10N as well (fr-FR)

I also tried to export LANG from the xinitrc (I am not using any display manager, starting with startxfce4).

I am running the Next version of Funtoo (I followed the guide recently given). Previously, I was also

unable to have xfce in French. I tried to find some solution with the Gentoo website and forum as well,

without success.

So, any help would be greatly appreciated in order to sort this out.

Thanks.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi foid!

I set up a fresh Xfce environment for testing. I succeeded to build a French Xfce desktop.

What I did:

  • Add "fr_FR.UTF-8 UTF-8" to /etc/locale.gen
  • Execute locale-gen
  • Select fr_FR.UTF-8 with eselect locale set
  • Reboot

What I did not:

  • Set LINGUAS (As you may know, setting LINGUAS reduces language supports. Without LINGUAS, Xfce installs French language support by default on my environment)
  • Set L10N (Doing so should not harm but I think it is not necessary in this case. It is recommended to set if you install Firefox, for instance.)
  • Set LANG in xinitrc (as eselect locale updates /etc/profile so the setting should be enabled system-wide anyways)

Would you show us the output of the following command?

env | grep "^\(LANG\|LC_\)"
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...