Jump to content
funtoo forums
  • 0
hfdaf

emerge -avuDN @world failed

Question

It just Installed Funtoo 1.3-Current. I chose the desktop flavor and changed the subarch from generic_64 to atom_64 as Funtoo is running on a Atom N450 @1.66GHz and 1GB of 800Mhz DDR2 SODIMM.

First i did a

ego sync

and then

emerge -avuDN @world

after waiting for the Netbook to ask me to install new packages , it gave me this error:

Total: 23 Packages (23 new), Size of downloads: 146,488 KiB

	* Error: circular dependencies:
    
	(x11-libs/libva-2.2.0:0/2::xorg-kit, ebuild scheduled for merge) depends on
    	(virtual/opengl-7.0-r4:0/0::xorg-kit, ebuild scheduled for merge) (buildtime)
        	(media-libs/mesa-18.2.8:0/0::core-gl-kit, ebuild scheduled for merge) (runtime)
            	(x11-libs/libva-2.2.0:0/2::xorg-kit, ebuild scheduled for merge) (buildtime_slot_op)
                
    It might be possible to break this cycle by applying any of the following changes:
    -media-libs/mesa-18.2.8 (Chnage USE: -gallium)
    -media-libs/mesa-18.2.8 (Chnage USE: -vaapi)
    -virtual/opengl-7.0-r4 (Chnage USE: +glvnd)
    
    Note that this change can be reverted, once the package has been installed.

Has Someone Experienced This Before and that fixed it?

EDIT:

I forgot to add the epro show output:

 === Enabled Profiles: ===
		
		   arch: x86_64bit
		  build: current
		subarch: atom_64
		 flavor: desktop
		mix-ins: audio
		mix-ins: X
		mix-ins: media

=== Python kit: ===

		branch: 3.7-release

 

btw. i am a noob to all lot of funtoo /gentoo things, so any help would be appreciated.

btw². if my english sounds kinda strange, well than it probaly is, as i am german

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Quote

    It might be possible to break this cycle by applying any of the following changes:
    -media-libs/mesa-18.2.8 (Chnage USE: -gallium)
    -media-libs/mesa-18.2.8 (Chnage USE: -vaapi)
    -virtual/opengl-7.0-r4 (Chnage USE: +glvnd)

That is the important part. Making the suggested changes could solve the problem. You can either do this manually, by adding the USE flags to /etc/portage/package.use or by choosing the appropiate mix-in for your graphics card. Available mix-ins can be shown with 'epro list'.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...