Jump to content
funtoo forums
  • 0
mortenlj

Help me debug missing card reader

Question

Hi

Some months ago, my SD card reader was working fine. Since then I have upgraded to newer kernels several times, and probably made other changes to the system as well. Now, my machine wont recognize that a card is inserted at all, and I'm struggling to find out which pieces of the puzzle to debug.

My machine is a Lenovo Thinkpad P51 with an integrated card reader. I have a kernel built from gentoo-sources with my own configuration, but I haven't made any significant changes to this since the card reader worked as far as I can recall. After some googling I discovered that the config options related to this type of card was changed from kernel 4.15 to 4.16, but after updating my config to use the new symbols it still doesn't work. The relevant options used to be called CONFIG_MFD_RTSX and CONFIG_MFD_RTSX_PCI, but changed name to CONFIG_MISC_RTSX and CONFIG_MISC_RTSX_PCI. A related option called CONFIG_MFD_RTSX_USB also exists, but as far as I can tell is only relevant if the card reader is attached via USB (I have tried enabling it with no change in behavior).

# lspci | grep -i card
3f:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
# zcat /proc/config.gz | grep RTSX
CONFIG_MISC_RTSX=y
CONFIG_MISC_RTSX_PCI=y
# CONFIG_MISC_RTSX_USB is not set

If I boot using just about any live CD, it works, so it's not a hardware failure. There is something in my system/kernel that has changed since the last time I used it, but I can't figure out what it is. Most of the reason for this problem is that I don't know which pieces are involved.

Obviously the kernel needs to be configured to include drivers. This is now fixed but it's still not detected.

Which other pieces are involved when I insert a card and dmesg prints out that it has detected a new device with X partitions? Does this involve udev or similar? Is there some other configuration that might be different? Are there other kernel options that could cause this, which are not directly related to the ones mentioned above?

Any help or hints is appreciated.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
5 hours ago, jhan said:

What about "Device Drivers->MMC/SD/SDIO card support" ?

It turns out that after enabling CONFIG_MISC_RTSX_PCI a new option under "MMC/SD/SDIO card support" was revealed that I hadn't noticed: CONFIG_MMC_REALTEK_PCI. Once I enabled this one, the card reader works. Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×