Jump to content
funtoo forums
  • 0
Sign in to follow this  
erikr

Somehow messed up locale settings

Question

Hi,

 

It seems I have messed up the language settings on my funtoo installation. I haver made a ton of installations and cannot recall this problems since before Gentoo went UTF-8 several years ago. And I am clueless at the moment :(

 

I am Swede and makes use of the Swedish characters ??? when I need them.

 

In KDE things works mostly well. If I save a file with ??? things works well and I can open in another KDE based application. I can browse with Dolphin and access files.

 

In GTK based applications (Firefox, libre office, Eclipse based Archi etc) and a few others this does not work. I can save a Libre Office file in "F?retag/Uppf?ljning.odt" (translated: Company/Follow up, i.e. makes sense to use) where "F?retag" exists but it creates a second directory name "F?retag" stores the file but fails to access it again and produces an error.

Right now I am trying to download a PDF from Firefox with a Swedish character in it and it failes - it seems like it can create but not carry the name further to write to it. The file name is "Inf?r 9e april.pdf" and this is the files created by firefox:

-rw-r--r-- 1 xx xx     0 21 Mar 10.40 Inf?r 9e april.pdf
-rw------- 1 xx xx  228K 21 Mar 10.40 Inf?r 9e april.pdf.part

My locale.gen:

# /etc/locale.gen: list all of the locales you want to have on your system

en_US.UTF-8 UTF-8
en_US ISO-8859-1
sv_SE.UTF-8 UTF-8
sv_SE ISO-8859-1

root locale outputs (I prefer en_US to get man pages in English, computing does not work very well in Swedish).

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE=POSIX
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

and my users locale outputs:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE=C
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

In /etc/portage/make.conf I have the following:

USE="djvu ebook epub git google mercurial mtp nls ogg pulseaudio threads
     unicode vdpau"

ABI_X86="32 64"
RUBY_TARGETS="ruby21  ruby22 ruby24"


LINGUAS="sv en sv_SE en_GB en_US"
INPUT_DEVICES="evdev keyboard mouse"
VIDEO_CARDS="nvidia"
L10N="sv en en-GB en-US"

CALLIGRA_FEATURES="author braindump flow karbon kexi krita sheets stage words"

MAKEOPTS="-j9"

Any clues what to do next?

 

 

Regards,

Erik

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×