Jump to content

Photo

Why is portage trying to download an old version of itself?

- - - - -

2 replies to this topic

#1
mauricev

mauricev

    Member

  • Members
  • PipPip
  • 13 posts

It looks like I have portage 2.4 and the current version is 2.4.3

[ebuild     U  ] sys-apps/portage-2.4.3-r1::gentoo [2.4.0::gentoo] USE="(ipc) xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 -pypy -python3_4 (-python3_5) (-python3_3%*)" 898 KiB

But portage is insisting on downloading some old version

>>> Emerging (1 of 1) sys-apps/portage-2.4.3-r1::gentoo
>>> Downloading 'http://distfiles.gentoo.org/distfiles/portage-2.3.2.tar.bz2'

Why is doing this and how can I fix it?



#2
mauricev

mauricev

    Member

  • Members
  • PipPip
  • 13 posts

This is odd, but according to the package list online, https://packages.gen...ys-apps/portage, the current version of portage is actually 2.3.5 and the portage I have installed doesn't exist yet, let alone 2.4.3. In the ebuld for 2.4.3, it references an older, non-existent version.

TARBALL_PV=2.3.2


#3
mauricev

mauricev

    Member

  • Members
  • PipPip
  • 13 posts

An explanation is posted here, https://bugs.funtoo.org/browse/FL-3713





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users