Jump to content
  • 0
Sign in to follow this  
jeanbiche

Installing Funtoo on a Libreboot x200 with full disk encryption

Question

Hello everyone,

 

I'm trying to install Funtoo on a LIbreboot x200 system, with full disk encryption. A particular thing about these computers is that they have a GRUB payload in a flash chip on the motherboard, thus you don't need to create an unencrypted boot partition. However, when rebooting, there's an error right after entering the volume password ; searching on internet didn't help much.

 

Enter passphrase for /dev/sda1:
device-mapper: reload ioctl1 on  failed : no such device or directory
Failed to setup dm-crypt key mapping for device /dev/sda1
check that kernel supports twofish-xts-plain64 cipher (check syslog for more info)
!! Failed to open LUKS device /dev/sda1
!! Could not find the root in /dev/sda1

 

I'm using parts of Francis Rowe's Parabola installation tutorial (to prepare the disk and manually reboot after installation) : https://libreboot.org/docs/gnulinux/encrypted_parabola.html, and the Funtoo installation instructions ( http://www.funtoo.org/Install ), using the debian-sources kernel and the standard initramfs for simplicity, and ext4 as the main filesystem. The installation works fine, except the Grub installation step, which seemed unnecessary and poped an error anyway (grub-install: error: disk `lvm/matrix-root' not found.) so I usually skip it (Could it be the source of my problem?)

 

And I'm manually amorcing the system using the commands described in the parabola tutorial and this page (the boot.conf part) : http://www.funtoo.org/Rootfs_over_encrypted_lvm

Which gives this :

grub> cryptomount -a
grub> set root='lvm/matrix-root'

grub> linux  /boot/kernel-debian-sources-x86-64-3.19.3-1~exp1 crypt_root=/dev/sda1 dolvm real_root=/dev/mapper/matrix-root rootfstype=ext4

grub> initrd /boot/initramfs-debian-sources-x86_64-3.19.3-1~exp1

grub> boot

 

My FSTab looks like this :

# <fs>          <mountpoint>    <type>      <opts>      <dump/pass>
 
/dev/mapper/matrix-swapvol      none        swap        sw  0 0
/dev/mapper/matrix-root     /   ext4        noatime     0 1

#/dev/cdrom     /mnt/cdrom  auto        noauto,ro   0 0

 

Does the problem only comes from an unsupported cipher? How can I know what is supported by the debian-sources kernel?

 

Thanks in advance for your help.

 

Regards,

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...