Jump to content
Funtoo Linux
  • 0
storkk

First update in a while, slot conflicts ahoy. (python-related?)

Question

Last time I updated @world was probably 6 months ago... and now I'm running into issues I don't seem to be able to solve, possibly partly python-related:

# emerge -v --info | wgetpaste

Your paste can be seen here: https://bpaste.net/show/4dcc37d656ac

# emerge --ask --update --newuse --deep --with-bdeps=y @world | wgetpaste

.... std err is at https://bpaste.net/show/3b353d5588b6 ...
Your paste can be seen here: https://bpaste.net/show/4deeb418e791

# python-updater | wgetpaste
emerge: there are no ebuilds to satisfy "dev-python/PyQt4:0/QtCore-1".


Your paste can be seen here: https://bpaste.net/show/0a030c9c47b4

... removing/unversioning all the packages that complain (not sure that's the best idea, but just trying to get something to work), I get:

# emerge -Dv1 --keep-going app-admin/syslog-ng:0 app-portage/gentoolkit:0 app-text/calibre:0 dev-java/javatoolkit:0 dev-libs/boost:0/1.56.0 dev-libs/libxml2:2 dev-libs/libxslt:0 dev-python/Babel:0 dev-python/apsw:0 dev-python/beautifulsoup:python-2 dev-python/cffi dev-python/cryptography:0 dev-python/cython:0 dev-python/decorator:0 dev-python/enum34:0 dev-python/eyeD3:0.7 dev-python/httplib2:0 dev-python/idna:0 dev-python/ipaddress:0 dev-python/lxml:0 dev-python/notify-python:0 dev-python/numpy:0 dev-python/packaging:0 dev-python/paver:0 dev-python/ply dev-python/pycparser:0 dev-python/pyelftools:0 dev-python/pygments:0 dev-python/pygobject:3 dev-python/pygtk:2 dev-python/pyopenssl:0 dev-python/python-dateutil:0 dev-python/python-gflags:0 dev-python/pytz:0 dev-python/pyxattr:0 dev-python/pyzmq:0 dev-python/setuptools:0 dev-python/simplejson:0 dev-python/sip:0/11 dev-python/six:0 dev-python/twisted-core:0 dev-python/twisted-web:0 dev-util/boost-build:0 dev-util/gdbus-codegen:0 dev-util/scons:0 net-p2p/deluge:0 sys-apps/file:0 sys-libs/cracklib:0 sys-libs/libcap-ng:0 x11-libs/vte:0 | wgetpaste


Your paste can be seen here: https://bpaste.net/show/145345d5d5bf

 

Trying to oneshot icu and what pulls it in:

# emerge -1 icu libxml2 calibre --backtrack=50 | wgetpaste
... std err is at https://bpaste.net/show/734ffceb3e2d ...
Your paste can be seen here: https://bpaste.net/show/21c89c124f17

 

Share this post


Link to post
Share on other sites

37 answers to this question

Recommended Posts

  • 0

@cardinal Sorry, because I had a 'conflict' with python_single_targets in make.conf and package.use, I've taken a step back...

 

With make.conf as https://bpaste.net/show/154d33ff84fc and package.use as http://bpaste.net/show/3a02aa194989 :

# emerge --pretend --update --newuse --deep --with-bdeps=y @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-util/mdds-0.12.1:0/0.12.1::gentoo, installed)
                  ^^^^^^^^^^                                                                
    (and 3 more with the same problem)

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by dev-libs/libclc-0.2.0_pre20151006::gentoo
# required by media-libs/mesa-11.1.1::gentoo[opencl]
# required by net-libs/webkit-gtk-2.4.9::gentoo[egl]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=sys-devel/llvm-3.7.1 clang

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])


Your paste can be seen here: https://bpaste.net/show/afbd910eeab1

 

 

Sorry for wasting your time with that mistake... any suggestions on how to proceed next? I've tried @system after toggling the PYTHON_SINGLE_TARGET make.conf variable, and after re-adding clang to llvm in package.use , both independently and together. IMO, just re-adding clang to llvm's use flags in package.conf produces the most likely next step:

# emerge --pretend --update --newuse --deep --with-bdeps=y @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0=[threads] required by (dev-libs/libixion-0.9.1:0/0.10::gentoo, installed)
                  ^^^^^^^^^^                                                                          
    (and 3 more with the same problem)

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/c8bdc30a2056
 
With clang disabled in package.use (ie. with package.use and make.conf as in the above bpastes), @world produces:
# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/giflib:0

  (media-libs/giflib-5.1.2:0/7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/giflib-4.2.3-r1:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.4.2:0/5::gentoo, installed)
                     ^^^^^                                                               

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55=[abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.7:4/4::gentoo, installed)
                ^^^^^^                                                                           

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-5:0/0= required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
                    ^^^^^                                                                  

dev-haskell/dlist:0

  (dev-haskell/dlist-0.7.1.2:0/0.7.1.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/dlist-0.7.1.1:0/0.7.1.1::gentoo, installed) pulled in by
    dev-haskell/dlist:0/0.7.1.1= required by (dev-haskell/data-default-instances-dlist-0.0.1:0/0.0.1::gentoo, installed)
                     ^^^^^^^^^^^                                                                                         

media-gfx/exiv2:0

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/exiv2-0.24-r1:0/13::gentoo, installed) pulled in by
    >=media-gfx/exiv2-0.14:0/13= required by (media-gfx/luminance-hdr-2.4.0:0/0::gentoo, installed)
                          ^^^^^^                                                                    

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0= required by (media-gfx/luminance-hdr-2.4.0:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                    

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

media-video/avidemux:2.6

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, installed) pulled in by
    ~media-video/avidemux-2.6.8:2.6[opengl?,qt4?] required by (media-libs/avidemux-plugins-2.6.8:2.6/2.6::gentoo, installed)
                                            ^^^^                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by sci-mathematics/rstudio-0.99.491::gentoo
# required by @selected
# required by @world (argument)
>=sys-devel/llvm-3.7.1 clang

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Your paste can be seen here: https://bpaste.net/show/624b9f9d97fb

 

With clang re-enabled for llvm, @world produces

# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Your paste can be seen here: https://bpaste.net/show/418bc53d0781
 
and with clang enabled and PYTHON_SINGLE_TARGET="python3_3" in make.conf, I get:
# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-gfx/exiv2:0

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/exiv2-0.24-r1:0/13::gentoo, installed) pulled in by
    >=media-gfx/exiv2-0.11:0/13= required by (media-gfx/ufraw-0.22:0/0::gentoo, installed)
                          ^^^^^^                                                           
    (and 2 more with the same problem)

media-video/avidemux:2.6

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, installed) pulled in by
    ~media-video/avidemux-2.6.8:2.6[opengl?,qt4?] required by (media-libs/avidemux-plugins-2.6.8:2.6/2.6::gentoo, installed)
                                            ^^^^                                                                             

dev-haskell/hashable:0

  (dev-haskell/hashable-1.2.4.0:0/1.2.4.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/hashable-1.2.3.3:0/1.2.3.3::gentoo, installed) pulled in by
    >=dev-haskell/hashable-1.0.1.1:0/1.2.3.3= required by (dev-haskell/unordered-containers-0.2.5.1:0/0.2.5.1::gentoo, installed)
                                  ^^^^^^^^^^^                                                                                     
    (and 9 more with the same problem)

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-5:0/0= required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
                    ^^^^^                                                                  


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-python-20151117-r3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/google-apputils-0.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-lang/yasm-1.3.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-pda/libplist-1.11-r1:0/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/file-5.25:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (app-editors/vim-7.4.712:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/gexiv2-0.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-wireless/aircrack-ng-1.2_rc3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/jinja-2.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-gflags-2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipaddress-1.0.16:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cssutils-1.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/send2trash-1.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libclc-0.2.0_pre20151006:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/zope-interface-4.1.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (media-gfx/inkscape-0.91-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/gimp-2.9.2:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/libproxy-0.4.11-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite] required by (app-misc/anki-2.0.33:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/keybinder-0.3.1-r200:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-web-15.2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[tk?,threads(+)] (>=dev-lang/python-2.7.5-r2:2.7[threads(+)]) required by (dev-python/pillow-3.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r4:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libixion-0.9.1:0/0.10::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/psutil-3.3.0:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:2.7 required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pexpect-4.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads,sqlite] required by (www-client/firefox-44.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/libgpod-0.8.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/service_identity-14.0.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libnl-3.2.27:3/3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/beautifulsoup-4.4.1:4/4::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/greenlet-0.4.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/webkit-gtk-2.4.9:3/25::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/lxml-3.5.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/apsw-3.8.11.1_p1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/jupyter_core-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/anjuta-3.16.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-greenlet-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipython_genutils-0.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/eyeD3-0.7.5:0.7/0.7::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/shiboken-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/path-py-8.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cddb-py-1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.7.0-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/enum34-1.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (dev-lang/spidermonkey-1.8.5-r4:0/mozjs185::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/mutagen-1.31:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-p2p/deluge-1.3.12:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (net-libs/rb_libtorrent-1.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/httplib2-0.9.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/protobuf-2.6.1-r3:0/9::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[readline,sqlite,threads(+)] required by (dev-python/ipython-4.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-java/javatoolkit-0.3.0-r9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyaudio-0.2.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/idna-2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (games-fps/doomsday-1.15.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses] required by (dev-python/urwid-1.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cssselect-0.9.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/tdb-1.3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/itstool-2.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/Babel-2.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (www-client/chromium-48.0.2564.82:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplejson-3.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/avidemux-plugins-2.6.8:2.6/2.6::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads,xml] required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-text/gnome-doc-utils-0.20.10-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/newt-0.52.18:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite,ssl] required by (app-text/calibre-2.47.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/jupyter_client-4.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/chardet-2.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/paver-1.2.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ptyprocess-0.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/py-1.4.31:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-print/cups-2.1.2-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplegeneric-0.8.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxslt-1.1.28-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libpeas-1.14.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/ipyparallel-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/decorator-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (sys-libs/tdb-1.3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/PyQt4-4.11.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygments-2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/dnspython-1.12.0-r200:py2/py2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/kmod-19:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-pda/libimobiledevice-1.1.6-r1:0/4::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-ipaddress-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pypy-4.0.1:0/4.0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyelftools-0.23-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycparser-2.14:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sci-libs/gdal-2.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/alsa-lib-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/eclean-kernel-0.4.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/syslog-ng-3.7.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/PyQt5-5.5.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pickleshare-0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-modules-0.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads,xml] required by (app-office/libreoffice-5.0.4.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cryptography-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycrypto-2.6.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxdg-0.25-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/characteristic-14.3.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyside-1.2.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-dnspython-1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sip-4.17-r1:0/11::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/traitlets-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/ipykernel-4.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ply-3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mechanize-0.2.5-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses?,xml] (>=dev-lang/python-2.7.5-r2:2.7[ncurses,xml]) required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses] required by (app-portage/elogv-0.7.6.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-wireless/lorcon-0.0_p20150109:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pytz-2015.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-dateutil-2.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/beautifulsoup-3.2.1-r1:python-2/python-2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/markupsafe-0.23:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+),threads(+)] required by (dev-python/gevent-1.1_beta6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyzmq-15.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyopenssl-0.15.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/usbutils-007:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/netifaces-0.10.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cython-0.23.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/twisted-core-15.2.1:0/0::gentoo, ebuild scheduled for merge)

  (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed) pulled in by
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-libs/libpeas-1.14.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (virtual/python-greenlet-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[ssl(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ptyprocess-0.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/cryptography-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pycrypto-2.6.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/sip-4.17-r1:0/11::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/shiboken-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (app-admin/eclean-kernel-0.4.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/characteristic-14.3.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads] required by (app-editors/vim-7.4.712:0/0::gentoo, installed)
    dev-lang/python required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/service_identity-14.0.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/paver-1.2.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[ssl(+),threads(+)] required by (dev-python/gevent-1.1_beta6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (virtual/python-dnspython-1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pexpect-4.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sci-libs/gdal-2.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/simplejson-3.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (app-accessibility/speech-dispatcher-0.8.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/simplegeneric-0.8.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyaudio-0.2.8:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/PyQt4-4.11.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/util-linux-2.27.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[bzip2(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/ipyparallel-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/zope-interface-4.1.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pyopenssl-0.15.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/decorator-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/jinja-2.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[readline,sqlite,threads(+)] required by (dev-python/ipython-4.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/file-5.25:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/markupsafe-0.23:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/idna-2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (app-editors/gedit-3.16.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyasn1-modules-0.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-libs/libnl-3.2.27:3/3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyxdg-0.25-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/netifaces-0.10.4:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/cssselect-0.9.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyside-1.2.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pyzmq-15.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/jupyter_core-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ply-3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ipython_genutils-0.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/python-dateutil-2.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-java/java-config-2.2.0:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/enum34-1.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/beautifulsoup-4.4.1:4/4::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyelftools-0.23-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (net-misc/youtube-dl-2016.02.01:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/ipykernel-4.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/Babel-2.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (media-gfx/fontforge-20150824:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (media-libs/gexiv2-0.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/kmod-19:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pytz-2015.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/greenlet-0.4.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/traitlets-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads] required by (net-libs/rb_libtorrent-1.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (virtual/python-ipaddress-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[tk?,threads(+)] (>=dev-lang/python-3.3.2-r2:3.3[threads(+)]) required by (dev-python/pillow-3.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (media-gfx/hugin-2015.0.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (media-libs/mutagen-1.31:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/dnspython-1.12.0-r300:py3/py3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[ncurses] required by (dev-python/urwid-1.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/apsw-3.8.11.1_p1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/path-py-8.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/httplib2-0.9.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pygobject-3.16.2:3/3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pycparser-2.14:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-boot/boot-update-1.7.3-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/psutil-3.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/jupyter_client-4.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pickleshare-0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pygments-2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/PyQt5-5.5.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/chardet-2.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/send2trash-1.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/cssutils-1.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/py-1.4.31:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/lxml-3.5.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/cython-0.23.4:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Your paste can be seen here: https://bpaste.net/show/a10b4020bb2d
 
For now, I've removed clang from llvm in package.use and commented PYTHON_SINGLE_TARGET in make.conf until you instruct otherwise, so those files are exactly as in the bpastes at the beginning of this post

Share this post


Link to post
Share on other sites
  • 0

From Reply#26 last screen:

(app-eselect/eselect-python-20151117-r3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)

app-eselect/eselect-python-20151117-r3:0/0 and dev-lang/python-3.4.3-r7:3.4/3.4m are hard masked by /usr/portage/profiles/package.mask/funtoo-python on my system. Why does portage want to install them on your system ?
Run the commands I used to output the following info from my system and see if the output is the same.

funtoo rj # equery l -p eselect-python
 * Searching for eselect-python ...
[-P-] [  ] app-eselect/eselect-python-20111108:0
[-P-] [  ] app-eselect/eselect-python-20131210:0
[-P-] [  ] app-eselect/eselect-python-20140115:0
[IP-] [  ] app-eselect/eselect-python-20140125:0
[-P-] [M ] app-eselect/eselect-python-20151117-r2:0
[-P-] [M ] app-eselect/eselect-python-20151117-r3:0
[-P-] [M-] app-eselect/eselect-python-99999999:0

funtoo rj # equery l -p python
 * Searching for python ...
[IP-] [  ] dev-lang/python-2.7.10-r1:2.7
[-P-] [M ] dev-lang/python-2.7.11-r2:2.7
[IP-] [  ] dev-lang/python-3.3.5-r2:3.3
[-P-] [M ] dev-lang/python-3.3.5-r7:3.3/3.3m
[-P-] [M ] dev-lang/python-3.4.3-r1:3.4
[-P-] [M ] dev-lang/python-3.4.3-r7:3.4/3.4m
[-P-] [M ] dev-lang/python-3.5.0-r2:3.5
[-P-] [M ] dev-lang/python-3.5.1-r2:3.5/3.5m

funtoo rj # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *

From emerge -v -info posted here

PYTHON_SINGLE_TARGET="python3_3"
PYTHON_TARGETS="python2_7 python3_3"

This problem was fixed on my system 

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

by adding to package.use

media-libs/lensfun -python_single_target_python3_4

Share this post


Link to post
Share on other sites
  • 0
# equery l -p eselect-python
 * Searching for eselect-python ...
[-P-] [  ] app-eselect/eselect-python-20111108:0
[-P-] [  ] app-eselect/eselect-python-20131210:0
[-P-] [  ] app-eselect/eselect-python-20140115:0
[IP-] [  ] app-eselect/eselect-python-20140125:0
[-P-] [M ] app-eselect/eselect-python-20151117-r2:0
[-P-] [  ] app-eselect/eselect-python-20151117-r3:0
[-P-] [M-] app-eselect/eselect-python-99999999:0

# equery l -p python
 * Searching for python ...
[IP-] [  ] dev-lang/python-2.7.10-r1:2.7
[-P-] [M ] dev-lang/python-2.7.11-r2:2.7
[IP-] [  ] dev-lang/python-3.3.5-r2:3.3
[-P-] [M ] dev-lang/python-3.3.5-r7:3.3/3.3m
[-P-] [M ] dev-lang/python-3.4.3-r1:3.4
[-P-] [  ] dev-lang/python-3.4.3-r7:3.4/3.4m
[-P-] [M ] dev-lang/python-3.5.0-r2:3.5
[-P-] [M ] dev-lang/python-3.5.1-r2:3.5/3.5m
# eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *

I have a non-empty package.unmask:

cat /etc/portage/package.unmask | wgetpaste

Your paste can be seen here: https://bpaste.net/show/df4a5808c574

Share this post


Link to post
Share on other sites
  • 0

Exciting... really looks like we're getting somewhere.

 

With 

media-libs/lensfun -python_single_target_python3_4

in package.use, it complains about llvm's clang again, so ...

 

With the above change as well as PYTHON_SINGLE_TARGET="python3_3" in make.conf, and llvm's clang flag set in package.use, I get:

# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    =dev-util/boost-build-1.57* required by (dev-libs/boost-1.57.0:0/1.57.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/boost:=[python,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (net-libs/rb_libtorrent-1.0.8:0/0::gentoo, ebuild scheduled for merge)
 
 
Your paste can be seen here: https://bpaste.net/show/3ddb37356e19
 
 
# emerge -v --info | wgetpaste

Your paste can be seen here: https://bpaste.net/show/cf1eeef3d633

Share this post


Link to post
Share on other sites
  • 0

Installing rb_libtorrent on my updated system would force downgrade of boost and boost-build

rj@funtoo ~ $ emerge -pv rb_libtorrent

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-util/boost-build-1.57.0::gentoo [1.58.0::gentoo] USE="python -examples {-test}" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     UD ] dev-libs/boost-1.57.0:0/1.57.0::gentoo [1.58.0-r1:0/1.58.0::gentoo] USE="icu nls python threads -context -debug -doc -mpi -static-libs -tools" PYTHON_TARGETS="python2_7 python3_3%* -python3_4 -python3_5" 0 KiB
[ebuild  N     ] net-libs/rb_libtorrent-1.0.8::gentoo  USE="python ssl -debug -doc -examples -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_3 -python3_4 -python3_5" 2,908 KiB

Total: 3 packages (2 downgrades, 1 new), Size of downloads: 2,908 KiB

Warning: is for your information but it isn't Blocking or creating a conflict.
Looking at https://bpaste.net/show/3ddb37356e19 the correct version of boost,boost-build,rb_libtorrent are listed for update.
[ebuild U ] dev-util/boost-build-1.57.0 [1.56.0-r1000] PYTHON_TARGETS="python2_7%*"
[ebuild U ] dev-libs/boost-1.57.0 [1.56.0-r1000] PYTHON_TARGETS="python2_7%* python3_3%* -python3_4% -python3_5%"
[ebuild U ] net-libs/rb_libtorrent-1.0.8 [1.0.6] PYTHON_TARGETS="-python3_5%"

 

I would update @system first then @world

# emerge --sync
# emerge --ask --update --newuse --deep --with-bdeps=y @system

Share this post


Link to post
Share on other sites
  • 0

Thanks for your continued patience... I'm starting to be of the serious opinion that it would have been faster and easier to start from scratch... but we're so close now, I think.

 

After syncing, I get 

# emerge --ask --update --newuse --deep --with-bdeps=y @system | wgetpaste


!!! Problem resolving dependencies for sys-apps/util-linux from @system

!!! The ebuild selected to satisfy "sys-apps/util-linux" has unmet requirements.
- sys-apps/util-linux-2.27.1::gentoo USE="cramfs ncurses pam python readline static-libs suid udev unicode -caps -fdformat -kill -nls (-selinux) -slang -systemd -test -tty-helpers" ABI_X86="64 -32 -x32" PYTHON_SINGLE_TARGET="python3_3 -python2_7 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( python_single_target_python3_3? ( python_targets_python3_3 ) )

  The above constraints are a subset of the following complete expression:
    python? ( exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) )

(dependency required by "@system" [argument])


Your paste can be seen here: https://bpaste.net/show/3aad9927f196

 

If I uncomment the PYTHON_TARGETS="python2_7 python3_3" line in make.conf, I get:

# emerge --ask --update --newuse --deep --with-bdeps=y @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtxml-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                          

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                               
    (and 9 more with the same problem)

sys-fs/eudev:0

  (sys-fs/eudev-3.1.5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] required by (virtual/libudev-215-r1:0/1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                     

  (sys-fs/eudev-2.1.1:0/0::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection,static-libs] required by (virtual/libgudev-215:0/0::gentoo, installed)
                                              ^^^^^                                                                                      

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                          
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/harfbuzz-1.1.3:0/0.9.18::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                  

  (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by
    dev-libs/icu:0/55= required by (dev-qt/qtcore-5.4.2:5/5::gentoo, installed)
                ^^^^^^                                                          
    (and 15 more with the same problem)

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-5:0/0= required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
                    ^^^^^                                                                  

dev-python/setuptools:0

  (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_python3_3(-),python_targets_python2_7(-),-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)] required by (net-misc/youtube-dl-2015.09.28:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                            
    dev-python/setuptools[python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (dev-python/google-apputils-0.4.2:0/0::gentoo, installed)
                                                                                                                                                                
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-libs/protobuf-2.6.1-r3:0/9::gentoo, installed)
                                                                                                                                                           
    dev-python/setuptools[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (sys-libs/cracklib-2.9.6:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                         
    >=dev-python/setuptools-9.1[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cython-0.23.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/send2trash-1.3.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                  
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/gdal-2.0.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/netifaces-0.10.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                            
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ipython-3.2.1-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                            

  (dev-python/setuptools-18.2-r1000:0/0::gentoo, installed) pulled in by
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/six-1.9.0-r1001:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                  
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/paver-1.2.4-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/numpy-1.9.2-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/Babel-1.3-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                  
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/mako-1.0.0-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                   
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/cryptography-0.9.3-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                           
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/pytz-2014.10-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                     
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/chardet-2.3.0-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                      
    dev-python/setuptools[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^                                                             

dev-python/packaging:0

  (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/packaging-15.3:0/0::gentoo, installed) pulled in by
    dev-python/packaging[python_abis_2.7,python_abis_3.3] required by (dev-python/setuptools-18.2-r1000:0/0::gentoo, installed)
                         ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                        

dev-python/six:0

  (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/six-1.10.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    ^^               ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/six-1.9.0-r1001:0/0::gentoo, installed) pulled in by
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/cryptography-0.9.3-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                           
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/paver-1.2.4-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/pyopenssl-0.15.1-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                         

app-text/poppler:0

  (app-text/poppler-0.40.0-r1:0/58::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.33.0:0/52::gentoo, installed) pulled in by
    >=app-text/poppler-0.24.3:0/52= required by (sci-libs/gdal-2.0.0-r1:0/0::gentoo, installed)
                             ^^^^^^                                                             
    (and 2 more with the same problem)

dev-python/pygtk:2

  (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/pygtk[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
                                                                                                                                                  
    >=dev-python/pygtk-2.8:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
                                                                                                                                                                        
    >=dev-python/pygtk-2.8[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-vcs/git-2.7.0-r2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                               
    >=dev-python/pygtk-2.12[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-libs/keybinder-0.3.0-r201:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                        
    >=dev-python/pygtk-2.10.4:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-gfx/gimp-2.8.14-r1:2/2::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                       

  (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed) pulled in by
    dev-python/pygtk:2[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^^^                                                             
    >=dev-python/pygtk-2.24:2[python_abis_2.7] required by (dev-python/notify-python-0.1.1-r1000:0/0::gentoo, installed)
                              ^^^^^^^^^^^^^^^                                                                            
    dev-python/pygtk:2[python_abis_2.7] required by (dev-python/twisted-core-13.2.0-r1000:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^^^                                                                            

dev-python/pygobject:2

  (dev-python/pygobject-2.28.6-r55:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pygobject-2.28:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/gst-python-0.10.22-r1:0.10/0.10::gentoo, installed)
                                                                                                                                                                               
    >=dev-python/pygobject-2.15.2:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
                                                                                                                                                                               
    >=dev-python/pygobject-2.8:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-libs/libgpod-0.8.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                        
    dev-python/pygobject:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
                                                                                                                                                        
    >=dev-python/pygobject-2.26.8-r53:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                          
    >=dev-python/pygobject-2.15.3:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-libs/keybinder-0.3.0-r201:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                

  (dev-python/pygobject-2.28.6-r1000:2/2::gentoo, installed) pulled in by
    >=dev-python/pygobject-2.21.3:2[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                                    ^^^^^^^^^^^^^^^                                                                     
    dev-python/pygobject:2[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                           ^^^^^^^^^^^^^^^                                                             

dev-python/pycairo:0

  (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pycairo-1.0.2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                 
    dev-python/pycairo[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
                                                                                                                                                                  
    dev-python/pycairo[python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-editors/gedit-3.14.3:0/0::gentoo, installed)
                                                                                                                                                                                                                      

  (dev-python/pycairo-1.10.0-r1000:0/0::gentoo, installed) pulled in by
    >=dev-python/pycairo-1.0.2[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                               ^^^^^^^^^^^^^^^                                                                     

dev-python/numpy:0

  (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-gfx/inkscape-0.91:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                           
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                       
    dev-python/numpy[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/gdal-2.0.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                  
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
                                                                                                                                                   

  (dev-python/numpy-1.9.2-r1000:0/0::gentoo, installed) pulled in by
    dev-python/numpy[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                     ^^^^^^^^^^^^^^^                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-init-scripts-27-r1:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/eudev-3.1.5:0/0::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-init-scripts-27-r1 required by (sys-fs/eudev-2.1.1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Your paste can be seen here: https://bpaste.net/show/736e17e74a93

Share this post


Link to post
Share on other sites
  • 0

Just leaving some ideas here, if you want to try some slightly different approach, trying to upgrade @system as a first step is good if you haven't done upgrades in a while, but sometimes all the configurations (e.g. USE flags), make it so if you want to try to upgrade only what came with the stage3 you get more packages and  thus potential conflicts, so IMHO its better to try to get a basic and clean @system, from which you can then try upgrade your @world, I would suggest you to try the following steps, as to get a basic clean @system :

1. back up make.conf and package.use.  and put a minimal make.conf( an empty one will do it fine, the idea is going back to the minimal stuff that came with the stage3)

cd /etc/portage
mv make.conf make.conf.bak
mv package.use package.use.bak
touch make.conf

2. change the profile to the core flavor and disable any mixin

3. run emerge -ave @system (and wait, this will rebuild all of @system and all the dependecy tree, doing this is going one step further than using backtrack)

4. restore your personal make.conf, and package.use, flavor and mixins, and proceed to try upgrade world( I'd run emerge --with-bdeps=y -avuND --backtrack=30 world), also check you have not by mistake let any dependencies of packages get into world wich might cause slot conflicts, and delete them from /var/lib/portage/world.



PD: try not to put a PYTHON_SINGLE_TARGET in make.conf, if need you to specify a single target for a package, use package.use and "python_single_target_python_3_4" style useflags for that package, to avoid setting it globally in make.conf.

 

Share this post


Link to post
Share on other sites
  • 0

This is good stuff,I'm in for the duration.
The last sync replaces python-3.3 with python-3.4 and updates python-2.7
I had to build 59 packages on my updated system.
 

commit 8aeba912754fd2026151d002d751178ca61fb464
Author: Daniel Robbins <drobbins@funtoo.org>
Date:   Thu Feb 11 03:53:07 2016 -0700

There is no reason we have to deal with new update conflicts caused by this revision.
We will revert portage back to the previous revision:

commit 92c3a85f3e36927a869f2d721394b2a16bed5d26
Author: Daniel Robbins <drobbins@funtoo.org>
Date:   Tue Feb 9 22:19:17 2016 -0700

Undo the last sync:
 

# cd /usr/portage
# git checkout HEAD~1

After git checkout is done you should see this output:

M	app-admin/conky/files/conky-1.10.0-cmake.patch
Previous HEAD position was 8aeba91... merged from funtoo-staging
HEAD is now at 92c3a85... merged from funtoo-staging

Change make.conf and package.use to the configuration you had in Reply #30.
Verify you see the same boost warning and package update output with no conflicts or Blocks.
 

# emerge --pretend --update --newuse --deep --with-bdeps=y @world

If output is good, change @world to @system, if output is good go ahead and update @system first.

If the computer is unattended during update I use --keep-going option in case merge fails.

Emerge automatically recalculates dependencies and continues update.

Share this post


Link to post
Share on other sites
  • 0

@j-g- thanks for that advice, I will keep your points in mind.

 

@cardinal I don't get the exact same output with git-checkout, but HEAD is at the same place, so I assume it's OK:

# git checkout HEAD~1
Note: checking out 'HEAD~1'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b <new-branch-name>

HEAD is now at 92c3a85... merged from funtoo-staging

I've changed my make.conf and package.use back to #30... 

 

@world warns about boost but does not block:

# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    =dev-util/boost-build-1.57* required by (dev-libs/boost-1.57.0:0/1.57.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/boost:=[python,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (net-libs/rb_libtorrent-1.0.8:0/0::gentoo, ebuild scheduled for merge)
                                                                                        

Your paste can be seen here: https://bpaste.net/show/456a5a6c53b3 (I can only think this isn't identical above because I unmerged avidemux and avidemux-plugins... that's the only thing that's different to #30)

 

@system blocks:

# emerge --pretend --update --newuse --deep --with-bdeps=y @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtxml-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                          

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtconcurrent-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                
    (and 9 more with the same problem)

sys-fs/eudev:0

  (sys-fs/eudev-3.1.5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] required by (virtual/libudev-215-r1:0/1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                     

  (sys-fs/eudev-2.1.1:0/0::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection,static-libs] required by (virtual/libgudev-215:0/0::gentoo, installed)
                                              ^^^^^                                                                                      

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                          
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/harfbuzz-1.1.3:0/0.9.18::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                  

  (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by
    dev-libs/icu:0/55=[abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7:4/4::gentoo, installed)
                ^^^^^^                                                                         
    (and 15 more with the same problem)

dev-python/six:0

  (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/six-1.10.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    ^^               ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/six-1.9.0-r1001:0/0::gentoo, installed) pulled in by
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/pyopenssl-0.15.1-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                         
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/paver-1.2.4-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    
    dev-python/six[python_abis_2.7,python_abis_3.3] required by (dev-python/cryptography-0.9.3-r1000:0/0::gentoo, installed)
                   ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                           

dev-python/setuptools:0

  (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_python3_3(-),python_targets_python2_7(-),-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)] required by (net-misc/youtube-dl-2015.09.28:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                            
    dev-python/setuptools[python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (dev-python/google-apputils-0.4.2:0/0::gentoo, installed)
                                                                                                                                                                
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/gdal-2.0.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                
    dev-python/setuptools[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-libs/protobuf-2.6.1-r3:0/9::gentoo, installed)
                                                                                                                                                           
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/send2trash-1.3.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                  
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/netifaces-0.10.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                            
    >=dev-python/setuptools-9.1[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cython-0.23.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                
    dev-python/setuptools[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (sys-libs/cracklib-2.9.6:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                         
    dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ipython-3.2.1-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                            

  (dev-python/setuptools-18.2-r1000:0/0::gentoo, installed) pulled in by
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/six-1.9.0-r1001:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                  
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/cryptography-0.9.3-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                           
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/Babel-1.3-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                  
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/numpy-1.9.2-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/chardet-2.3.0-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                      
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/mako-1.0.0-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                   
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/pytz-2014.10-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                     
    dev-python/setuptools[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^                                                             
    dev-python/setuptools[python_abis_2.7,python_abis_3.3] required by (dev-python/paver-1.2.4-r1000:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                    

dev-python/packaging:0

  (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/packaging-15.3:0/0::gentoo, installed) pulled in by
    dev-python/packaging[python_abis_2.7,python_abis_3.3] required by (dev-python/setuptools-18.2-r1000:0/0::gentoo, installed)
                         ^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^^^                                                                        

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-5:0/0= required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
                    ^^^^^                                                                  

dev-python/pygobject:2

  (dev-python/pygobject-2.28.6-r55:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pygobject-2.26.8-r53:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                          
    dev-python/pygobject:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
                                                                                                                                                        
    >=dev-python/pygobject-2.28:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/gst-python-0.10.22-r1:0.10/0.10::gentoo, installed)
                                                                                                                                                                               
    >=dev-python/pygobject-2.8:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-libs/libgpod-0.8.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                        
    >=dev-python/pygobject-2.15.3:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-libs/keybinder-0.3.0-r201:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                
    >=dev-python/pygobject-2.15.2:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
                                                                                                                                                                               

  (dev-python/pygobject-2.28.6-r1000:2/2::gentoo, installed) pulled in by
    >=dev-python/pygobject-2.21.3:2[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                                    ^^^^^^^^^^^^^^^                                                                     
    dev-python/pygobject:2[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                           ^^^^^^^^^^^^^^^                                                             

dev-python/pygtk:2

  (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pygtk-2.8[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-vcs/git-2.7.0-r2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                               
    >=dev-python/pygtk-2.8:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
                                                                                                                                                                        
    dev-python/pygtk[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
                                                                                                                                                  
    >=dev-python/pygtk-2.10.4:2[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-gfx/gimp-2.8.14-r1:2/2::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/pygtk-2.12[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-libs/keybinder-0.3.0-r201:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                        

  (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed) pulled in by
    dev-python/pygtk:2[python_abis_2.7] required by (dev-python/twisted-core-13.2.0-r1000:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^^^                                                                            
    dev-python/pygtk:2[python_abis_2.7] required by (net-p2p/deluge-1.3.11:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^^^                                                             
    >=dev-python/pygtk-2.24:2[python_abis_2.7] required by (dev-python/notify-python-0.1.1-r1000:0/0::gentoo, installed)
                              ^^^^^^^^^^^^^^^                                                                            

dev-python/pycairo:0

  (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pycairo-1.0.2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                 
    dev-python/pycairo[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
                                                                                                                                                                  
    dev-python/pycairo[python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-editors/gedit-3.14.3:0/0::gentoo, installed)
                                                                                                                                                                                                                      

  (dev-python/pycairo-1.10.0-r1000:0/0::gentoo, installed) pulled in by
    >=dev-python/pycairo-1.0.2[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                               ^^^^^^^^^^^^^^^                                                                     

dev-python/numpy:0

  (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                       
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
                                                                                                                                                   
    dev-python/numpy[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/gdal-2.0.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                  
    dev-python/numpy[python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-gfx/inkscape-0.91:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                           

  (dev-python/numpy-1.9.2-r1000:0/0::gentoo, installed) pulled in by
    dev-python/numpy[python_abis_2.7] required by (dev-python/pygtk-2.24.0-r1000:2/2::gentoo, installed)
                     ^^^^^^^^^^^^^^^                                                                     

app-text/poppler:0

  (app-text/poppler-0.40.0-r1:0/58::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.33.0:0/52::gentoo, installed) pulled in by
    >=app-text/poppler-0.26.0:0/52=[cairo] required by (media-gfx/inkscape-0.91:0/0::gentoo, installed)
                             ^^^^^^                                                                     
    (and 2 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-init-scripts-27-r1:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-27-r1 required by (sys-fs/eudev-2.1.1:0/0::gentoo, installed)
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/eudev-3.1.5:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Your paste can be seen here: https://bpaste.net/show/5ae547d803ff

Share this post


Link to post
Share on other sites
  • 0

Still emerging. A bit of a hiccup after 228 packages of 594 emerged just fine, then libwpg borked. Just for future googlers:

 

from portage's summary.log:

>>> Messages generated by process 3072 on 2016-02-12 18:42:08 GMT for package app-text/libwpg-0.3.1:

ERROR: preinst
This package will overwrite one or more files that may belong to other
packages (see list below). You can use a command such as `portageq
owners / <filename>` to identify the installed package that owns a
file. If portageq reports that only one package owns a file then do
NOT file a bug report. A bug report is only useful if it identifies at
least two or more packages that are known to install the same file(s).
If a collision occurs and you can not explain where the file came from
then you should simply ignore the collision since there is not enough
information to determine if a real problem exists. Please do NOT file
a bug report at http://bugs.gentoo.org unless you report exactly which
two packages install the same file(s). See
http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
solve the problem. And once again, please do NOT file a bug report
unless you have completely understood the above message.

Detected file collision(s):

        /usr/lib64/pkgconfig/libwpg-0.3.pc
        /usr/include/libwpg-0.3/libwpg/WPGraphics.h
        /usr/include/libwpg-0.3/libwpg/libwpg.h
        /usr/lib64/libwpg-0.3.so.3
        /usr/lib64/libwpg-0.3.so

Searching all installed packages for file collisions...

Press Ctrl-C to Stop

app-text/libwpg-0.3.0:0.2::gentoo
        /usr/include/libwpg-0.3/libwpg/WPGraphics.h
        /usr/include/libwpg-0.3/libwpg/libwpg.h
        /usr/lib64/libwpg-0.3.so
        /usr/lib64/libwpg-0.3.so.3
        /usr/lib64/pkgconfig/libwpg-0.3.pc

Package 'app-text/libwpg-0.3.1' NOT merged due to file collisions. If
necessary, refer to your elog messages for the whole content of the
above message.

fixed by

# FEATURES="-collision-detect -protect-owned" emerge -1DNuv libwpg

... after which updating @world continues... (38 of 366 at the moment)...

 

If my fingers were crossed any harder, they'd dislocate.

Share this post


Link to post
Share on other sites
  • 0

woohoo! a couple more hiccups, and vlc-2.2.2 won't emerge (but that's the last package left!)... but it looks like I'm good to go.

 

Thanks to everyone who gave me advice, and especially cardinal for the patient help you gave.

 

Cheers!

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×