Jump to content
Sign in to follow this  
adessemond

there are no ebuilds to satisfy ">=virtual/pam-0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]

Recommended Posts


emerge: there are no ebuilds to satisfy ">=virtual/pam-0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]".
(dependency required by "net-fs/samba-3.6.23-r1" [installed])
(dependency required by "gnome-base/gnome-vfs-2.24.4-r2[samba]" [installed])
(dependency required by "media-video/vlc-2.1.4[gnome]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Something is clearly missing and the tree is currently broken...

Share this post


Link to post
Share on other sites

The tree *was* broken. I have added many ebuild updates to address this.

 

What is happening is that Gentoo is updating some ebuilds to be able to build 32-bit binaries on 64-bit systems in order to get rid of the emul-linux-x86 packages. This is resulting in lots of ebuilds in Gentoo depending on these new USE variables. The ebuilds in Funtoo need to be updated to provide 32-bit builds and thus these USE variables. This is impacting a lot of "core" ebuilds, which of course are the ones that we tend to have forked in Funtoo.

 

Jean-Francis is going to be testing my updates, and we should be pretty much on top of this issue from now on. However, as Gentoo transitions away from emul-linux-86, it is possible that you may see very similar build failures (missing abi_x86_32 USE flags in ebuilds) -- just report them on bugs.funtoo.org and we will get them fixed as soon as possible.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...