Jump to content

kde frameworks 5.9 not authorized to control networking


Recommended Posts

I've used layman and the advice here https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#Troubleshooting to install kde frameworks 5.9  with plasma 5.2. So far so good except for one hitch. I'm unable to control networking. When I try to make changes by clicking the network manager I receive this message: "not authorized to control networking."

I've googled a bit and have come up pretty empty.

I've made sure I'm part of netdev group and have rebooted with no effect.

1582 root # id chytraeus
uid=1000(chytraeus) gid=100(users) groups=100(users),10(wheel),18(audio),19(cdrom),27(video),104(plugdev),102(vboxusers),999(realtime),998(scanner),35(games),994(stb-admin),993(netdev)

In addition dbus is running:

1583 root # ps aux | grep dbus
message+ 10499  0.0  0.0  18080  2888 ?        Ss   May03   0:09 /usr/bin/dbus-daemon --system
root     16567  0.0  0.0  10576   844 pts/2    S+   17:17   0:00 grep --colour=auto dbus
chytrae+ 28356  0.0  0.0  26404  1784 tty1     S    May03   0:00 dbus-launch --sh-syntax --exit-with-session
chytrae+ 28357  0.0  0.0  18508  3024 ?        Ss   May03   0:02 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
chytrae+ 28821  0.0  0.0  17396  2396 ?        S    May03   0:00 /usr/bin/dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3

I have the following in my .xinitrc:

1584 root # cat /home/chytraeus/.xinitrc 
onsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
            xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
            xmodmap $usermodmap
fi

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
    ck-launch-session startkde
else
    startkde
fi

Desktop looks beautiful and is very functional but kind of worthless if I can't control networking. Has anyone resolved this issue?

Link to post
Share on other sites

yes i resolved it...  i also suggested we fork polkit console kit and network manager away from gentoo over this issue.  (though im not sure this is coming from gentoo anymore)

 

the network manager 0.9.9? ebuilds not placing the rules file in /usr/share/polkit-1/rules.d/

 

network manager 1 will insert the file, though i dont know if that networkmanager works or not.

root@spaceball-1 /usr/share/polkit-1/rules.d # cat 01-org.freedesktop.NetworkManager.settings.modify.system.rules 
// Let users in plugdev group modify NetworkManager
polkit.addRule(function(action, subject) {
    if (action.id == "org.freedesktop.NetworkManager.settings.modify.system" &&
        subject.isInGroup("plugdev") && subject.active) {
        return "yes";
    }
});

at the very bottom of this article is a rule to tell polkit to never ask those dialogs globally for wheel users =D

https://wiki.archlinux.org/index.php/Polkit

 

Link to post
Share on other sites

yes i resolved it...  i also suggested we fork polkit console kit and network manager away from gentoo over this issue.  (though im not sure this is coming from gentoo anymore)

 

the network manager 0.9.9? ebuilds not placing the rules file in /usr/share/polkit-1/rules.d/

 

network manager 1 will insert the file, though i dont know if that networkmanager works or not.

root@spaceball-1 /usr/share/polkit-1/rules.d # cat 01-org.freedesktop.NetworkManager.settings.modify.system.rules 
// Let users in plugdev group modify NetworkManager
polkit.addRule(function(action, subject) {
    if (action.id == "org.freedesktop.NetworkManager.settings.modify.system" &&
        subject.isInGroup("plugdev") && subject.active) {
        return "yes";
    }
});

at the very bottom of this article is a rule to tell polkit to never ask those dialogs globally for wheel users =D

https://wiki.archlinux.org/index.php/Polkit

I have the above in my /usr/share/polkit-1/rules.d/. But I am unable to connect. Perhaps I am misunderstanding your meaning. Thank you for the link.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...