Jump to content
Sign in to follow this  
upc0d3

emerge net-libs/gupnp -- failing

Recommended Posts

Hi guys,

I'm having an issue to update my funtoo, when I try to do:

# emerge -uDav @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] net-libs/gupnp-igd-0.2.5-r1::gnome-kit [0.2.5::gnome-kit] USE="(introspection) (-abi_riscv_lp64%) (-abi_riscv_lp64d%)" 0 KiB
[ebuild     U  ] net-libs/webkit-gtk-2.26.2:4/37::gnome-kit [2.24.3:4/37::gnome-kit] USE="(X) bwrap%* egl geolocation gnome-keyring gstreamer introspection jpeg2k libnotify nsplugin opengl wayland webgl (-aqua) -coverage -doc -gles2 -spell -test (-jit%*)" 0 KiB

 

I type "Yes", the merge starts but it fails with this message:

checking for LIBGUPNP... no
configure: error: Package requirements (glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0) were not met:

Package 'gssdp-1.0', required by 'virtual:world', not found
Package 'gupnp-1.0', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBGUPNP_CFLAGS
and LIBGUPNP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/work/gupnp-igd-0.2.5/config.log
 * ERROR: net-libs/gupnp-igd-0.2.5-r1::gnome-kit failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *               ebuild.sh, line  93:  Called src_configure
 *             environment, line 469:  Called econf '--disable-static' '--disable-gtk-doc' '--disable-python' '--enable-introspection'
 *        phase-helpers.sh, line 681:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line 112:  Called die
 * The specific snippet of code:
 *              die "$@"
 * 
 * If you need support, post the output of `emerge --info '=net-libs/gupnp-igd-0.2.5-r1::gnome-kit'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/gupnp-igd-0.2.5-r1::gnome-kit'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/work/gupnp-igd-0.2.5'
 * S: '/var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/work/gupnp-igd-0.2.5'

>>> Failed to emerge net-libs/gupnp-igd-0.2.5-r1, Log file:

>>>  '/var/tmp/portage/net-libs/gupnp-igd-0.2.5-r1/temp/build.log'

 

So, I tried to set my environment variable PKG_CONFIG_PATH, to:

# echo $PKG_CONFIG_PATH
/usr/lib/pkgconfig/

And when I tried to update again, I got the exact same message, it seems like it didn't even consider my environment variable.

(It can be because pkg-config already look into this place, maybe I'm not familiar with the internals of pkg-config)

One more thing is, the pkg-config it is coming from this package:

dev-util/pkgconf
      Latest version available: 1.5.4
      Latest version installed: 1.5.4
      Size of files: 284 KiB
      Homepage:      https://github.com/pkgconf/pkgconf
      Description:   pkg-config compatible replacement with no dependencies other than ANSI C89
      License:       ISC

 

But when I search for there is another pkg-config package which is:

dev-util/pkgconfig
      Latest version available: 0.29.2
      Latest version installed: [ Not Installed ]
      Size of files: 1,970 KiB
      Homepage:      https://pkgconfig.freedesktop.org/wiki/
      Description:   Package config system that manages compile/link flags
      License:       GPL-2

 

I'm not sure which one should I use.

Has someone face similar issue? Someone to help?

Thanks!

Share this post


Link to post
Share on other sites
9 hours ago, upc0d3 said:

Package 'gssdp-1.0', required by 'virtual:world', not found Package 'gupnp-1.0', required by 'virtual:world', not found

I would do like the message suggests and check if the packages

net-libs/gssdp

net-libs/gupnp

are installed. They are required for gupnp-idg

Share this post


Link to post
Share on other sites

Hi @jhan and @bcowan,

I do have the libs installed, but as bcowan said it is in the newer version not in the older version, see:

# emerge -s net-libs/gssdp
  
[ Results for search key : net-libs/gssdp ]
Searching...

*  net-libs/gssdp
      Latest version available: 1.2.1
      Latest version installed: 1.2.1
      Size of files: 60 KiB
      Homepage:      https://wiki.gnome.org/Projects/GUPnP
      Description:   A GObject-based API for handling resource discovery and announcement over SSDP
      License:       LGPL-2


# emerge -s net-libs/gupnp
  
[ Results for search key : net-libs/gupnp ]
Searching...

*  net-libs/gupnp
      Latest version available: 1.2.1
      Latest version installed: 1.2.1
      Size of files: 133 KiB
      Homepage:      https://wiki.gnome.org/Projects/GUPnP
      Description:   An object-oriented framework for creating UPnP devs and control points
      License:       LGPL-2

 

Should I downgrade the libs? If yes, how should I do that?

Thanks!

Share this post


Link to post
Share on other sites

@upc0d3 can you try emerge -1 =net-libs/gssdp-1.0.3 and emerge -1 =net-libs/gupnp-1.0.3 then emerge -1 gupnp-igd

the versions are slotted so they will install side by side...or both versions will be installed, however you wish to say it 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...