Jump to content
funtoo forums
Sign in to follow this  
upc0d3

AMD FirePro V4900 - Configuration help

Recommended Posts

Hi guys,

I've upgraded my Funtoo to 1.4, following the recommendation here: https://www.funtoo.org/Upgrade_Instructions/1.4-release

Almost everything went well, I manage to complete the upgrade but I'm having some issues regarding my graphic card.

The main problem is I'm not sure how it should be configured I've being searching and reading a lot about graphic cards and DRM/DRI, Mesa, Radeon drivers, etc.

But a lot of confusion, I could get a good basic understanding on this by reading this: 

Very good explanation by the way.

 

Now, yes I can open KDE 5 no problem, so something is working fine, But it is very slow specially to start..

What I believe I need to do is to configure the 3D acceleration part.

My Graphic Card is: AMD FirePro V4900 (https://www.techpowerup.com/gpu-specs/firepro-v4900.c578)

One thing, the GPU processor is Turks, not sure if this information help.

From what I understood it's a professional graphic card it is designed to work mainly with CAD tools, so in theory I should use the driver amdgpu-pro (but this is proprietary and there is no Funtoo package), So instead I'm using the radeon driver.

Has someone already configured this graphic card? What is the stack that you used? Has someone know how to configure this?

Any guidance on how to do it correctly would be great.

 

Thanks!

Edited by upc0d3
Adding information

Share this post


Link to post
Share on other sites

Did you follow the instructions on this page to set a Mix-In to enable the drivers for your graphics card?

https://www.funtoo.org/Install/Profiles

Run "epro show" to see what mix-ins you have set.  Although your card says AMD it looks like it's a "Northern Islands" generation which would use the gfxcard-radeon mix-in.

 

 

Share this post


Link to post
Share on other sites

Hi,

My upgraded 1.3->1.4 funtoo has an ASUS HD6450 Silent graphics card with a Northern Islands Caicos chipset.

I have lxde and  gfxcard-radeon mix-ins locked in.

Direct rendering verified with glxgears and glxinfo owned by x11-apps/mesa-progs-8.3.0

Share this post


Link to post
Share on other sites

Hi @cardinal,

Can you share your kernel config? Your make.conf? And your xorg configuration?

 

I don't think I have Direct rendering, because when I try to run the glxgears, it gives me an error saying: "libGL not found", but the gears itself are displayed.

Share this post


Link to post
Share on other sites

Hi guys, some more information regarding my system, anything else required to understand my problem, please let me know I'll post it here.

glxgears output:

"# glxgears
MESA-LOADER: failed to open r600 (search paths /usr/lib64/dri)
libGL error: failed to load driver: r600"

As I said, I get this error but the glxgears screen still open up.

lspci output:
 

"# lspci -k |grep VGA
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks GL [FirePro V4900]"

"02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks GL [FirePro V4900]
        Subsystem: Dell Turks GL [FirePro V4900]
        Kernel driver in use: radeon
        Kernel modules: radeon"

dmesg output:

"# dmesg |grep drm
[    9.035959] [drm] radeon kernel modesetting enabled.
[    9.383694] [drm] initializing kernel modesetting (TURKS 0x1002:0x6749 0x1028:0x240A 0x00).
[    9.383995] [drm] Detected VRAM RAM=1024M, BAR=256M
[    9.383996] [drm] RAM width 128bits DDR
[    9.384161] [drm] radeon: 1024M of VRAM memory ready
[    9.384162] [drm] radeon: 1024M of GTT memory ready.
[    9.384170] [drm] Loading TURKS Microcode
[    9.755395] [drm] Internal thermal controller with fan control
[    9.760221] [drm] radeon: dpm initialized
[    9.786990] [drm] GART: num cpu pages 262144, num gpu pages 262144
[    9.787642] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[    9.809239] [drm] PCIE GART of 1024M enabled (table at 0x0000000000162000).
[    9.810104] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    9.810104] [drm] Driver supports precise vblank timestamp query.
[    9.810171] [drm] radeon: irq initialized.
[    9.826539] [drm] ring test on 0 succeeded in 2 usecs
[    9.826549] [drm] ring test on 3 succeeded in 7 usecs
[   10.002321] [drm] ring test on 5 succeeded in 2 usecs
[   10.002329] [drm] UVD initialized successfully.
[   10.002490] [drm] ib test on ring 0 succeeded in 0 usecs
[   10.002569] [drm] ib test on ring 3 succeeded in 0 usecs
[   10.683449] [drm] ib test on ring 5 succeeded
[   10.684046] [drm] Radeon Display Connectors
[   10.684047] [drm] Connector 0:
[   10.684047] [drm]   DP-1
[   10.684048] [drm]   HPD1
[   10.684049] [drm]   DDC: 0x6470 0x6470 0x6474 0x6474 0x6478 0x6478 0x647c 0x647c
[   10.684049] [drm]   Encoders:
[   10.684050] [drm]     DFP1: INTERNAL_UNIPHY2
[   10.684050] [drm] Connector 1:
[   10.684050] [drm]   DP-2
[   10.684051] [drm]   HPD5
[   10.684052] [drm]   DDC: 0x6460 0x6460 0x6464 0x6464 0x6468 0x6468 0x646c 0x646c
[   10.684052] [drm]   Encoders:
[   10.684052] [drm]     DFP2: INTERNAL_UNIPHY1
[   10.684053] [drm] Connector 2:
[   10.684053] [drm]   DVI-I-1
[   10.684053] [drm]   HPD4
[   10.684054] [drm]   DDC: 0x6450 0x6450 0x6454 0x6454 0x6458 0x6458 0x645c 0x645c
[   10.684054] [drm]   Encoders:
[   10.684055] [drm]     DFP3: INTERNAL_UNIPHY
[   10.684055] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   10.785070] [drm] fb mappable at 0xE0363000
[   10.785072] [drm] vram apper at 0xE0000000
[   10.785073] [drm] size 8294400
[   10.785074] [drm] fb depth is 24
[   10.785075] [drm]    pitch is 7680
[   10.785209] fbcon: radeondrmfb (fb0) is primary device
[   10.980467] radeon 0000:02:00.0: fb0: radeondrmfb frame buffer device"

 

epro show output:

# epro show

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: generic_64
      flavor: desktop
     mix-ins: kde-plasma-5
     mix-ins: gfxcard-radeon


=== Python kit: ===

      branch: 3.7-release

=== All inherited flavor from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

=== All inherited flavor from kde-plasma-5 mix-ins: ===

                         desktop (from gnome-kit:gnome mix-in)
                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from kde-plasma-5 mix-ins: ===

                         wayland (from kde-plasma-5 mix-in)
                           gnome (from kde-plasma-5 mix-in)
                 gnome-kit:gnome (from gnome mix-in)
                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

 

Share this post


Link to post
Share on other sites

Hi @upc0d3

Not sure if xorg-x11 is the opengl provider for your card but could be. @cardinal might be able to tell more.

To get more output from glxgears you can use

LIBGL_DEBUG=verbose glxgears

You can also use

glxinfo|grep DRI

to see information about DRI usage. That should also be visible in the Xorg log file:

cat /var/log/Xorg.0.log|grep DRI

In that regard it would also be interesting to see what USE flags are used for mesa and xorg-drivers and what driver xorg is using.

It might also help to have a look at the gentoo wiki page to see if there is something that might help.

Share this post


Link to post
Share on other sites

Hi @jhan,

I do believe it is not the correct provider, but I don't have other (not sure how to install)

Regarding the info:

# LIBGL_DEBUG=verbose glxgears
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /root/.drirc: No such file or directory.
MESA-LOADER: failed to open r600 (search paths /usr/lib64/dri)
libGL error: failed to load driver: r600
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /root/.drirc: No such file or directory.
3931 frames in 5.0 seconds = 786.019 FPS
# glxinfo |grep DRI
MESA-LOADER: failed to open r600 (search paths /usr/lib64/dri)
libGL error: failed to load driver: r600

 

# cat /var/log/Xorg.0.log|grep DRI
[    25.994] (II) RADEON(0): [DRI2] Setup complete
[    25.994] (II) RADEON(0): [DRI2]   DRI driver: r600
[    25.994] (II) RADEON(0): [DRI2]   VDPAU driver: r600
[    25.995] (==) RADEON(0): DRI3 disabled
[    25.998] (II) Initializing extension DRI3
[    26.000] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[    26.000] (II) Initializing extension XFree86-DRI
[    26.000] (II) Initializing extension DRI2

 

When I had done this before, I thought the problem is because the mesa is not having the VIDEO_CARDS flag with the driver "r600" instead it is having "radeon".

But in the USE flags it has only the "gallium-r600" and it sees to be incompatible to be merged together, see:

# VIDEO_CARDS="gallium-r600" emerge -avt mesa

These are the packages that would be merged, in reverse order:

Calculating dependencies /

!!! Problem resolving dependencies for media-libs/mesa
... done!

!!! The ebuild selected to satisfy "mesa" has unmet requirements.
- media-libs/mesa-19.1.4::core-gl-kit USE="(X) (drm) (egl) (gbm) (gles1) (gles2) (glvnd) (glx) (llvm) (ocl-icd) (opengl) (shader-cache) (surfaceless) wayland -alternate-path -android -d3d9 -debug -extra-hud -haiku -opencl -pax_kernel -pic (-selinux) -sensors -test -unwind -valgrind" CPU_FLAGS_X86="-avx -avx2 -avx512bw -avx512er" VIDEO_CARDS="gallium-r600 (osmesa) (swrast) -amdgpu -dri3 -gallium-freedreno -gallium-i915 -gallium-imx -gallium-nouveau -gallium-osmesa -gallium-pl111 -gallium-r300 -gallium-radeonsi -gallium-swr -gallium-swrast -gallium-tegra -gallium-v3d -gallium-vc4 -gallium-virgl -gallium-vivante -gallium-vmware -i915 -i965 -intel -nouveau -openmax -r100 -r200 -radeon -vaapi -vdpau -virgl -vulkan-amdgpu -vulkan-intel -xa -xvmc"

  The following REQUIRED_USE flag constraints are unsatisfied:
    video_cards_gallium-r600? ( video_cards_radeon )

  The above constraints are a subset of the following complete expression:
    d3d9? ( video_cards_gallium-swrast ) opencl? ( llvm any-of ( video_cards_gallium-pl111 video_cards_gallium-radeonsi video_cards_gallium-r300 video_cards_gallium-r600 video_cards_gallium-nouveau video_cards_gallium-freedreno video_cards_gallium-vc4 video_cards_gallium-v3d video_cards_gallium-vivante video_cards_gallium-imx video_cards_gallium-tegra video_cards_gallium-i915 video_cards_gallium-vmware video_cards_gallium-virgl video_cards_gallium-swr ) ) at-most-one-of ( video_cards_i915 video_cards_gallium-i915 ) at-most-one-of ( video_cards_swrast video_cards_gallium-swrast ) at-most-one-of ( video_cards_osmesa video_cards_gallium-osmesa ) video_cards_vulkan-intel? ( video_cards_intel ) video_cards_i915? ( video_cards_intel ) video_cards_i965? ( video_cards_intel ) video_cards_gallium-i915? ( video_cards_intel ) video_cards_r100? ( video_cards_radeon ) video_cards_r200? ( video_cards_radeon ) video_cards_gallium-r300? ( video_cards_radeon ) video_cards_gallium-r600? ( video_cards_radeon ) video_cards_amdgpu? ( video_cards_radeon ) video_cards_vulkan-amdgpu? ( video_cards_radeon ) wayland? ( egl gbm ) video_cards_gallium-swrast? ( llvm ) video_cards_gallium-swr? ( any-of ( cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512er cpu_flags_x86_avx512bw ) ) video_cards_gallium-imx? ( video_cards_gallium-vivante ) video_cards_gallium-tegra? ( video_cards_gallium-nouveau ) video_cards_gallium-r300? ( x86? ( llvm ) amd64? ( llvm ) ) video_cards_gallium-radeonsi? ( llvm egl? ( any-of ( drm surfaceless ) ) ) video_cards_gallium-pl111? ( video_cards_gallium-vc4 ) video_cards_gallium-virgl? ( egl? ( any-of ( drm surfaceless ) ) ) video_cards_gallium-vivante? ( gbm )

 

And one more thing I read in the "https://www.x.org/wiki/RadeonFeature/", that for 2D the kernel driver should be "radeon" and for 3D should be "r600g", but I'm not sure how to get this "r600g" .

Thanks!

Share this post


Link to post
Share on other sites

If you have set gfxcard-radeon as a mix-in, gallium-r600 is already set as VIDEO_CARDS:

farout $ more /var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/mix-ins/gfxcard-radeon/make.defaults 
# reference:
# https://www.x.org/wiki/RadeonFeature/
# https://wiki.gentoo.org/wiki/Radeon
# profile covers: r600 <= chipset <= N.Islands
# GFX Core 4 and 5
VIDEO_CARDS="radeon r600 gallium-r600"
USE="glamor vdpau vaapi"

But so is radeon, which makes your mesa warning above look a bit suspicious but I see no profile setting that would disable it. Are you sure your local /etc/portage/ files don't accidentally contain anything that would disable it?

And my guess for the r600g would be that that is the gallium-r600.

 

Share this post


Link to post
Share on other sites

Hi @jhan,

 

what do you mean by "don't accidentally contain anything that would disable it?"
I'm sure that I haven't added anything manually in this directory.

Once I'm home I'll check the files and post here, but not sure how can be disabling.

 

Thanks!

Share this post


Link to post
Share on other sites

He means to make sure that you don't have anything in make.conf or package.* that would be contradicting the video card settings being established by the mix-in.   Make sure that you're not setting VIDEO_CARDS in make.conf, for example.

Also try "equery u xorg-drivers" to verify that your USE settings are correct.

Share this post


Link to post
Share on other sites
17 minutes ago, upc0d3 said:

Hi @nrc,

 

thanks for the reply.

Yes, I do have the VIDEO_CARDS="radeon" in my make.conf.

I'll remove it and build xorg and mesa again.

That might be a good idea, as the VIDEO_CARDS setting in make.conf seems to have priority over the mix-ins setting.

I tested that locally by adding the gfxcard-radeon mix-in but the USE flags for xorg-drivers and mesa only changed after I removed the VIDEO_CARDS line from make.conf.

A 'emerge -pv mesa xorg-drivers' would probably enough to see if a rebuild would change anything.

Share this post


Link to post
Share on other sites

Hi @jhan,

I did something right and something wrong.

I manage to remove the VIDEO_CARDS from the make.conf and rebuild the mesa and xorg-drivers.

Now it added in the VIDEO_CARDS the fbdev (not sure if it should happen), see:

# emerge -pv mesa xorg-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-base/xorg-drivers-1.20::xorg-kit  INPUT_DEVICES="evdev keyboard mouse synaptics -elographics -joystick -libinput -tslib -vmmouse -void -wacom" VIDEO_CARDS="fbdev radeon -amdgpu -ast -dummy (-freedreno) -gallium-radeonsi -gallium-tegra (-geode) -glint -i915 -i965 -intel -mga -nouveau -nv -nvidia (-omap) -qxl -r128 -radeonsi -siliconmotion (-tdfx) (-tegra) (-vc4) -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB
[ebuild   R    ] media-libs/mesa-19.1.4::core-gl-kit  USE="(X) (drm) (egl) (gbm) (gles1) (gles2) (glvnd) (glx) (llvm) (ocl-icd) (opengl) (shader-cache) (surfaceless) wayland -alternate-path -android -d3d9 -debug -extra-hud -haiku -opencl -pax_kernel -pic (-selinux) -sensors -test -unwind -valgrind" CPU_FLAGS_X86="-avx -avx2 -avx512bw -avx512er" VIDEO_CARDS="gallium-r600 (osmesa) radeon (swrast) vaapi vdpau xa xvmc -amdgpu -dri3 -gallium-freedreno -gallium-i915 -gallium-imx -gallium-nouveau -gallium-osmesa -gallium-pl111 -gallium-r300 -gallium-radeonsi -gallium-swr -gallium-swrast -gallium-tegra -gallium-v3d -gallium-vc4 -gallium-virgl -gallium-vivante -gallium-vmware -i915 -i965 -intel -nouveau -openmax -r100 -r200 -virgl -vulkan-amdgpu -vulkan-intel" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB

 

This is after remerged.

I also merged one more eselect module, which is: " xvmc                      Manage the XvMC implementation used by your system"

And I set it with xorg-x11, because I have only this option:

# eselect xvmc list
Available XvMC implementations (* is current):
  [1]   xorg-x11 *

The OpenGL didn't changed:

# eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *

The X.org log:

# cat /var/log/Xorg.0.log |grep DRI
[  1759.306] (II) RADEON(0): [DRI2] Setup complete
[  1759.306] (II) RADEON(0): [DRI2]   DRI driver: r600
[  1759.306] (II) RADEON(0): [DRI2]   VDPAU driver: r600
[  1759.306] (==) RADEON(0): DRI3 enabled
[  1759.308] (II) Initializing extension DRI3
[  1759.312] (II) GLX: Initialized DRI2 GL provider for screen 0
[  1759.312] (II) Initializing extension XFree86-DRI
[  1759.312] (II) Initializing extension DRI2

 

But after I did this, I can't open the KDE using Plasma, only using Plasma (Wayland). And in this Plasma (Wayland) I can't open glxgears nor play videos for instance.

What am I missing here?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi @nrc,

 

I didn't have the xorg.conf file, in the directory /etc/X11/xorg.conf.d/ I had only 20opengl.conf and radeon.conf

I did generate the xorg.conf by running X -configure, but I have had the same result with my graphic environment, see my conf files:

/etc/X11/xorg.conf.d # cat 20opengl.conf 
Section "Files"
EndSection
/etc/X11/xorg.conf.d # cat radeon.conf 
Section "Device"
        Identifier "Radeon"
        Driver "radeon"
EndSection
/etc/X11/xorg.conf.d # cat xorg.conf 
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/OTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                     # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "EnablePageFlip"            # [<bool>]
        #Option     "ColorTiling"               # [<bool>]
        #Option     "ColorTiling2D"             # [<bool>]
        #Option     "RenderAccel"               # [<bool>]
        #Option     "SubPixelOrder"             # [<str>]
        #Option     "AccelMethod"               # <str>
        #Option     "ShadowPrimary"             # [<bool>]
        #Option     "EXAVSync"                  # [<bool>]
        #Option     "EXAPixmaps"                # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        #Option     "SwapbuffersWait"           # [<bool>]
        #Option     "DeleteUnusedDP12Displays"  # [<bool>]
        #Option     "DRI3"                      # [<bool>]
        #Option     "DRI"                       # <i>
        #Option     "TearFree"                  # [<bool>]
        Identifier  "Card0"
        Driver      "radeon"
        BusID       "PCI:2:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

 

According to the xorg.conf file it is using the driver radeon, should it be r600?

One thing after I generated the xorg.conf I did restart my machine, just make sure that I'm using the correct file.

Share this post


Link to post
Share on other sites
On 10/16/2019 at 11:12 PM, upc0d3 said:

wayland (from kde-plasma-5 mix-in)

If you can only start wayland but don't want or need it. You could etiher remove the wayland mix-in (which you inherited) or use the '-wayland' USE flag. That should at least give you you the possibility to to start plasma normally.

Share this post


Link to post
Share on other sites
6 hours ago, upc0d3 said:

According to the xorg.conf file it is using the driver radeon, should it be r600?

One thing after I generated the xorg.conf I did restart my machine, just make sure that I'm using the correct file.

I'm running nvidia so I'm not sure.  In my install the driver entry in the xorg.conf file matches the xorg log file entry for DRI driver.

If that file was generated before your latest changes you might try regenerating it with "Xorg -configure"

Share this post


Link to post
Share on other sites
13 hours ago, upc0d3 said:

[ 1759.306] (II) RADEON(0): [DRI2] DRI driver: r600

The radeon driver is correct. The name of the driver is just radeon but it supports many different versions of similar cards: https://www.x.org/releases/current/doc/man/man4/radeon.4.xhtml

 

Share this post


Link to post
Share on other sites

Hi @nrc,

according to the xorg log file that I've post previously I should set r600, which I tried and it didn't work saying the driver was not found.

I changed to "fbdev" and it got even worse (I know this was going to happen, but I had to try)

In fact I did generate the xorg.conf using "X -configure" after latest changes.

@jhan, I don't mind to use "wayland" actually, because I don't even understand it yet, I've always used Xorg and KDE.

But what happens is that after I remove the VIDEO_CARDS from the make.conf file and reemerged xorg-drivers and mesa I can't actually use Xorg + KDE (it try to load but it doesn't load, it seems stuck), I can only load my KDE when I change it to "wayland".

I will read your link.

Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, upc0d3 said:

 

@jhan, I don't mind to use "wayland" actually, because I don't even understand it yet, I've always used Xorg and KDE.

But what happens is that after I remove the VIDEO_CARDS from the make.conf file and reemerged xorg-drivers and mesa I can't actually use Xorg + KDE (it try to load but it doesn't load, it seems stuck), I can only load my KDE when I change it to "wayland".

As plasma also has the wayland USE flag, I said it might be good to try to build the system without this USE flag first. To not have a "mixed state", where one part supports wayland and one not.

As far as I know, wayland is not yet ready for "general use", there are too many things that don't work yet or still need the use of XWayland, depending on the desktop environment you want to use. Gnome seems to be working fine, KDE plasma e.g still has some problems (https://community.kde.org/Plasma/Wayland_Showstoppers) and no idea about the others.  At the moment I wouldn't use it as my normal desktop, unless I have tested all applications under it first, probably on another computer.

And if you say that Xorg+KDE seems to get stuck, how far does it get? How are you starting it? Any messages in the Xorg protocol or dmesg?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...