Jump to content
funtoo forums
walterw

characters in terminator are squished together [SOLVED]

Recommended Posts

I recently rebuilt my system to use the new 1.4 release and am still working out a few kinks which may be self-induced.  I kept many of the previous use flags I had before, so maybe I should start anew?  In any case, I compared the list of packages from my old image to the current one and don't see anything around fonts.  The fonts also work well everywhere else, chromium, libreoffice, geany, etc.

The only place where they're "messed up" is in terminator.  Even if I go to an old console (from bootup), the fonts are easy to read and not squished together.

The characters are over top of one another horizontally making it very difficult to read.  I tried playing with the font settings, but that didn't get me anywhere.

terminator-screenshot.png

Share this post


Link to post
Share on other sites

Thanks - I don't have an .Xresources and I did try playing with those font settings.  Also, my old system does not have a .Xresources either.

On a random note, I noticed that between 1.3 and 1.4, the path to libraries has changed, I think the 64 was dropped and it is just /lib or something.  I wonder if that might be related ...

Also, I'm not sure if it helps or not, but the fonts all look perfectly fine when previewing them in terminator's configuration, but once I choose them, that is when the appear squished like above.

 

Walter

Share this post


Link to post
Share on other sites

I installed xfce4-terminal and st and both display just fine.

I am leaning toward migrating to xfce4-terminal since it is fairly lightweight, written in c versus python (I've had some annoyances in the past where terminator would hangup when I was doing a fair amount of I/O in the terminal), and still has tabs.  I use a tiling WM, so terminator doesn't provide anything I cannot do with my WM with better performance.

 

I am curious as to what happened that is causing this issue, but in the end, I am planning to migrate back toward xfce4-terminal.

 

Walter

Share this post


Link to post
Share on other sites
3 hours ago, cardinal said:

Using a fixed width monospaced font may fix the problem.  Open  terminator preferences, global tab,  uncheck "Use the system font".

Install and test various monospaced fonts by selecting them from the drop-down menu to the right of Font:

Okay, I think you're right.  So, I think I thought I must have selected a monospaced font, but did not.  When I selected the Deja Vu Sans Book Mono, it looks good, but when I select just a Deja Vu Sans (non-mono), I have the problem.

Okay, that explains it.

font-selection.png

font-selection.png

Share this post


Link to post
Share on other sites

@walterw you have found a legitimate bug.

I have seen this issue as well but have not fixed it yet.

My guess is that it is caused by GNOME missing a font set like Liberation Fonts which it uses by default. So I believe the ultimate solution is to conclusively determine what font is missing and then add this as a dependency of the terminal app and/or GNOME itself.

I believe that is a correct fix. What you have done -- while it works -- is a workaround. It should just work by default, with no workaround required.

Edited by drobbins

Share this post


Link to post
Share on other sites

Agreed, so what you need me to do is to switch back to the default and then I think I have a utility installed that lists all the open files (strace?) during execution and see which ones are reported as file does not exist?  Then, that should be very clear which font is missing?

I would be happy to do that, just need a teeny, tiny bit of guidance (if the above approach sounds reasonable) :).

Share this post


Link to post
Share on other sites

Frankly I am not sure. Probably what I would do is emerge liberation-fonts, and then see if the problem goes away. Then emerge another font set if that doesn't solve it, see if that fixes it. It is probably a very common font set and I'd bet it's liberation-fonts.

I don't think strace will show you what you want. There is already a catalog of fonts, and I don't think it's going to try to do any IO to load the font it needs. It will just look in the catalog and see it's not available.

Share this post


Link to post
Share on other sites

I do have liberation-fonts installed.  I built terminator for python 3.6, I see it is looking for python 2.7.  Also, on a possibly related note, I was attempting to watch videos in VLC and on my new image, the video doesn't play very well at all.  I suspect there may be an issue with my opengl setup?  Perhaps it is related?

It does report file not found for libGldispatch.so.0 and lib64/charset.alias.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...