Jump to content
  • 0
Sign in to follow this  
kris

How to update the gentoo-sources with genkernel --zfs initramfs

Question

What am I doing wrong when updating kernel gentoo-sources with genkernel --zfs initramfs

# make -j5 bzImage modules && make install && make modules_install
# cd /boot
# ls
System.map-3.15.1-gentoo-kris      initramfs-genkernel-x86_64-3.15.1-gentoo-kris
System.map-3.15.1-gentoo-kris.old  initramfs-genkernel-x86_64-3.17.2-gentoo-kris
System.map-3.17.2-gentoo-kris      lost+found
boot                               splash.jpg
config-3.15.1-gentoo-kris          vmlinuz-3.15.1-gentoo-kris
config-3.15.1-gentoo-kris.old      vmlinuz-3.15.1-gentoo-kris.old
config-3.17.2-gentoo-kris          vmlinuz-3.17.2-gentoo-kris
grub
funtoo kris # cd /boot
funtoo boot # ls
System.map-3.15.1-gentoo-kris      initramfs-genkernel-x86_64-3.15.1-gentoo-kris
System.map-3.15.1-gentoo-kris.old  initramfs-genkernel-x86_64-3.17.2-gentoo-kris
System.map-3.17.2-gentoo-kris      lost+found
boot                               splash.jpg
config-3.15.1-gentoo-kris          vmlinuz-3.15.1-gentoo-kris
config-3.15.1-gentoo-kris.old      vmlinuz-3.15.1-gentoo-kris.old
config-3.17.2-gentoo-kris          vmlinuz-3.17.2-gentoo-kris
grub

# genkernel --zfs initramfs
# boot-update
boot-update 1.7.1 /
Copyright 2009-2012 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

 * Generating config for grub...

 DEFAULT > Funtoo ZFS - vmlinuz-3.15.1-gentoo-kris
           Funtoo ZFS - vmlinuz-3.17.2-gentoo-kris
 * WARN : No boot/default match found - using first boot entry by default.
 * Completed successfully with warnings.

Reboot ....

>> Importing ZFS pool tank
Failed to load ZFS module stack,
Load the module manually by running 'insmod <location>/zfs.ko' ass root,
!! Importing tank failed 
>> Determinning root device...
Failed to load ZFS module stack,
Load the module manually by running 'insmod <location>/zfs.ko' ass root,
!! tank/funtoo/root is not a filesystem
!! Could not find the root block device in ZFS=tank/funtoo/root,
Please specify another value or: press Enter for the same, type "shell" for a shell,
root block device(ZFS=tank/funtoo/root) :: _

Regards

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I added:

# make modules_prepare
# emerge --ask @module-rebuild
[ebuild   R    ] sys-kernel/spl-0.6.3 
[ebuild   R    ] sys-fs/zfs-kmod-0.6.3

this kernel (3.17.2-gentoo) does not support modules:   spl-0.6.3,  zfs-kmod-0.6.3

* ERROR: sys-fs/zfs-kmod-0.6.3 failed (setup phase):
 *   Linux 3.16 is the latest supported version.
 * 
 * Call stack:
 *               ebuild.sh, line  93:  Called pkg_setup
 *   zfs-kmod-0.6.3.ebuild, line  71:  Called die
 * The specific snippet of code:
 *      [ ${PV} != "9999" ] && \
 *              { kernel_is le 3 16 || die "Linux 3.16 is the latest supported version."; }

I have to wait for upgrade modules: spl, zfs-kmod

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...