Jump to content
stamasd

Duration of 1.3 support?

Recommended Posts

Now with 1.4 up, how long will 1.3 be supported?

Here is the reason for my question. Yesterday I started experimenting with upgrading from 1.3 to 1.4. On a test machine (Core2Duo, 2 cores at 2.53GHz, -j2) I first installed a minimal 1.3 system, basically just the stage3 and a couple extra packages (firmware for wifi card etc). Then I started upgrading it to 1.4 as per instructions. The first part of the process, up to and including gcc, took over 9h. I stopped there for now as the day was running out, I'll continue later to get a total time for this minimal system.

Now, my main system that I'm looking at upgrading isn't that much more powerful; it's a laptop with dual-core Ivy Bridge CPU at 2.6GHz. Yes it is hyperthreaded so I can expect 1.5 to 2x the performance maybe. But it's not a minimal system so I'll have to budget a couple of days at least to upgrade it to 1.4, and I'd like to plan that in advance a few months. I'm hoping thus that 1.3 will continue to be supported at least through the end of the year.

 

Share this post


Link to post
Share on other sites

... and i add: 1.3 version is actually fully supported? 

I think that a stable version (instead a rolling release) can be a good idea, but it must to be fully manteined and long term supported. Debian model is good, for example. 

At present 1.3 release seems to be forgotten. For example: why add a new version of "conky" to repository without dependances? 

And security update?

 

 

 

Share this post


Link to post
Share on other sites
On 8/31/2019 at 5:43 AM, ser said:

At present 1.3 release seems to be forgotten. For example: why add a new version of "conky" to repository without dependances? 

And security update?

FWIW, upgrade to conky is held back because of lua version. Latest conky wants lua-5.3 while 1.3-release uses lua 5.1.x

As you pointed out...this isn't a rolling release. This is that cost/benefit of rolling release vs stable release as you allude to.

Share this post


Link to post
Share on other sites
13 hours ago, digifuzzy said:

FWIW, upgrade to conky is held back because of lua version. Latest conky wants lua-5.3 while 1.3-release uses lua 5.1.x

As you pointed out...this isn't a rolling release. This is that cost/benefit of rolling release vs stable release as you allude to.

the point is: why add conky new version if it isn't installable? It is better not to add it or add lua new version too.

If you decide to choice release model instead rolling model, i think that is better "first maintain stable version and then develop the new".

At present, it seems that "first develop new version, then maintain the current stable version".

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...