Jump to content
funtoo forums
Sign in to follow this  
drobbins

GNOME 3.32 is working well

Recommended Posts

Hey everyone,

Just wanted to let you know that as of last night, I am happily running GNOME 3.32 with no issues (I did need to fix librsvg to get SVG's to display properly, but after that, it's working great.) I successfully upgraded my dev workstation from 1.3 to 1.4. If you want to upgrade from 1.3, or install a fresh 1.4 using one of our 1.4 stages (now available for Intel only), things should work well. 

One thing to note, on both the beta 1.4 stages and a 1.3 upgrade, you will need to manually run "eselect python set --python3 python3.7" to set python3.7 to be the default python interpreter instead of 3.6. Our stages will be fixed to have this set already but this is not done yet. I will also include a copy of my post from another place on the forums about upgrading from 1.3:

So, upgrade is pretty easy this time around.I will have instructions soon. But you can basically use "standard" upgrade steps. I recommend emerge -1 glibc gcc first, then emerge -auDN @world should generally work. Report any bugs related to upgrade like failed builds because often this can be fixed by tweaking dependencies. Overall the upgrade is MUCH easier than 1.2 -> 1.3.

One trick is to remember to "eselect python set --python3 python3.7" after python-3.7 is emerged to make it default. Also, mesa right now is very picky about USE flags related to video card. For example, if you don't have a card that supports vulkan, you cannot have vulkan in USE. Same with xa and other things that were more "permissible" before.

As of yesterday, I am now happily running gnome 3.32 and it is working perfectly. I would still call things "in beta" but the remaining issues (there is a "reboot doesn't work" issue currently active, due to a missing /run/initctl -> /dev/initctl symlink) should be worked out with minor package updates.

Share this post


Link to post
Share on other sites

Also note -- kde5-plasma *should* also merge cleanly. While I don't personally use this desktop environment, I have started testing plasma builds. Please report any issues you encounter.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...