Jump to content
funtoo forums

Recommended Posts

I always prefer make a new installation from stage3 and recompile all with the new gcc 9.1.

 

I didn't upgrade from 1.3 yet.

Share this post


Link to post
Share on other sites
44 minutes ago, nigga-china said:

Which overlay do you use to emerge gcc 9.1?

I'm not using overlay to gcc, that is already available on 1.4.

Share this post


Link to post
Share on other sites

So, upgrade is pretty easy this time around.I will have instructions soon. But you can basically use "standard" upgrade steps. I recommend emerge -1 glibc gcc first, then emerge -auDN @world should generally work. Report any bugs related to upgrade like failed builds because often this can be fixed by tweaking dependencies. Overall the upgrade is MUCH easier than 1.2 -> 1.3.

One trick is to remember to "eselect python set --python3 python3.7" after python-3.7 is emerged to make it default. Also, mesa right now is very picky about USE flags related to video card. For example, if you don't have a card that supports vulkan, you cannot have vulkan in USE. Same with xa and other things that were more "permissible" before.

As of yesterday, I am now happily running gnome 3.32 and it is working perfectly. I would still call things "in beta" but the remaining issues (there is a "reboot doesn't work" issue currently active, due to a missing /run/initctl -> /dev/initctl symlink) should be worked out with minor package updates.

Share this post


Link to post
Share on other sites

If I am using the 1.4 generic 64-bit stage 3 tarball, that will already be referencing the 1.4 branches, correct?  Will most things build under 1.4 without changing my use flags and other settings?

Share this post


Link to post
Share on other sites

I can't confirm that migrate to 1.4 is easy. On local machine it was very slow and pain. Many packages must be removed and than added and rebuilded many times.

 

On Funtoo container migration is also not success. For example dev-libs/hyperscan-5.1.0::dev-kit is failed to build. But all other was simple.

Share this post


Link to post
Share on other sites

I'm performing the 1.4 migration on my VM and it has mostly gone well but I am running into some of those issues with video cards.

I looked into using the video card mixins but I am running this in VMWare and I didn't see a mixin for that so I am bravely making lots of stupid mistakes.

At least, I'll claim to do them on purpose since the alternative is admitting that I don't know what I am doing.

Here's what I continue to get when I try to do an emerge --update for @world

cricket /etc/portage # emerge --update --deep --with-bdeps=y -j3 --keep-going  @world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "media-libs/mesa[xa]".
!!! One of the following packages is required to complete your request:
- media-libs/mesa-19.1.3-r1::core-gl-kit (Missing IUSE: xa)
(dependency required by "x11-drivers/xf86-video-vmware-13.3.0::xorg-kit" [ebuild])
(dependency required by "x11-base/xorg-drivers-1.20::xorg-kit[video_cards_vmware]" [ebuild])
(dependency required by "x11-base/xorg-server-1.20.1-r1::xorg-kit" [ebuild])
(dependency required by "x11-base/xorg-x11-7.4-r3::xorg-kit" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
 

I can go post for help in the General Help forum if I can't figure it out shortly.  I just figured this was topical to the 1.4 discussion so I would bring it up here.

Share this post


Link to post
Share on other sites

Quick self-update.

I removed all of the x11-proto packages as suggested in the 1.2 to 1.3 upgrade procedure, removed the stuff I had put in the VIDEO_CARDS variable in make.conf and removed the USE variables for xa and the vmware video driver in various packages in package.use (libdrm, mesa, xorg-server)

I added the vmware-guest as a mixin and emerged the x11-proto,  and xorg-server stuff and it all seems to work fine now. 

Kudos..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...