Jump to content
  • 0
Sign in to follow this  
paddymac

Update world blockers - nvidia-cg-toolkit relies on libstdc++-v3 !?

Question

So I ran 'emerge -1uDNva --keep-going --with-bdeps=y --complete-graph @world' and met a few blockers. I removed a few packages to get rid of a few warnings, but I still get a few.
 

 Total: 740 packages (658 upgrades, 5 downgrades, 32 new, 7 in new slots, 38 reinstalls, 2 uninstalls), Size of downloads: 2,255,479 kB
Conflict: 4 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxkbcommon:0

  (x11-libs/libxkbcommon-0.4.1::gentoo, installed) pulled in by
    >=x11-libs/libxkbcommon-0.2.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/libsdl2-2.0.3-r200::gentoo, ebuild scheduled for merge)

  (x11-libs/libxkbcommon-0.3.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/wxpython:2.8

  (dev-python/wxpython-2.8.12.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/wxpython[python_abis_2.7] required by (dev-python/twisted-core-13.2.0-r1000::gentoo, ebuild scheduled for merge)
    dev-python/wxpython[python_abis_2.7] required by (dev-python/matplotlib-1.3.1-r1000::gentoo, ebuild scheduled for merge)

  (dev-python/wxpython-2.8.12.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libnl:3

  (dev-libs/libnl-3.2.24-r1::gentoo, installed) pulled in by
    <dev-libs/libnl-3.2.25:3= required by (net-misc/networkmanager-0.9.8.10-r1::gentoo, ebuild scheduled for merge)

  (dev-libs/libnl-3.2.25::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-devel/bison:0

  (sys-devel/bison-3.0.2::gentoo, installed) pulled in by
    >=sys-devel/bison-3 required by (dev-libs/rasqal-0.9.32::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (sys-devel/bison-2.7.1::gentoo, ebuild scheduled for merge) pulled in by
    <sys-devel/bison-3 required by (sys-libs/libstdc++-v3-3.3.6-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The libxkbcommon and libnl blockers don't seem to be a major issue, and the wxpython blocker seems odd to me, but probably not major. The only real issue seems to be with sys-devel/bison. sys-libs/libstdc++-v3-3.3.6-r1::gentoo is the program which requires <bison-3, so I ran equery to find out which program is pulling in sys-libs/libstdc++-v3-3.3.6-r1::gentoo. The only ebuild which requires it is media-gfx/nvidia-cg-toolkit. Now I suppose if this is really the case, I'll just have to live with it, but quite honestly I find it amazing that the nVidia Cg Toolkit, which was last released April 2012, would require such an old library. Any ideas?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Unfortunately, a resync doesn't clear up the issue with nvidia-cg-toolkit and virtual/libstdc++. I'm not 100% sure, but I don't think that dependency used to be there. But I examined the ebuild; it's there now. In any case, I just unmerged the offending packages and was able to proceed with a world update. I may try putting an ebuild for nvidia-cg-toolkit in a local overlay which doesn't depend on virtual/libstdc++ and see if it causes any problems or if it works. Frankly I'm just incredulous at the idea that a toolkit released in 2012 would actually depend on a pre-gcc-3.4 library. Either the Gentoo maintainer goofed, or, if it's true, the guys at nVidia are insane.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...