Jump to content
funtoo forums
  • 0
synteejol

After build the kernel os starts only in text mode

Question

I installed sys-kernel/gentoo-sources and build the kernel following these guide lines

https://www.funtoo.org/Building_a_Kernel_from_Source

I didn't use "No ebuild methods". 

When I finished and reboot I can only use funtoo in text mode.

I Also tried to build the kernel with genkernel but I got same issue.

Is not the first time I do this operation. On another machine I often use genkernel and all go fine.

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0

Did you had a graphical environment before? If yes, you might look into dmesg and the log files under /var/log for any errors. It could be that you didn't include all the settings in your kernel config and might need to add them.

Share this post


Link to post
Share on other sites
  • 0

Thank you for reply. I builded the kernel again with genkernel, using the same config, this time It works. Can't really understrand what the problem was. Now I can't use the mouse, but setting properly the config file the problem wil be solved. Next step Is installing Nvidia drivers. Fingers crossed. 

Share this post


Link to post
Share on other sites
  • 0

I rebuilt the kernel to fix mouse issue, this time it run in text mode again. I have another kernel that works fine. I post the output of "diff" command to show u the difference between the 2 kernels>

< # Linux/x86 4.9.168_p1-debian-sources-lts Kernel Configuration
---
> # Linux/x86 4.9.130-2 Kernel Configuration
1219d1218
< # CONFIG_BT_HCIUART_3WIRE is not set

they are almost the same. I really appreciate if someone can help me. thank you 

 

Share this post


Link to post
Share on other sites
  • 0

It could be that the modules required by your hardware are not loading.  You could try adding them to /etc/conf.d/modules or you could try editing /etc/genkernel.conf and having genkernel add all of the modules to the initramfs.  By the way, did you install the linux-firmware package?  If I remember correctly newer kernel versions do not include firmware so the firmware package might be mandatory.

Share this post


Link to post
Share on other sites
  • 0

Linux-firmware package is installed. The error message that appear is this:

myhostname.unknown_domain (Linux x86_64 4.19.27-gentoo-r1)

I'v checked /etc/conf.d/hostname, /etc/hosts and  /proc/sys/kernel/hostname, they have the same hostname

Share this post


Link to post
Share on other sites
  • 0

Well, that really isn's an error message.  It just means that there is no domain set on your system.  It's nothing to worry about and would not keep you from loading into a Xorg GUI.  For more info on setting your hostname in Funtoo see:  https://www.funtoo.org/Hostname

 

Before we get to deep into this please post the output "ego profile show" and "emerge --info" and we will see if that gives us any clues.

Share this post


Link to post
Share on other sites
  • 0

In your /etc/portage/make.conf on the VIDEO_CARDS line change "intel i 965 nvidia" to "intel i965" and then run "epro mix-ins gfxcard-nvidia" and then do "emerge -vauND @world" and finally edit /etc/conf.d/modules and add the following to you modules= line:

i915 nvidia nvidia_modeset nvidia_uvm nvidia_drm

After that you can reboot and try it again.  Just as a side note, setting the the nvidia USE flag with epro might not be required, but it works for me.  Right now my desktop CPU is a Haswell i7 but I don't use the integrated graphics.  I just use the fancy RTX 2070 I bought a few months ago.  Since you have laptop that can switch between GPUs this is about as far I can help you.  I have never had one to play with so I don't know how to set them up to switch.  This should at least get all of the modules loaded and all of the Xorg drivers sorted for you.

Share this post


Link to post
Share on other sites
  • 0

thank u I had not noticed that space between "i" and "965". When I do "epro mix-ins gfxcard-nvidia" it gives me an error:

!!! The ebuild selected to satisfy "dev-libs/libclc" has unmet requirements.
- dev-libs/libclc-0.2.0_pre20180915::dev-kit USE="" VIDEO_CARDS="-nvidia -r600 -radeonsi"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( video_cards_nvidia video_cards_r600 video_cards_radeonsi )

Should I add "-nvidia" to my make.conf?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, synteejol said:

thank u I had not noticed that space between "i" and "965". When I do "epro mix-ins gfxcard-nvidia" it gives me an error:


!!! The ebuild selected to satisfy "dev-libs/libclc" has unmet requirements.
- dev-libs/libclc-0.2.0_pre20180915::dev-kit USE="" VIDEO_CARDS="-nvidia -r600 -radeonsi"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( video_cards_nvidia video_cards_r600 video_cards_radeonsi )

Should I add "-nvidia" to my make.conf?

I would say the opposite. Or better said you should add back in nvidia to the video cards you want:

VIDEO_CARDS="intel i965 nvidia"

When you want to use the nvidia mix-in you need to add nvidia, if not, then you can omit it.

Share this post


Link to post
Share on other sites
  • 0

ok, I add again "nvidia" in make.conf emerge -auvDN @world, but the problem is still there. When I select  kernel I build,  appears "

unknown_domain (Linux x86_64 4.19.27-gentoo-r1)

Share this post


Link to post
Share on other sites
  • 0

I was wrong about removing the nvidia entry from your VIDEO_CARDS line.  I am sorry I thought that make.conf would compliment the profile and not over ride it. 

 

For your host name display at login:  This is controlled by the file /etc/issue and it's contents are parsed by agetty when it creates the terminal at login.  Check the man page for agetty to find out what the codes in /etc/issue mean and customize them as you see fit.

Share this post


Link to post
Share on other sites
  • 0

the strange is that /etc/issue file is the same for the kernel I installed but one of them start starts the other no. I've builded the kernel manually and using genkernel. 

Share this post


Link to post
Share on other sites
  • 0

Well, /etc/issue isn't part of the kernel package so no it wouldn't change.  Different kernels can have the exact same .config file and still give different results depending on how the system in is configured to use them.  The reason Funtoo defaults to the Debian kernel is because it "just works" for everyone.  If you use a different kernel you will need to do more work if you want everything to run as smoothly.  If you don't want to chase after this problem just edit /etc/issue and change \O to \o and I think most things will still work OK.

Share this post


Link to post
Share on other sites
  • 0

I solve that issue, it wasn't hostname problem, I went int Device drivers > graphic driver > <M> Nouveau (nvidia) card. with this option xserver satrt normally, but mouse doesn't work. So I go in input device section and sett everytthing, but still not work. I don't if it is a building phase probel. I have 3 kernel debian-sources-4.9.168, this one is working, gentoo sources with no moving mouse and debian sources-4.9.130. this last kernel worked perfectly before build it with genkernel. On my other pc, a laptop, I often do these build operation and never had a problem.

Share this post


Link to post
Share on other sites
  • 0

I can see how that could be the case.  Portage does a lot when it builds the kernel and if you didn't do all the same steps it does your results will be different.  Genkernel isn't going to do any more than it is explicitly told to do.  I don't enough information about your setup to give a better answer.  In the meantime I would suggest you boot into your working debian-sources-lts kernel, get a list of all the loaded modules and then reboot into your new kernel and get a listing of all the loaded modules and compare the two lists.  That way you will at least know what needs to be loaded and if you can not fix it out right at least you can find a work around.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, synteejol said:

So I go in input device section and sett everytthing, but still not work

Depending on the mouse you still need to set something else. For an usb mouse there would be e.g. also USB support. Also HID support could be an issue and maybe others. It all depends on what mouse you have and what drivers are needed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...