Jump to content
funtoo forums
  • 0
Sandro

trouble with dependencies (systemd .... grrrrr ..... :D)

Question

Hello and sorry if maybe disorder :

 

My make.conf :



sandro @ c2iht ~ $ cat / etc / make.conf
 
# These settings were Set by the metro build script That automatically built this internship .
# Please consult / etc / portage / make.conf.example blackberries for a detailed example.
 
CFLAGS = "- march = native - O2-pipe - mfpmath = sse "
CXXFLAGS = "- march = native - O2-pipe - mfpmath = sse "
FFlags = "- march = native - O2-pipe - mfpmath = sse "
FCFLAGS = "- march = native - O2-pipe - mfpmath = sse "
USE = " mmx sse SSE2 SSE3 SSSE3 SSE4 sse4_1 AVX AVX2 threads mpi smp nvidia \
     mpi -threads usb bluetooth audio sip scanner custom- cflags \
     custom -optimization jpeg mng jpeg2k smartcard jack v4l vdpau \
     ffmpeg speex realtime libsamplerate lirc raw ios ipod OpenCL \
     cpuopts custom- qt4 qt3support cups alsa cdda cddb python kde \
     plasma gps rar zip semantic -desktop Fortran mysql sql svg nokia \
     xine gstreamer xps pdf xmp iptc thunderbird applet cue gsf \
     sox encode mp3 mp4 bluray x264 v4l2 libv4l aacPlus AAC faac gsm \
     libass libcaca pic vpx xvid VAAPI twolame theora \
     Schroedinger matroska static- ppds hpijs quicktime wmf xpm thunar Xaw3d \
     a52 aalib acpi apm bcmath bidi blas bzip2 cairo calendar cane \
     caps cdb cdparanoia cdr clamav cracklib crypt css ctype cvs \
     cxx dbi dbm dbus dga djvu dri dts dv dvb dvdr evo exif expat \
     fastcgi fftw flac fltk foomaticdb ftp gdbm geoip ggi gif gimp \
     git glut gmp gpm graphviz gsl guile gzip hddtemp iconv icq \
     icu ieee1394 imap blades libedit libffi libnotify lm_sensors \
     lzma lzo maildir mbox MEMLIMIT mikmod mime mmap mms mpeg mplayer \
     msn musicbrainz nsplugin OpenEXR ogg openal opengl openmp \
     pam pcmcia pda perl png ppds recode ruby shorten szip taglib \
     tiff tcl tk wavpack xcomposite xface xft xml xv zlib fluidsynth \
     smpeg timidity midi xinerama xscreensaver xvmc fat gles2 gtk \
     video gphoto2 introspection java- gnome- pulseaudio openrc \
     soap curl gd truetype -cli wifi networkmanager fax WebGL sound \
     consolekit upower sdl - static- libs "
LDFLAGS = "$ { LDFLAGS } -Wl, - hash -style = gnu "
MAKEOPTS = "- j9 "
LINGUAS = " en "
INPUT_DEVICES = " keyboard mouse evdev "
VIDEO_CARDS = " nvidia"
ACCEPT_LICENSE = "*"
PORTAGE_TMPDIR = "/ dev / shm "
[/ code]
 
My / etc / portage / package.use
[code]

c2iht ~ # cat /etc/portage/package.use |grep -v "#" |sort
=app-crypt/pinentry-0.8.2 gtk
=app-i18n/ibus-1.5.2 dconf
=app-text/poppler-0.24.5 cairo
=dev-db/mariadb-5.5.37-r1 embedded
=dev-db/mysql-5.1.70 embedded
=dev-db/tinycdb-0.77-r2 -satic-libs
=dev-libs/folks-0.8.0 vala eds
=dev-libs/libgdata-0.14.0 gnome
=dev-libs/libpeas-1.8.1 gtk
=dev-libs/nss-3.15.4 utils
=dev-scheme/guile-1.8.8-r1:12 discouraged networking
=dev-vcs/subversion-1.7.16-r1000 -dso
=gnome-base/gnome-settings-daemon-3.6.4 policykit
=gnome-base/gvfs-1.14.2 udisks cdda gtk
=gnome-base/gvfs-1.16.4 udisks
=gnome-base/gvfs-1.18.3-r1 udisks
=gnome-base/librsvg-2.39.0 gtk
=gnome-extra/evolution-data-server-3.6.4 vala
=kde-base/kdelibs-4.11.5 udisks
=media-gfx/exiv2-0.23-r1 xmp
=media-libs/gst-plugins-base-1.0.10 theora
=media-libs/libcanberra-0.30-r1 gtk
=media-libs/libchamplain-0.12.5 gtk
=media-libs/mlt-0.8.2 melt
=media-libs/sdl-mixer-1.2.12-r3 -mikmod
=media-plugins/alsa-plugins-1.0.27 pulseaudio
=media-sound/cdparanoia-3.10.2-r6
=media-video/ffmpeg-1.0.8 sdl
=net-libs/gnutls-2.12.23-r1 pkcs11
=net-libs/gnutls-2.12.23-r4 pkcs11
=net-libs/gssdp-0.14.6 introspection
=sci-libs/fftw-3.3.3-r2 threads
=sys-apps/dbus-1.6.12 X
=sys-apps/systemd-212-r5 gudev
=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
=sys-auth/pambase-20120417 consolekit
=sys-devel/gcc-4.8.1-r2 fortran
=sys-devel/llvm-3.3-r3 clang video_cards_radeon
=sys-devel/llvm-3.4 video_cards_radeon clang
=sys-fs/lvm2-2.02.103 -static
=sys-process/lsof-4.85-r2 rpc
=virtual/ffmpeg-0.10.3 sdl
=virtual/mysql-5.1 embedded
=virtual/opencl-0-r2 abi_x86_32
=x11-libs/cairo-1.12.14-r4 X
=x11-libs/cairo-1.12.16 X
=x11-libs/gdk-pixbuf-2.28.2 X
=x11-libs/gdk-pixbuf-2.30.6 X
=x11-libs/pango-1.34.1 X
=x11-libs/pango-1.36.2 X
>=app-admin/eselect-php-0.7.1-r3 fpm
>=app-crypt/gcr-3.10.1 gtk
>=app-crypt/gcr-3.10.1 gtk
>=dev-db/mysql-5.5.32 embedded
>=dev-libs/elfutils-0.158 static-libs
>=dev-libs/folks-0.9.6 eds
>=dev-python/PyQt4-4.10.3-r1000 webkit
>=dev-ruby/json-1.8.1 ruby_targets_ruby21
>=dev-ruby/racc-1.4.11 ruby_targets_ruby21
>=dev-ruby/rake-0.9.6-r1 ruby_targets_ruby21
>=dev-ruby/rdoc-4.0.1-r2 ruby_targets_ruby21
>=dev-ruby/rubygems-2.0.14 ruby_targets_ruby21
>=dev-scheme/guile-1.8.8-r2:12 networking
>=gnome-extra/evolution-data-server-3.10.4 vala
>=media-libs/gd-2.0.35-r3 fontconfig
>=media-libs/libcanberra-0.30-r1 gtk
>=media-libs/libcanberra-0.30-r1 gtk
>=media-libs/libpng-1.6.8 apng
>=media-libs/mlt-0.9.0 kdenlive melt
>=media-plugins/gst-plugins-meta-0.10-r8:0.10 vorbis ogg
>=net-libs/gnutls-3.2.12.1 pkcs11
>=sys-process/lsof-4.87-r1 rpc
>=virtual/mysql-5.5 embedded
>=virtual/opencl-0-r4 abi_x86_32
>=x11-libs/gdk-pixbuf-2.30.7-r1 X
>=x11-libs/wxGTK-2.8.12.1-r1:2.8 X
app-accessibility/espeak portaudio
app-arch/p7zip wxwidgets
app-misc/tracker gstreamer -xine
app-office/libreoffice telepathy
app-office/scribus scripts
dev-lang/php pcntl cli cgi fpm inifile mysqli snmp xmlreader xmlrpc xmlwriter xml readline -libedit -recode
dev-libs/folks -eds
dev-libs/libpcre -libedit
dev-python/PyQt4 script declarative
media-gfx/xsane lcms ocr
media-sound/amarok lastfm mp3tunes mtp ofa
media-sound/pulseaudio equalizer
media-video/mplayer radio
media-video/vlc zvbi wma-fixed vlm vcdx optimisememory pvr
net-libs/telepathy-glib introspection vala
net-libs/webkit-gtk -gles2media-sound amarok lastfm mp3tunes mtp ofa -gles2
net-misc/networkmanager -nss gnutls
net-misc/networkmanager gnutls -nss
net-print/hplip libusb0 parport snmp
sys-block/gparted btrfs fat ntfs
sys-kernel/debian-sources binary
sys-libs/zlib minizip
sys-power/cpupower cpufreq_bench
virtual/libgudev -static-libs
x11-drivers/nvidia-drivers uvm
x11-wm/compiz-fusion emerald unsuppored
[/code]
 
And "the trouble"
[code]

ebuild   R    ] x11-libs/xcb-util-renderutil-0.3.8  USE="static-libs*" 
[ebuild   R    ] x11-libs/xcb-util-image-0.3.9  USE="static-libs*" 
[ebuild   R    ] x11-libs/startup-notification-0.12  USE="static-libs*" 
[ebuild  N     ] sys-apps/systemd-212-r5  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam policykit python seccomp -audit -cryptsetup -doc -gcrypt -http (-kdbus) -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4 
[ebuild  N     ] virtual/libgudev-208  USE="introspection -static-libs" 
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-1.4)
 
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
 
  (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-208:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs(-)?] (>=sys-apps/systemd-208:0/2[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)
 
  (sys-fs/eudev-1.4::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,modutils,gudev?,introspection?,selinux?,static-libs?] (>=sys-fs/eudev-1.3[abi_x86_64(-),modutils,gudev,introspection,static-libs]) required by (virtual/udev-208::gentoo, installed)
 
 
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
 
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 


Should I wait? 

Or, proceed .... but how? 

 

Thanks for any suggestion


Edited by Sandro

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Thank You Oleg, You're very kind..... 

 


and I understood that my argument is similar to that already present in the forum. 

If my argument is therefore unnecessary, delete it as well :)


 

Thus, following the discussion above in place, it means that I should wait a couple of days before checking for updates of my system? 

Thank you .... and forgive me if I do not write very well in the U.S. language ...... 

 

Funtoo Never Dies :)

Share this post


Link to post
Share on other sites
  • 0

I'm reinstalling everything from the beginning .... but I notice a lot of difference .... I've never had to deal with so many "inconsistencies" .... I feel depressed, I feel like crying .... and maybe all the fault this "Damned Damned Hellfire systemd" .....
It 'hard to swallow this bitter pill ..... I do not know what temp to wait before re-install / re-compile the whole system .....

Share this post


Link to post
Share on other sites
  • 0

I'm sorry to have you alarmed ...
I've recompiled most of the system ..... I do not know why this happened, there was also, among the various, the update of the kernel.

Now my kernel is:
 


uname-a:
Linux ci7ht 3:12:21-gentoo-r1 # 1 SMP PREEMPT Tue Jun 10 22:09:49 CEST 2014 x86_64 Intel ® Core (TM) i7-4771 CPU@3.50GHz GenuineIntel GNU / Linux
[/ code]

and I'm compiling it very calmly, adding a few options for once (just to compile the kernel takes 5 minutes and 30 processing).

Luckily I always keep a copy of my config files :)
So (with the 4771 processor) can restore the system in less than a day.
Only, I do not know if has to do, I used the "fstream" as the operating system resides on ssd and the /home on a "classic HDD 1 TiB"

Anyway I think this will make me a better understanding of what software "calls" the USE systemd.
As I finished rebuilding the whole thing, I will let you know.

Thank you :)

Share this post


Link to post
Share on other sites
  • 0

The first problem is that i've used masked proprietary nvidia-drivers; now I use the "stable" version

 

Also I have compiled most of the system; 
Miss networkmanager, that gives me some complications about dependencies:
 

ci7ht ~ # USE="networkmanager" emerge -DNu world -pv
 
These are the packages that would be merged, in order:
 
Calculating dependencies... done!
 
emerge: there are no ebuilds to satisfy ">=net-libs/libnm-qt-0.9.8.1[modemmanager?]".
(dependency required by "kde-misc/plasma-nm-0.9.3.3" [ebuild])
(dependency required by "kde-base/solid-runtime-4.12.5[networkmanager]" [ebuild])
(dependency required by "kde-base/kdebase-runtime-meta-4.12.5" [installed])
(dependency required by "kde-base/kdebase-startkde-4.11.9" [installed])
(dependency required by "kde-base/kdebase-meta-4.12.5" [installed])
(dependency required by "kde-base/kde-meta-4.12.5" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
 
Also adding the USE "modemmanager", nothing happens and the system repeat the error.

Share this post


Link to post
Share on other sites
  • 0

Also after "eix-update && emerge -DNu world" the problem persist,

also

 

ci7ht ~ # emerge -1 networkmanager
Calculating dependencies... done!
[ebuild  N     ] net-wireless/rfkill-0.5 
[ebuild  N     ] net-wireless/wireless-regdb-20130213 
[ebuild  N     ] net-libs/libqmi-1.8.0  USE="static-libs -doc" 
[ebuild  N     ] dev-libs/libnl-3.2.23  USE="python static-libs -utils" PYTHON_TARGETS="python2_7 python3_3 (-python2_6) -python3_2" 
[ebuild  N     ] net-wireless/crda-1.1.3-r1 
[ebuild  N     ] net-dialup/ppp-2.4.5-r3  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius" 
[ebuild  N     ] net-wireless/wpa_supplicant-2.0-r2  USE="dbus qt4 readline smartcard ssl -ap -eap-sim -fasteap -gnutls -p2p (-ps3) (-selinux) -wimax -wps" 
[ebuild  N    ~] sys-power/upower-0.99.0-r1  USE="introspection ios" 
[ebuild  N     ] net-misc/modemmanager-1.2.0-r1  USE="introspection policykit qmi -mbim -qmi-newest -vala" 
[ebuild  N     ] net-misc/networkmanager-0.9.8.2-r2  USE="bluetooth consolekit dhcpcd introspection modemmanager nss policykit ppp resolvconf wext -avahi -connection-sharing -dhclient -gnutls -systemd {-test} -vala" 
[blocks B      ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23)
 
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
 
  (sys-power/upower-0.99.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-power/upower required by (net-misc/networkmanager-0.9.8.2-r2::gentoo, ebuild scheduled for merge)
    sys-power/upower required by (media-tv/xbmc-12.2-r1::gentoo, installed)
 
  (sys-power/upower-pm-utils-0.9.23::gentoo, installed) pulled in by
    sys-power/upower-pm-utils required by (xfce-base/xfce4-session-4.10.1-r1::gentoo, installed)
 
 
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
 
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Share this post


Link to post
Share on other sites
  • 0
Ok, I think I have achieved significant results.

Networkmanager now works.

Remain unmet dependencies but only 2:


sandro @ ci7ht ~ $ emerge-DNupv world
 
These are the packages That would be merged, in order:
 
Calculating dependencies ... done!
[Ebuild N] sys-power/upower-pm-utils-0.9.23 USE = "introspection ios-doc" 0 kB
[Ebuild R] net-im/telepathy-mission-control-5.14.1 USE = "networkmanager * upower *-connman-gnome-keyring-debug" 1,003 kB
[Blocks B] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23)
 
Total: 2 packages (1 new, 1 reinstall), Size of downloads: 1,003 kB
Conflict: 1 block (1 unsatisfied)
 
 * Error: The above package list contains packages Which can not be
 * Installed at the same time on the same system.
 
  (Sys-power/upower-0.99.0-r1 :: gentoo, installed) pulled in by
    > = Sys-power/upower-0.9.23 required by (kde-base/kdelibs-4.12.5 :: gentoo, installed)
    sys-power/upower required by (net-misc/networkmanager-0.9.8.2-r2 :: gentoo, installed)
    sys-power/upower required by (media-tv/xbmc-12.2-r1 :: gentoo, installed)
 
  (Sys-power/upower-pm-utils-0.9.23 :: gentoo, ebuild scheduled for merge) pulled in by
    sys-power/upower-pm-utils required by (net-im/telepathy-mission-control-5.14.1 :: gentoo, ebuild scheduled for merge)
    sys-power/upower-pm-utils required by (xfce-base/xfce4-session-4.10.1-r1 :: gentoo, installed)
 
 
For more information about Blocked Packages, please refer to the Following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
 
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1 # blocked

 

For me This discussion can be marked as "Solved".

 

Thanks to All :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...