Jump to content
  • 0
Sign in to follow this  

Issue installing Grub




I'm attemptin my very first install.  And was doin fine up to

emerge boot-update

Which fails with

chmod a+x grub-mkrescue
PATH=.:$PATH pkgdatadir=. /usr/bin/help2man --section=1 -i /var/tmp/portage/sys-boot/grub-2.00-r7/work/grub-2.00/docs/man/grub-mkrescue.h2m -o grub-mkrescue.1 grub-mkrescue
Can't locate Locale/gettext.pm in @INC (you may need to install the Locale::gettext module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.20.1/x86_64-linux /usr/local/lib64/perl5/5.20.1 /usr/lib64/perl5/vendor_perl/5.20.1/x86_64-linux /usr/lib64/perl5/vendor_perl/5.20.1 /usr/lib64/perl5/5.20.1/x86_64-linux /usr/lib64/perl5/5.20.1 .) at /usr/bin/help2man line 29.
BEGIN failed--compilation aborted at /usr/bin/help2man line 29.
Makefile:22935: recipe for target 'grub-mkrescue.1' failed
make[2]: *** [grub-mkrescue.1] Error 2

I tried

perl-cleaner --all

But that did not fix the issue, probably because it didn't finish.


All relevant logs are attached.


I used  http://build.funtoo.org/funtoo-stable/x86-64bit/core2_64/stage3-latest.tar.xz


Any ideas how I can rectify this?







Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello and welcome.

It's probably not your fault, you lucked out and installed at the same time perl was being updated to a new version.  It can be kind of tricky even for established installs to cope with that.

Yes, the fact that perl-cleaner didn't finish sounds like a good bet.  Hopefully someone more knowledgeable will come to the rescue here, but until then, I wonder if perl-cleaner complains about blockers?  That's often the case.  If so, make a note of the blockers and uninstall them, then it should finish and you should get over the hump.  Then you can reinstall them ( I think you should, but I never do), do emerge --depclean && revdep-rebuild.  You often have to pull out perl stuff to get it to work.

Otherwise, perhaps post your results from perl-cleaner to give us more to go on.

Share this post

Link to post
Share on other sites
  • 0



Thanks for the reply.  I've just completed  emerge -e boot-update  It seems to have worked (it didn't give me any errors)  I'll continue on and see how I go.


The output from perlcleaner was attached above in case that helps anyone else 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...