Jump to content
funtoo forums
Sign in to follow this  
lego12239

Trying to upgrade from funtoo 1.0

Recommended Posts

Hi.

 

Trying to upgrade and get some trouble. At first, ego want sync. I done:

git clone https://github.com/funtoo/ego.git
cd ego
./ego sync

And emerge isn't working now :-):

 

Quote

 

# emerge -a1 ego
!!! Unable to parse profile: '/etc/portage/make.profile'
!!! ParseError: Parent '/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/build/stable' not found: '/etc/portage/make.profile/parent'


!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /var/git/meta-repo/kits/core-kit/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.

 

 

What can i do to solve this problem :-)?

 

Thanks!

 

Share this post


Link to post
Share on other sites
# equery l ego
!!! Unable to parse profile: '/etc/portage/make.profile'
!!! ParseError: Parent '/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/build/stable' not found: '/etc/portage/make.profile/parent'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/freeswitch/metadata/layout.conf'
!!! Unable to parse profile: '/etc/portage/make.profile'
!!! ParseError: Parent '/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/build/stable' not found: '/etc/portage/make.profile/parent'
 * Searching for ego ...
!!! Unable to parse profile: '/etc/portage/make.profile'
!!! ParseError: Parent '/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/build/stable' not found: '/etc/portage/make.profile/parent'
[I--] [??] app-admin/ego-2.4.0_beta1:0

 

2.4.0_beta1

Share this post


Link to post
Share on other sites
# ./ego profile

=== Enabled Profiles: ===

        arch: x86-64bit
       build: stable
     subarch: generic_64
      flavor: core
     mix-ins: no-systemd


=== Python kit: ===

      branch: 3.6-prime

=== All inherited flavor from core flavor: ===

                         minimal (from core flavor)

 

Share this post


Link to post
Share on other sites

Some strange error when boost installing:


 

>>> Install boost-1.65.0 into /var/tmp/portage/dev-libs/boost-1.65.0/image/ category dev-libs
 * abi_x86_64.amd64: running multilib-minimal_abi_src_install
 * python2_7: running installation
 * ACCESS DENIED:  symlinkat:    /var/tmp/portage/dev-libs/boost-1.65.0/temp/libpython2.7.so
ln: failed to create symbolic link '/var/tmp/portage/dev-libs/boost-1.65.0/temp/libpython2.7.so': Permission denied
 * ERROR: dev-libs/boost-1.65.0::core-kit failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   92:  Called src_install

 *   environment, line 4402:  Called multilib-minimal_src_install
 *   environment, line 2544:  Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
 *   environment, line 2738:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
 *   environment, line 2443:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
 *   environment, line 2441:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
 *   environment, line  436:  Called multilib-minimal_abi_src_install
 *   environment, line 2534:  Called multilib_src_install
 *   environment, line 3049:  Called python_foreach_impl 'installation'
 *   environment, line 3817:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'installation'
 *   environment, line 2443:  Called _multibuild_run '_python_multibuild_wrapper' 'installation'
 *   environment, line 2441:  Called _python_multibuild_wrapper 'installation'
 *   environment, line  565:  Called installation
 *   environment, line 3007:  Called create_user-config.jam
 *   environment, line  917:  Called die
 * The specific snippet of code:
 *           ln -f -s "$(python_get_library_path)" "${T}/lib${EPYTHON}$(get_libname)" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.65.0::core-kit'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.65.0::core-kit'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/boost-1.65.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/boost-1.65.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/boost-1.65.0/work/boost_1_65_0-abi_x86_64.amd64'
 * S: '/var/tmp/portage/dev-libs/boost-1.65.0/work/boost_1_65_0'
 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/var/log/sandbox/sandbox-30018.log"
 *
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: symlinkat
S: deny
P: /var/tmp/portage/dev-libs/boost-1.65.0/temp/libpython2.7.so
A: /var/tmp/portage/dev-libs/boost-1.65.0/temp/libpython2.7.so
R: /usr/lib64/libpython2.7.so.1.0
C: ln -f -s /usr/lib64/libpython2.7.so /var/tmp/portage/dev-libs/boost-1.65.0/temp/libpython2.7.so

 

How can i fix it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×