Jump to content
funtoo forums
Sign in to follow this  
minou666

Funtoo stage 3 for Beagleboard X15

Recommended Posts

I had the message posted on the wrong group. The issues I mentionned earlier I have fixed so I changed my message to be a real news message.

The ACCESS DENIED message of my previous was caused by a bug in one of Texas Instruments scripts that was checking to see if I use clang. In the function that check for the presense of clang it tries to create some log on a place where it can't. TI must never have tested that on the target. I managed to get it to compile on the target after I fixed the script. That bug is in the pvrsrvkm source tree.
 

I have published a stage 3 for Funtoo to use on the beagleboard X15 which uses an AM5728 processor from Texas Instruments.

TI broke the eMMC support for the Beagleboard X15 Rev A2. I have fixed that. Note that I have not checked u-boot yet so I think that you might not be able to boot on eMMC.

With a simular bug I was not able to boot off the eMMC on the DRA726 boards we have at work. I would have to wipe out debian on the beagleboard to check that out and I am not ready to do that yet.

You can find the files on my website http://suzielinux.com/

I am creating some ebuilds for my Beagleboard X15 boards.

I will publish those ebuilds in a few weeks.  So far I have the kernel 4.14 and sgx kernel module ebuild created. My next targets are EGL and adapting mesa to not interfere with the sgx EGL.

Michel

 

 

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...