Jump to content
funtoo forums
Sign in to follow this  
minou666

e2fsprogs breaks u-boot

Recommended Posts

I have been working on yocto, gentoo and funtoo for the Beagleboard X15. I needed to create a new image for one of my Beagleboard X15 boards. I created a partition of 90MB in fat32 for u-boot and MLO. I then created an ext4 partition for the rootfs using the following command because funtoo now uses the e2fsprogs that breaks u-boot :

mkfs.ext4 -L rootfs -O ^metadata_csum,^64bit /dev/sdd2

That didn't not create a 32 bit filesystem as expected. The solution was to boot to ubuntu 16.04 which still uses 1.42

This command worked correctly on arch linux last I tried.

I looke to replace 1.43 with 1.42 in my overlay but it doesn't appear to be possible. The unmask and mask do not work, funtoo insists on keeping the buggy version.

I find it annoying to have to boot to ubuntu to do my work on arm boards.

Any idea how to fix that? Is there any alternative to that e2fsprogs crapware?

 

Michel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...