Jump to content
funtoo forums
Sign in to follow this  
kovale

ANSWERED How properly to uninstall nvidia?

Recommended Posts

Hi all,

I have tried to install nvidia driver for my GeForce 920MX in a fresh installed funtoo with KDE-plasma-5. The original NVIDIA-Linux-x86_64-390.48.run failed to load the module, thogh I continued the installation according to www.funtoo.org/Package:NVIDIA_Linux_Display_Drivers. Unfortunately, after reboot I could not even login in cli because of the blinking screen. So, I decided to uninstall the driver in a reverse order. I’ve deleted the three nvidia, nvidia_drm, and nvidia_uvm modules from /lib64/modules/4.16.7-gentoo/video/nvidia.ko, set the configs files back to “intel”, but was unable to remove glx. Now sddm can’t start, since xorg fails to find “intel” module. I would be happy to return to gui with or without nvidia.

etc/portage/make.conf
---------------------------------
VIDEO_CARDS="i915"
---------------------------------

/etc/X11/xorg.conf
---------------------------------
Section "Device"
    Identifier     "Device0"
    Driver         "intel"
    VendorName     "Intel"
#    BoardName       "geforce 920MX"
EndSection
---------------------------------

/var/log/Xorg.0.log
---------------------------------
X.Org X Server 1.19.3
Release Date: 2017-03-15
[  3072.096] X Protocol Version 11, Revision 0
[  3072.096] Build Operating System: Linux 4.16.7-gentoo x86_64 Gentoo
[  3072.096] Current Operating System: Linux alexhome 4.16.7-gentoo #1 SMP Thu May 10 12:34:05 CEST 2018 x86_64
[  3072.096] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.16.7-gentoo real_root=UUID=aa05dbbc-1eb2-408a-8ba7-aaad0507f2d8 real_rootflags=acl,active_logs=6 rootfstype=f2fs
[  3072.096] Current version of pixman: 0.34.0
[  3072.096] (==) Automatically adding devices
[  3072.096] (==) Automatically enabling devices
[  3072.096] (==) Automatically adding GPU devices
[  3072.096] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3072.096] (**) ModulePath set to "/usr/lib64/xorg/modules"
[  3072.096] (II) Module ABI versions:
[  3072.096]     X.Org ANSI C Emulation: 0.4
[  3072.096]     X.Org Video Driver: 23.0
[  3072.096]     X.Org XInput driver : 24.1
[  3072.096]     X.Org Server Extension : 10.0
[  3072.097] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3072.101] (--) PCI:*(0:0:2:0) 8086:5916:17aa:39f1 rev 2, Mem @ 0xa2000000/16777216, 0xb0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[  3072.101] (--) PCI: (0:3:0:0) 10de:134f:17aa:39f1 rev 162, Mem @ 0xa3000000/16777216, 0x90000000/268435456, 0xa0000000/33554432, I/O @ 0x00003000/128
[  3072.101] (II) LoadModule: "glx"
[  3072.101] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  3072.102] (II) Module glx: vendor="X.Org Foundation"
[  3072.102]     compiled for 1.19.3, module version = 1.0.0
[  3072.102]     ABI class: X.Org Server Extension, version 10.0
[  3072.102] (II) LoadModule: "intel"
[  3072.102] (WW) Warning, couldn't open module intel
[  3072.102] (II) UnloadModule: "intel"
[  3072.102] (II) Unloading intel
[  3072.102] (EE) Failed to load module "intel" (module does not exist, 0)
[  3072.102] (EE) No drivers available.
[  3072.102] (EE) 
Fatal server error:
[  3072.102] (EE) no screens found(EE) 
[  3072.102] (EE) 
---------------------------------


/usr/src/linux-4.16.7-gentoo/kernel.config
attached


/var/log/nvidia-installer.log
----------------------------------
   WARNING: "swiotlb_map_sg_attrs" [/tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia.ko] undefined!
     CC      /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-drm.mod.o
     CC      /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-modeset.mod.o
     CC      /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-uvm.mod.o
     CC      /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia.mod.o
     LD [M]  /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-modeset.ko
     LD [M]  /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-drm.ko
     LD [M]  /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia.ko
     LD [M]  /tmp/selfgz12775/NVIDIA-Linux-x86_64-390.48/kernel/nvidia-uvm.ko
   make[2]: Leaving directory '/usr/src/linux-4.16.7-gentoo'
   make[1]: Leaving directory '/usr/src/linux-4.16.7-gentoo'
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.
-> Kernel module load error: No such file or directory
-> Kernel messages:
[  876.334984] -- transfer complete
[  876.334988] Bulk status result = 0
[  876.334994] Bulk Status S 0x53425355 T 0xacff R 0 Stat 0x0
[  876.335000] scsi cmd done, result=0x0
[  876.335071] *** thread sleeping
[  876.409729] *** thread awakened
[  876.409730] Command WRITE_10 (10 bytes)
[  876.409731] bytes: 2a 00 00 fd fa a0 00 00 08 00
[  876.409733] Bulk Command S 0x43425355 T 0xad00 L 4096 F 0 Trg 0 LUN 0 CL 10
[  876.409734] xfer 31 bytes
[  876.409751] Status code 0; transferred 31/31
[  876.409751] -- transfer complete
[  876.418290] Bulk status result = 0
[  876.418296] Bulk Status S 0x53425355 T 0xad00 R 0 Stat 0x0
[  876.418302] scsi cmd done, result=0x0
[  876.418345] *** thread sleeping
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
-----------------------------------

Thank you for your time.
 

kernel.config

Share this post


Link to post
Share on other sites

 

The intel value is for x11-base/xorg-drivers. The i915  value is for media-libs/mesa.

Change

VIDEO_CARDS="i915" 

to

VIDEO_CARDS="intel i915"

Build drivers and install linux-firmware:

emerge -av xorg-x11 linux-firmware

 

Reference:

https://www.funtoo.org/Video

Video Driver Installation and Setup

Selecting a Video Driver

https://wiki.gentoo.org/wiki/Intel

Share this post


Link to post
Share on other sites

Hi cardinal,

thank's a lot for a prompt answer! I followed your instructions, but it still didn't worked. After I deleted /etc/X11/xorg.conf the sddm log-in screen appeared.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×