Jump to content

Recommended Posts

Hi guys,

 

I heard about Funtoo on the Manjaro forums, and decided to take a look.

Seems like an interesting project to me :)

 

However I already have two distros installed on my (only) PC (laptop) that I am satisfied with, and Funtoo being source based, I am wondering where I can fit it..

 

I think I will try the VM option with dual cores rather than a single core and 1.5 Gb of RAM rather than the 1 Gb I usually set ;)

 

Edit-

Wondering if I should go in for the current build or the stable, as current seems to be recommended, but I prefer stable if its not too old, and as I want to keep updates to a minimum.

Share this post


Link to post
Share on other sites

I decided to go for it in a VM with the following configuration:

 

VM: Virtualbox

Processors: 2

RAM: 1.5 Gb

Swap: 1 Gb

Hard Disk: 5 Gb (maybe I should have selected more..)

Arch: x86-64 bit

Build: Stable

 

I could follow the steps in the Installation guide till the Configuring_and_installing_the_Linux_kernel part, where I hit some snags.

 

1. The guide mentions that I should have 14 Gb of free space in /var/tmp for the debian-sources kernel which I did not have, so I skipped it.

 

2. I then tried the ubuntu-server kernel, which failed because it could not satisfy the dependency for gcc-4.5

 

3. Next i tried the sysrescue-std-sources kernel, which failed beacuse it could not download the source.

 

4. Finally I tried the debian-sources-lts kernel, which downloaded the source, and started compiling. It could compile bzImage but failed on compiling the modules due to lack of space.

 

Will give it another try tomorrow maybe (this time I am thinking of increasing the root size to 7 Gb)..

Share this post


Link to post
Share on other sites
aaditya hi, welcome :); in my opinion can serve as an exercise in the use of VM. 

 

But in order to "enjoy" all the power and possibility of Funtoo, you would need to install it to multiboot maybe in a dedicated partition, so you can take full advantage of all the hardware resources.

 

And I assure you that there is a big difference compared to the pre-compiled mainly if you have a cpu advanced. (so instead of creating generic code you can  optimize everything for your hardware. 

 

Good job and I hope that you remain excited about this "magic" distribution :)

 

Good for All :)

Share this post


Link to post
Share on other sites

Hi Sandro :)

 

What attracted me to Funtoo on reading about it was the comparatively easier install process as compared to Gentoo, the feel and tone of the documentation about the distribution and its users, and the usage of OpenRC system :)

 

Having 4 different Operating Systems on a single PC would be a bit overkill in my opinion. Hence I am thinking virtual for now.

Share this post


Link to post
Share on other sites

Hello and welcome. :)

If you are going to put Funtoo in a VM and not configure an appropriate kernel by hand (e.g. gentoo-sources or vanilla-sources) then you are going to need to pump a bit more resources into your VM since, as you discovered, debian-sources is a bit of a hog.

 

If you want less updates, on average, then the stable profile is what you want. It shouldn't be too far behind current.

Share this post


Link to post
Share on other sites

Hello and welcome. :)

 

If you are going to put Funtoo in a VM and not configure an appropriate kernel by hand (e.g. gentoo-sources or vanilla-sources) then you are going to need to pump a bit more resources into your VM since, as you discovered, debian-sources is a bit of a hog.

 

If you want less updates, on average, then the stable profile is what you want. It shouldn't be too far behind current.

Thanks for the tips :)

 

I will give it another try with increased disk space.

Share this post


Link to post
Share on other sites

This time I tried Funtoo_Linux_Genkernel, and was able to build and install the debian-sources-lts kernel as described in the genkernel guide, and built and installed boot-update, but I cannot boot the newly installed system, as it gives errors about not able to find the root device..

 

So it looks like I will have to put off this install till I can find more time to figure it out.

Share this post


Link to post
Share on other sites

Could You post your:

# fdisk -l
# parted -l
# cat /etc/boot.conf

May be that is not enabled some kernel module for the hdd or must specified in /etc/boot.conf instead of

params += real_root=auto

the UUID or /dev/sdxy fof the / (root) Filesystem.

 

For example i've this:

sandro@ci7ht ~ $ cat /etc/boot.conf
boot {
        generate grub
        default "Windows 8.1 x64" 
        timeout 5 
}
 
"Windows 8.1 x64" {
        type win8
        params root=/dev/sda1
}
 
"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=UUID=3722ea24-8aed-4edc-a43f-1389c408d41b
        params += rootfstype=ext4 
}

The UUID can be discovered using (e.g.)

 

# blkid -g && blkid

 

you may filtrate the result using grep (e.g.)

 

 

blkid -g && blkid |grep -i /dev/sdXY

Where  /dev/sdXY is your root partition.

Share this post


Link to post
Share on other sites

Hi aaditya, good to see you here  :)

 

Everyone is much more experienced than me here so I'll let them continue to help but I had this problem when I installed, it turned out to be an error in the numbering in fstab so check that. 

Share this post


Link to post
Share on other sites

Hi spectromas, how are you :)

 

Thx for the help Sandro :)

 

I think the parameters are right, because when I am at the Grub menu, I press e to edit, and it seems to show the correct parameter for the root partition.

 

I have attached the screenshots for it. I will chroot and post the outputs that you mention.

 

I think the problem is that I may not have compiled or configured the kernel correctly.

post-199-0-82562800-1408340027_thumb.png

post-199-0-45680900-1408340028_thumb.png

Share this post


Link to post
Share on other sites

Here are the other outputs.

 

With the kernel compilation, no initrd was generated, as it said that all the modules were built-in, so I think I may have erred there.

You should try a newer kernel(debian-sources or gentoo-sources are good), I think your boot failed because maybe older kernels need a more specific command line, try to change the command line, in the grub menu(F2 or 'c') to 'real_root=/dev/sda1 rootfstype=ext4' but you should really try a newer kernel, I wouldn't use anything bellow 3.4 these days.

Share this post


Link to post
Share on other sites

You should try a newer kernel(debian-sources or gentoo-sources are good), I think your boot failed because maybe older kernels need a more specific command line, try to change the command line, in the grub menu(F2 or 'c') to 'real_root=/dev/sda1 rootfstype=ext4' but you should really try a newer kernel, I wouldn't use anything bellow 3.4 these days.

Thx for the help :)

However, setting rootfstype=ext4 did not make a difference.

 

I was thinking of an older kernel as I was trying to reduce the compilation time + size, plus I did not need any new drivers and stuff for the VM install.

 

However, having failed at that, I will try a vanilla or gentoo kernel in the lower end of the 3.x series that is still being maintained.

Share this post


Link to post
Share on other sites

Seems more research is required in order to figure out how portage works, and how to configure and install the vanilla-sources.

 

Since I do not have much time currently, I will let it be and come back to it when I can.

Share this post


Link to post
Share on other sites

When you are at the situation of the 2nd thumbnail, have you tryed to impose /dev/sda1 then press enter ?

Nope I had not tried that..

 

Afterwards I had tried the vanilla-sources, but could not download that, then the gentoo-sources;

I was able to download the gentoo-sources and ready a config file, but did not compile it yet.

 

So I had decided to delete the debian-sources, and now I cannot check whether it works or not..

Thx anyway :)

Share this post


Link to post
Share on other sites

Nope I had not tried that..

 

Afterwards I had tried the vanilla-sources, but could not download that, then the gentoo-sources;

I was able to download the gentoo-sources and ready a config file, but did not compile it yet.

 

So I had decided to delete the debian-sources, and now I cannot check whether it works or not..

Thx anyway :)

How come you could download gentoo-sources but not vanilla the command is practically the same, was it something with ACCEPT_KEYWORDS? eselect is what you use to change the /usr/src/linux symlink 'eselect kernel [command]'.

 

Anyway have you considered running a funtoo container instead of running a full VM, considering the amount of compiling you'll be doing later, using a VM in your case(just trying a distro) will be slow and overhead, just to share some ideas, I also happen to run a funtoo vm to mess around with a web server and openrc, and for the compiling and initial setup, I used a loopback device on a raw disk image(made with dd), and created a chroot(I actually used systemd-nspawn) where I compiled and configured funtoo, then I configured and compiled a kernel for it, and used qemu to boot it, and run/test what I wanted, and I switch back to the chroot for upgrades.

Share this post


Link to post
Share on other sites

The error I was getting with the vanilla-sourcess was that it was asking for some extra parameters / arguments, I tried passing it the kernel version but that did not work.

 

Thx for the suggestion about running a Funtoo container, but I dont think I have that kind of expertise to run it via qemu and stuff :)

Share this post


Link to post
Share on other sites

Did you used funtoo stable? I checked the vanilla sources ebuilds, and all have KEYWORDS=~arch, so you might have needed to tell portage you wanted vanilla sources from current since there's no 'stable' version, that is adding 'sys-kernel/vanilla-sources ~amd64' or your ~arch, in /etc/portage/package.accept_keywords, create that file if you don't have it, in the portage(5) manual you will find out about all the files in /etc/portage and their use, but a when you are starting with funtoo you mostly will use package.use and package.accept_keywords, so I recommend you to read about those two files first.

Share this post


Link to post
Share on other sites

Did you used funtoo stable? I checked the vanilla sources ebuilds, and all have KEYWORDS=~arch, so you might have needed to tell portage you wanted vanilla sources from current since there's no 'stable' version, that is adding 'sys-kernel/vanilla-sources ~amd64' or your ~arch, in /etc/portage/package.accept_keywords, create that file if you don't have it, in the portage(5) manual you will find out about all the files in /etc/portage and their use, but a when you are starting with funtoo you mostly will use package.use and package.accept_keywords, so I recommend you to read about those two files first.

Yeah, I used funtoo stable. And I think the error was saying something about ~amd64, so you might have nailed it :)

 

I will have a look at the portage man page and the package.use and package.accept_keywords when I can, currently its bit of a hectic time for me.

 

Thx for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...