Jump to content
funtoo forums
aitikin

boot-update gives MBR when GPT

Recommended Posts

Trying to fix my Funtoo install and boot-update is giving the following output:

 

Quote

boot-update 1.8.2 /
Copyright 2009-2017 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

  * Generating config for grub...

            Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.8.15-1
  DEFAULT > Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.14.2-1
            memtest86+

  * NOTE: Detected MBR boot. Configuring for Legacy MBR booting.
  * WARN: multiple matches found for default "Funtoo Linux genkernel" - most recent used.
  * NOTE: Intel microcode will be loaded at boot-time.

  * Completed successfully with warnings.

now, normally I'd trust a utility, but I know this disk is a GPT and "gdisk -l /dev/sda" gives the following:

Quote

GPT fdisk (gdisk) version 1.0.3

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

 

So...is there a good solution here?  For the record, I'm in a chroot environment from an Ubuntu live USB.

Share this post


Link to post
Share on other sites

looks like a warning saying it found two kernels , should be fine

from boot.conf manual....

When using GRUB, boot-update will auto-enable UEFI boot configuration if it sees that your system has been booted in UEFI mode. Otherwise, MBR (legacy) boot mode will be used.

I guess ubuntu booted in legacy mode.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...