Jump to content
funtoo forums
  • 0
Sign in to follow this  

ICU flag conflict for chromium install


After the last sync there are new chromium builds available:

63.0.3230.0 and 63.0.3239.30

I tried to install 63.0.3230.0 but got the message 

"Known build break with gcc, see https://bugs.gentoo.org/633452 . Use clang as workaround."

Looking up that bug I found that chromium version 63.0.3239.30 is the fixed version. OK, trying to install that version gives me:

emerge: there are no ebuilds to satisfy ">=media-libs/harfbuzz-1.5.0:=[icu(-)]".
(dependency required by "www-client/chromium-63-0.3239.30::net-kit" [ebuild])

OK, no problem, added the -icu to package.use and tried again:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for details)
# required by app-office/libreoffice-
# required by libreoffice (argument)
>=media-libs/harfbuzz-1.4.6-r2 icu

So now I've got a new chromium version that requires harfbuzz without icu flag and libreoffice with it. How to solve that problem?

Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...