Jump to content
funtoo forums
  • 0
Sign in to follow this  
jhan

ICU flag conflict for chromium install

Question

After the last sync there are new chromium builds available:

63.0.3230.0 and 63.0.3239.30

I tried to install 63.0.3230.0 but got the message 

"Known build break with gcc, see https://bugs.gentoo.org/633452 . Use clang as workaround."

Looking up that bug I found that chromium version 63.0.3239.30 is the fixed version. OK, trying to install that version gives me:

emerge: there are no ebuilds to satisfy ">=media-libs/harfbuzz-1.5.0:=[icu(-)]".
(dependency required by "www-client/chromium-63-0.3239.30::net-kit" [ebuild])

OK, no problem, added the -icu to package.use and tried again:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for details)
# required by app-office/libreoffice-5.4.2.2::kde-kit
# required by libreoffice (argument)
>=media-libs/harfbuzz-1.4.6-r2 icu

So now I've got a new chromium version that requires harfbuzz without icu flag and libreoffice with it. How to solve that problem?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×